]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
28210d65ffb21602b117c7b469f1c777146b079e
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 %bcond_with     x       # Use the X Windows System
4 %bcond_without  cgi     # Disable Local CGI support
5 %bcond_without  ipv6    # Disable IPv6 Support
6 %bcond_without  led     # Disable LEDs
7 %bcond_without  256     # Disable 256 colors support
8 %bcond_without  lua     # Disable Lua scripting
9 #
10 Summary:        Experimantal Links (text WWW browser)
11 Summary(es):    El links es un browser para modo texto, similar a lynx
12 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
13 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
14 Name:           elinks
15 Version:        0.9.2
16 Release:        1
17 Epoch:          1
18 License:        GPL
19 Group:          Applications/Networking
20 #Source0Download:       http://elinks.or.cz/download.html
21 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
22 # Source0-md5:  2bd5f150ed91628bd2b64ad7d2d1edfd
23 # Source0-size: 1894301
24 Source1:        %{name}.desktop
25 Source2:        links.png
26 #Patch0:                %{name}-pl.po.patch
27 Patch1:         %{name}-home_etc.patch
28 Patch2:         %{name}-lua40.patch
29 Patch3:         %{name}-locale_names.patch
30 URL:            http://elinks.or.cz/
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  bzip2-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  gpm-devel
37 %{?with_lua:BuildRequires:      lua40-devel >= 4.0.1-9}
38 BuildRequires:  ncurses-devel => 5.1
39 BuildRequires:  openssl-devel >= 0.9.7d
40 BuildRequires:  tetex
41 BuildRequires:  zlib-devel
42 Provides:       webclient
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _sysconfdir     /etc/elinks
46 %define         specflags_ia32  -fomit-frame-pointer
47
48 %description
49 This is the elinks tree - intended to provide feature-rich version of
50 links, however not rock-stable and dedicated mainly for testing. Its
51 purpose is to make alternative to links, until Mikulas will have some
52 time to maintain it, and to test and tune various patches for Mikulas
53 to be able to include them in the official links releases.
54
55 %description -l es
56 Links es un browser WWW modo texto, similar al Lynx. El links muestra
57 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
58 keepalive.
59
60 %description -l pl
61 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
62 elinks jednak jest dedykowana g³ównie do testowania.
63
64 %description -l pt_BR
65 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
66 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
67 keepalive.
68
69 %prep
70 %setup -q
71 #%patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74 %patch3 -p1
75
76 mv -f po/{no,nb}.po
77
78 %build
79 %{__aclocal}
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83 %configure \
84 %{!?debug:      --enable-fastmem} \
85 %{?debug:       --enable-debug} \
86         %{!?with_ipv6:--disable-ipv6} \
87         %{!?with_lua:--without-lua} \
88         --with%{!?with_x:out}-x
89 %{?with_led:echo    '#define CONFIG_LEDS' >> feature.h}
90 %{?with_256:echo    '#define CONFIG_256_COLORS' >> feature.h}
91 %{?with_cgi:echo -e "#ifdef HAVE_SETENV\n\t#define CONFIG_CGI\n#endif" >> feature.h}
92 %{__make}
93
94 cd doc
95 texi2html elinks-lua.texi
96 cd ..
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT%{_desktopdir} \
101         $RPM_BUILD_ROOT%{_datadir}/%{name} \
102         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
108 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
109
110 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
111
112 %find_lang %{name}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files -f %{name}.lang
118 %defattr(644,root,root,755)
119 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
120 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
121 %doc contrib/conv/{*awk,*.pl,*.sh}
122 %doc doc/{*.txt,*.html}
123 %attr(755,root,root) %{_bindir}/*
124 %{_mandir}/man*/*
125 %{_desktopdir}/*
126 %{_pixmapsdir}/*
127 %{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
This page took 0.032884 seconds and 3 git commands to generate.