]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- without tsts bcond
[packages/elfutils.git] / elfutils.spec
1
2 %bcond_without tests    # do not perform tests
3
4 Summary:        A collection of utilities and DSOs to handle compiled objects
5 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
6 Name:           elfutils
7 Version:        0.94
8 Release:        1
9 License:        OSL 1.0 (http://www.opensource.org/licenses/osl.php)
10 Group:          Development/Tools
11 # http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/SRPMS/elfutils-0.94-2.1.src.rpm
12 Source0:        %{name}-%{version}.tar.gz
13 # Source0-md5:  de39e0af6b82b30d48e5d69b75aa2e0b
14 Patch0:         %{name}-pl.po.patch
15 Patch1:         %{name}-debian-manpages.patch
16 Patch2:         %{name}-alpha-stat.patch
17 Patch3:         %{name}-gcc34.patch
18 #URL:           file://home/devel/drepper
19 BuildRequires:  autoconf >= 2.54
20 BuildRequires:  automake >= 1.7
21 BuildRequires:  gcc >= 3.2
22 BuildRequires:  gettext-devel
23 BuildRequires:  libltdl-devel
24 BuildRequires:  perl-tools-pod
25 BuildRequires:  sharutils
26 Requires:       elfutils-libelf = %{version}-%{release}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _programprefix  eu-
30
31 %description
32 Elfutils is a collection of utilities, including ld (a linker), nm
33 (for listing symbols from object files), size (for listing the section
34 sizes of an object or archive file), strip (for discarding symbols),
35 readline (the see the raw ELF file structures), and elflint (to check
36 for well-formed ELF files). Also included are numerous helper
37 libraries which implement DWARF, ELF, and machine-specific ELF
38 handling.
39
40 %description -l pl
41 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
42 listowania symboli z plików obiektów), size (do listowania rozmiarów
43 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
44 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
45 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
46 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
47 specyficznych dla architektury.
48
49 %package devel
50 Summary:        Development part of libraries to handle compiled objects
51 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
52 Group:          Development/Libraries
53 Obsoletes:      libelf-devel
54 Requires:       elfutils = %{version}-%{release}
55
56 %description devel
57 The elfutils-devel package contains the development part of libraries
58 to create applications for handling compiled objects. libelf allows
59 you to access the internals of the ELF object file format, so you can
60 see the different sections of an ELF file. libebl provides some
61 higher-level ELF access functionality. libdwarf provides access to the
62 DWARF debugging information. libasm provides a programmable assembler
63 interface.
64
65 %description devel -l pl
66 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
67 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
68 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
69 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
70 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
71 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
72 udostêpnia programowalny interfejs asemblera.
73
74 %package libelf
75 Summary:        Library to read and write ELF files
76 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
77 Group:          Libraries
78 #Obsoletes:     libelf
79
80 %description libelf
81 The elfutils-libelf package provides a DSO which allows reading and
82 writing ELF files on a high level. Third party programs depend on this
83 package to read internals of ELF files. The programs of the elfutils
84 package use it also to generate new ELF files.
85
86 %description libelf -l pl
87 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
88 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
89 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
90 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
91
92 %package static
93 Summary:        Static libraries to handle compiled objects
94 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
95 Group:          Development/Libraries
96 Obsoletes:      libelf-static
97 Requires:       elfutils-devel = %{version}-%{release}
98
99 %description static
100 The elfutils-static package contains the static libraries to create
101 applications for handling compiled objects. libelf allows you to
102 access the internals of the ELF object file format, so you can see the
103 different sections of an ELF file. libebl provides some higher-level
104 ELF access functionality. libdwarf provides access to the DWARF
105 debugging information. libasm provides a programmable assembler
106 interface.
107
108 %description static -l pl
109 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
110 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
111 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
112 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
113 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
114 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
115 programowalny interfejs asemblera.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122 %patch3 -p1
123
124 %build
125 %{__gettextize}
126 %{__aclocal}
127 %{__autoheader}
128 %{__automake}
129 %{__autoconf}
130 %configure \
131         --program-prefix=%{_programprefix} \
132         --enable-shared
133
134 %{__make}
135 %{__make} -C debian/man
136 %{?with_tests:%{__make} -C tests check}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT%{_mandir}/man1
141
142 # *OBJEXT must be passed to workaround problem with messed gettext,
143 # which doesn't like *-po dir names
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT \
146         CATOBJEXT=.gmo INSTOBJEXT=.mo
147
148 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
149
150 %find_lang libelf
151 %find_lang libasm
152 %find_lang libdw
153 %find_lang libebl
154 %find_lang %{name}
155 cat libasm.lang libdw.lang libebl.lang >> %{name}.lang
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %post   libelf -p /sbin/ldconfig
164 %postun libelf -p /sbin/ldconfig
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc AUTHORS COPYING NEWS NOTES README THANKS TODO
169 %attr(755,root,root) %{_bindir}/*
170 %attr(755,root,root) %{_libdir}/libasm-*.so
171 %attr(755,root,root) %{_libdir}/libdw-*.so
172 %dir %{_libdir}/elfutils
173 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
174 %{_mandir}/man1/*.1*
175
176 %files devel
177 %defattr(644,root,root,755)
178 %doc doc/elfutils.sgml
179 %attr(755,root,root) %{_libdir}/libasm.so
180 %attr(755,root,root) %{_libdir}/libdw.so
181 %attr(755,root,root) %{_libdir}/libelf.so
182 %{_libdir}/libebl.a
183 %{_includedir}/*
184
185 %files libelf -f libelf.lang
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libelf-*.so
188
189 %files static
190 %defattr(644,root,root,755)
191 %{_libdir}/libasm.a
192 %{_libdir}/libdw.a
193 %{_libdir}/libelf.a
This page took 0.067118 seconds and 4 git commands to generate.