]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- added %zu type patch (gcc4)
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.116
9 Release:        1
10 License:        OSL 1.0 (http://www.opensource.org/licenses/osl.php)
11 Group:          Development/Tools
12 # http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/
13 # abuse systemtap to get .tar.gz directly
14 Source0:        ftp://sources.redhat.com/pub/systemtap/elfutils/%{name}-%{version}.tar.gz
15 # Source0-md5:  bfc77b2f448d8d7e0881bbb3196f3f5d
16 Patch0:         %{name}-pl.po.patch
17 Patch1:         %{name}-debian-manpages.patch
18 Patch2:         %{name}-portability.patch
19 Patch3:         %{name}-robustify.patch
20 Patch4:         %{name}-align.patch
21 Patch5:         %{name}-sh.patch
22 Patch6:         %{name}-paxflags.patch
23 Patch7:         %{name}-alpha.patch
24 Patch8:         %{name}-gcc4.patch
25 #URL:           file://home/devel/drepper
26 BuildRequires:  autoconf >= 2.59
27 BuildRequires:  automake >= 1:1.7
28 BuildRequires:  gcc >= 3.2
29 BuildRequires:  gettext-devel
30 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
31 # PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
32 # also needed for nanosecond timestamps on alpha
33 BuildRequires:  glibc-devel >= 6:2.3.4
34 %endif
35 BuildRequires:  libltdl-devel
36 BuildRequires:  perl-tools-pod
37 BuildRequires:  rpmbuild(macros) >= 1.213
38 BuildRequires:  sharutils
39 Requires:       %{name}-libelf = %{version}-%{release}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _programprefix  eu-
43
44 %description
45 Elfutils is a collection of utilities, including ld (a linker), nm
46 (for listing symbols from object files), size (for listing the section
47 sizes of an object or archive file), strip (for discarding symbols),
48 readline (the see the raw ELF file structures), and elflint (to check
49 for well-formed ELF files). Also included are numerous helper
50 libraries which implement DWARF, ELF, and machine-specific ELF
51 handling.
52
53 %description -l pl
54 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
55 listowania symboli z plików obiektów), size (do listowania rozmiarów
56 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
57 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
58 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
59 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
60 specyficznych dla architektury.
61
62 %package devel
63 Summary:        Development part of libraries to handle compiled objects
64 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Obsoletes:      libelf-devel
68
69 %description devel
70 The elfutils-devel package contains the development part of libraries
71 to create applications for handling compiled objects. libelf allows
72 you to access the internals of the ELF object file format, so you can
73 see the different sections of an ELF file. libebl provides some
74 higher-level ELF access functionality. libdwarf provides access to the
75 DWARF debugging information. libasm provides a programmable assembler
76 interface.
77
78 %description devel -l pl
79 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
80 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
81 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
82 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
83 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
84 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
85 udostêpnia programowalny interfejs asemblera.
86
87 %package libelf
88 Summary:        Library to read and write ELF files
89 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
90 Group:          Libraries
91 #Obsoletes:     libelf
92
93 %description libelf
94 The elfutils-libelf package provides a DSO which allows reading and
95 writing ELF files on a high level. Third party programs depend on this
96 package to read internals of ELF files. The programs of the elfutils
97 package use it also to generate new ELF files.
98
99 %description libelf -l pl
100 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
101 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
102 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
103 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
104
105 %package static
106 Summary:        Static libraries to handle compiled objects
107 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110 Obsoletes:      libelf-static
111
112 %description static
113 The elfutils-static package contains the static libraries to create
114 applications for handling compiled objects. libelf allows you to
115 access the internals of the ELF object file format, so you can see the
116 different sections of an ELF file. libebl provides some higher-level
117 ELF access functionality. libdwarf provides access to the DWARF
118 debugging information. libasm provides a programmable assembler
119 interface.
120
121 %description static -l pl
122 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
123 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
124 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
125 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
126 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
127 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
128 programowalny interfejs asemblera.
129
130 %prep
131 %setup -q
132 %patch0 -p1
133 %patch1 -p1
134 %patch2 -p1
135 %patch3 -p1
136 %patch4 -p1
137 %patch5 -p1
138 %patch6 -p1
139 %patch7 -p1
140 %patch8 -p1
141
142 %build
143 #%%{__gettextize}
144 %{__aclocal}
145 %{__autoheader}
146 %{__automake}
147 %{__autoconf}
148
149 %configure \
150         --program-prefix=%{_programprefix} \
151         --enable-shared
152
153 # make check depends on test-nlist not stripped
154 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
155
156 %{__make}
157 %{__make} -C debian/man
158 %if %{with tests}
159 # $ORIGIN used in RPATH needs /proc to work - workaround it using LD_LIBRARY_PATH;
160 # ../libelf is needed also to use proper libelf by ../src/elflint during tests
161 LD_LIBRARY_PATH=../libasm:../libdw:../libebl:../libelf \
162 %{__make} -C tests check
163 %endif
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
168
169 # *OBJEXT must be passed to workaround problem with messed gettext,
170 # which doesn't like *-po dir names
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT \
173         MKINSTALLDIRS=$(pwd)/config/mkinstalldirs \
174         CATOBJEXT=.gmo \
175         INSTOBJEXT=.mo
176
177 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
178
179 mv $RPM_BUILD_ROOT%{_libdir}/libelf-*.so $RPM_BUILD_ROOT/%{_lib}
180 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libelf-*.so) \
181         $RPM_BUILD_ROOT%{_libdir}/libelf.so
182
183 %find_lang libelf
184 %find_lang %{name}
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post   -p /sbin/ldconfig
190 %postun -p /sbin/ldconfig
191
192 %post   libelf -p /sbin/ldconfig
193 %postun libelf -p /sbin/ldconfig
194
195 %files -f %{name}.lang
196 %defattr(644,root,root,755)
197 %doc AUTHORS COPYING NEWS NOTES README THANKS TODO
198 %attr(755,root,root) %{_bindir}/*
199 %attr(755,root,root) %{_libdir}/libasm-*.so
200 %attr(755,root,root) %{_libdir}/libdw-*.so
201 %dir %{_libdir}/elfutils
202 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
203 %{_mandir}/man1/*.1*
204
205 %files devel
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/libasm.so
208 %attr(755,root,root) %{_libdir}/libdw.so
209 %attr(755,root,root) %{_libdir}/libelf.so
210 %{_libdir}/libebl.a
211 %{_includedir}/*
212
213 %files libelf -f libelf.lang
214 %defattr(644,root,root,755)
215 %attr(755,root,root) /%{_lib}/libelf-*.so
216
217 %files static
218 %defattr(644,root,root,755)
219 %{_libdir}/libasm.a
220 %{_libdir}/libdw.a
221 %{_libdir}/libelf.a
This page took 0.065676 seconds and 4 git commands to generate.