]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- Release: 4 (to build _and_tag_ for Ac)
[packages/elfutils.git] / elfutils.spec
1 Summary:        A collection of utilities and DSOs to handle compiled objects
2 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
3 Name:           elfutils
4 Version:        0.89
5 Release:        4
6 License:        OSL 1.0 (http://www.opensource.org/licenses/osl.php)
7 Group:          Development/Tools
8 # from ftp://download.fedora.redhat.com:/pub/fedora/linux/core/development/SRPMS/%{name}-%{version}-*.src.rpm
9 Source0:        %{name}-%{version}.tar.gz
10 # Source0-md5:  a690778e93e4b04eb531c6a3ef0ad23a
11 Patch0:         %{name}-pl.po.patch
12 Patch1:         %{name}-debian-manpages.patch
13 #URL:           file://home/devel/drepper
14 BuildRequires:  autoconf >= 2.54
15 BuildRequires:  automake >= 1.7
16 BuildRequires:  gcc >= 3.2
17 BuildRequires:  gettext-devel
18 BuildRequires:  libltdl-devel
19 BuildRequires:  perl-tools-pod
20 BuildRequires:  sharutils
21 Requires:       elfutils-libelf = %{version}-%{release}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _programprefix  eu-
25
26 %description
27 Elfutils is a collection of utilities, including ld (a linker), nm
28 (for listing symbols from object files), size (for listing the section
29 sizes of an object or archive file), strip (for discarding symbols),
30 readline (the see the raw ELF file structures), and elflint (to check
31 for well-formed ELF files). Also included are numerous helper
32 libraries which implement DWARF, ELF, and machine-specific ELF
33 handling.
34
35 %description -l pl
36 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
37 listowania symboli z plików obiektów), size (do listowania rozmiarów
38 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
39 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
40 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
41 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
42 specyficznych dla architektury.
43
44 %package devel
45 Summary:        Development part of libraries to handle compiled objects
46 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
47 Group:          Development/Libraries
48 Obsoletes:      libelf-devel
49 Requires:       elfutils = %{version}-%{release}
50
51 %description devel
52 The elfutils-devel package contains the development part of libraries
53 to create applications for handling compiled objects. libelf allows
54 you to access the internals of the ELF object file format, so you can
55 see the different sections of an ELF file. libebl provides some
56 higher-level ELF access functionality. libdwarf provides access to the
57 DWARF debugging information. libasm provides a programmable assembler
58 interface.
59
60 %description devel -l pl
61 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
62 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
63 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
64 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
65 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
66 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
67 udostêpnia programowalny interfejs asemblera.
68
69 %package libelf
70 Summary:        Library to read and write ELF files
71 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
72 Group:          Libraries
73 #Obsoletes:     libelf
74
75 %description libelf
76 The elfutils-libelf package provides a DSO which allows reading and
77 writing ELF files on a high level. Third party programs depend on this
78 package to read internals of ELF files. The programs of the elfutils
79 package use it also to generate new ELF files.
80
81 %description libelf -l pl
82 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
83 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
84 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
85 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
86
87 %package static
88 Summary:        Static libraries to handle compiled objects
89 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
90 Group:          Development/Libraries
91 Obsoletes:      libelf-static
92 Requires:       elfutils-devel = %{version}-%{release}
93
94 %description static
95 The elfutils-static package contains the static libraries to create
96 applications for handling compiled objects. libelf allows you to
97 access the internals of the ELF object file format, so you can see the
98 different sections of an ELF file. libebl provides some higher-level
99 ELF access functionality. libdwarf provides access to the DWARF
100 debugging information. libasm provides a programmable assembler
101 interface.
102
103 %description static -l pl
104 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
105 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
106 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
107 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
108 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
109 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
110 programowalny interfejs asemblera.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %patch1 -p1
116
117 %build
118 %{__gettextize}
119 %{__aclocal}
120 %{__autoheader}
121 %{__automake}
122 %{__autoconf}
123 %configure \
124         --program-prefix=%{_programprefix} \
125         --enable-shared
126
127 %{__make}
128
129 %{__make} -C debian/man
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT%{_mandir}/man1
134
135 # *OBJEXT must be passed to workaround problem with messed gettext,
136 # which doesn't like *-po dir names
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT \
139         CATOBJEXT=.gmo INSTOBJEXT=.mo
140
141 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
142
143 %find_lang libelf
144 %find_lang libasm
145 %find_lang libdwarf
146 %find_lang libebl
147 %find_lang %{name}
148 cat libasm.lang libdwarf.lang libebl.lang >> %{name}.lang
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %post   libelf -p /sbin/ldconfig
157 %postun libelf -p /sbin/ldconfig
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc AUTHORS COPYING NEWS NOTES README THANKS TODO
162 %attr(755,root,root) %{_bindir}/*
163 %attr(755,root,root) %{_libdir}/libasm-*.so
164 %attr(755,root,root) %{_libdir}/libdw-*.so
165 %attr(755,root,root) %{_libdir}/libdwarf-*.so
166 %dir %{_libdir}/elfutils
167 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
168 %{_mandir}/man1/*.1*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %doc libdwarf/AVAILABLE doc/elfutils.sgml
173 %attr(755,root,root) %{_libdir}/libasm.so
174 %attr(755,root,root) %{_libdir}/libdw.so
175 %attr(755,root,root) %{_libdir}/libdwarf.so
176 %attr(755,root,root) %{_libdir}/libelf.so
177 %{_libdir}/libebl.a
178 %{_includedir}/*
179
180 %files libelf -f libelf.lang
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libelf-*.so
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libasm.a
187 %{_libdir}/libdw.a
188 %{_libdir}/libdwarf.a
189 %{_libdir}/libelf.a
This page took 0.070856 seconds and 4 git commands to generate.