]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- BR: libltdl-devel
[packages/elfutils.git] / elfutils.spec
1 Summary:        A collection of utilities and DSOs to handle compiled objects
2 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
3 Name:           elfutils
4 Version:        0.76
5 Release:        7
6 License:        GPL
7 Group:          Development/Tools
8 Source0:        %{name}-%{version}.tar.gz
9 #URL:           file://home/devel/drepper
10 BuildRequires:  gcc >= 3.2
11 BuildRequires:  sharutils
12 BuildRequires:  libltdl-devel
13 Requires:       elfutils-libelf = %{version}-%{release}
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define _programprefix eu-
17
18 %description
19 Elfutils is a collection of utilities, including ld (a linker), nm
20 (for listing symbols from object files), size (for listing the section
21 sizes of an object or archive file), strip (for discarding symbols),
22 readline (the see the raw ELF file structures), and elflint (to check
23 for well-formed ELF files). Also included are numerous helper
24 libraries which implement DWARF, ELF, and machine-specific ELF
25 handling.
26
27 %description -l pl
28 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
29 listowania symboli z plików obiektów), size (do listowania rozmiarów
30 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
31 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
32 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
33 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
34 specyficznych dla architektury.
35
36 %package devel
37 Summary:        Development part of libraries to handle compiled objects
38 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
39 Group:          Development/Libraries
40 Obsoletes:      libelf-devel
41 Requires:       elfutils = %{version}-%{release}
42
43 %description devel
44 The elfutils-devel package contains the development part of libraries
45 to create applications for handling compiled objects. libelf allows
46 you to access the internals of the ELF object file format, so you can
47 see the different sections of an ELF file. libebl provides some
48 higher-level ELF access functionality. libdwarf provides access to the
49 DWARF debugging information. libasm provides a programmable assembler
50 interface.
51
52 %description devel -l pl
53 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
54 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
55 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
56 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
57 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
58 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
59 udostêpnia programowalny interfejs asemblera.
60
61 %package libelf
62 Summary:        Library to read and write ELF files
63 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
64 Group:          Libraries
65 Obsoletes:      libelf
66
67 %description libelf
68 The elfutils-libelf package provides a DSO which allows reading and
69 writing ELF files on a high level. Third party programs depend on this
70 package to read internals of ELF files. The programs of the elfutils
71 package use it also to generate new ELF files.
72
73 %description libelf -l pl
74 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
75 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
76 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
77 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
78
79 %package static
80 Summary:        Static libraries to handle compiled objects
81 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
82 Group:          Development/Libraries
83 Obsoletes:      libelf-static
84 Requires:       elfutils-devel = %{version}-%{release}
85
86 %description static
87 The elfutils-static package contains the static libraries to create
88 applications for handling compiled objects. libelf allows you to
89 access the internals of the ELF object file format, so you can see the
90 different sections of an ELF file. libebl provides some higher-level
91 ELF access functionality. libdwarf provides access to the DWARF
92 debugging information. libasm provides a programmable assembler
93 interface.
94
95 %description static -l pl
96 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
97 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
98 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
99 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
100 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
101 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
102 programowalny interfejs asemblera.
103
104 %prep
105 %setup -q
106
107 %build
108 %{__aclocal}
109 %{__autoheader}
110 %{__automake}
111 %{__autoconf}
112 %configure \
113         --program-prefix=%{_programprefix} \
114         --enable-shared
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d ${RPM_BUILD_ROOT}%{_prefix}
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
124 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
125
126 #%%check
127 #make check
128
129 %clean
130 rm -rf ${RPM_BUILD_ROOT}
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %post   libelf -p /sbin/ldconfig
136 %postun libelf -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc README TODO
141 %attr(755,root,root) %{_bindir}/*
142 %attr(755,root,root) %{_libdir}/lib*-*.so
143 %dir %{_libdir}/elfutils
144 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
145 %exclude %{_libdir}/libelf-*.so
146
147 %files devel
148 %defattr(644,root,root,755)
149 %doc libdwarf/AVAILABLE
150 %{_includedir}/*
151 %{_libdir}/lib*.so
152 %exclude %{_libdir}/lib*-*.so
153
154 %files libelf
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/libelf-*.so
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/lib*.a
This page took 0.060659 seconds and 4 git commands to generate.