]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- sh syntax fixes
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.108
9 Release:        3
10 License:        OSL 1.0 (http://www.opensource.org/licenses/osl.php)
11 Group:          Development/Tools
12 # http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/SRPMS/
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  fd318a634c8f67c7ac8a975f16965cc3
15 Patch0:         %{name}-pl.po.patch
16 Patch1:         %{name}-debian-manpages.patch
17 Patch2:         %{name}-portability.patch
18 Patch3:         %{name}-bswap.patch
19 Patch4:         %{name}-robustify.patch
20 Patch5:         %{name}-align.patch
21 #URL:           file://home/devel/drepper
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1:1.7
24 BuildRequires:  gcc >= 3.2
25 BuildRequires:  gettext-devel
26 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
27 # PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
28 # also needed for nanosecond timestamps on alpha
29 BuildRequires:  glibc-devel >= 6:2.3.4
30 %endif
31 BuildRequires:  libltdl-devel
32 BuildRequires:  perl-tools-pod
33 BuildRequires:  rpmbuild(macros) >= 1.213
34 BuildRequires:  sharutils
35 Requires:       %{name}-libelf = %{version}-%{release}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _programprefix  eu-
39
40 %description
41 Elfutils is a collection of utilities, including ld (a linker), nm
42 (for listing symbols from object files), size (for listing the section
43 sizes of an object or archive file), strip (for discarding symbols),
44 readline (the see the raw ELF file structures), and elflint (to check
45 for well-formed ELF files). Also included are numerous helper
46 libraries which implement DWARF, ELF, and machine-specific ELF
47 handling.
48
49 %description -l pl
50 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
51 listowania symboli z plików obiektów), size (do listowania rozmiarów
52 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
53 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
54 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
55 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
56 specyficznych dla architektury.
57
58 %package devel
59 Summary:        Development part of libraries to handle compiled objects
60 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Obsoletes:      libelf-devel
64
65 %description devel
66 The elfutils-devel package contains the development part of libraries
67 to create applications for handling compiled objects. libelf allows
68 you to access the internals of the ELF object file format, so you can
69 see the different sections of an ELF file. libebl provides some
70 higher-level ELF access functionality. libdwarf provides access to the
71 DWARF debugging information. libasm provides a programmable assembler
72 interface.
73
74 %description devel -l pl
75 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
76 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
77 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
78 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
79 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
80 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
81 udostêpnia programowalny interfejs asemblera.
82
83 %package libelf
84 Summary:        Library to read and write ELF files
85 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
86 Group:          Libraries
87 #Obsoletes:     libelf
88
89 %description libelf
90 The elfutils-libelf package provides a DSO which allows reading and
91 writing ELF files on a high level. Third party programs depend on this
92 package to read internals of ELF files. The programs of the elfutils
93 package use it also to generate new ELF files.
94
95 %description libelf -l pl
96 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
97 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
98 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
99 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
100
101 %package static
102 Summary:        Static libraries to handle compiled objects
103 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106 Obsoletes:      libelf-static
107
108 %description static
109 The elfutils-static package contains the static libraries to create
110 applications for handling compiled objects. libelf allows you to
111 access the internals of the ELF object file format, so you can see the
112 different sections of an ELF file. libebl provides some higher-level
113 ELF access functionality. libdwarf provides access to the DWARF
114 debugging information. libasm provides a programmable assembler
115 interface.
116
117 %description static -l pl
118 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
119 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
120 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
121 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
122 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
123 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
124 programowalny interfejs asemblera.
125
126 %prep
127 %setup -q
128 %patch0 -p1
129 %patch1 -p1
130 %patch2 -p1
131 %patch3 -p1
132 %patch4 -p1
133 %patch5 -p1
134
135 %build
136 #%%{__gettextize}
137 %{__aclocal}
138 %{__autoheader}
139 %{__automake}
140 %{__autoconf}
141
142 %configure \
143         --program-prefix=%{_programprefix} \
144         --enable-shared
145
146 # make check depends on test-nlist not stripped
147 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
148
149 %{__make}
150 %{__make} -C debian/man
151 %if %{with tests}
152 # $ORIGIN used in RPATH needs /proc to work - workaround it using LD_LIBRARY_PATH;
153 # ../libelf is needed also to use proper libelf by ../src/elflint during tests
154 LD_LIBRARY_PATH=../libasm:../libdw:../libebl:../libelf \
155 %{__make} -C tests check
156 %endif
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
161
162 # *OBJEXT must be passed to workaround problem with messed gettext,
163 # which doesn't like *-po dir names
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT \
166         MKINSTALLDIRS=$(pwd)/config/mkinstalldirs \
167         CATOBJEXT=.gmo \
168         INSTOBJEXT=.mo
169
170 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
171
172 mv $RPM_BUILD_ROOT%{_libdir}/libelf-*.so $RPM_BUILD_ROOT/%{_lib}
173 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libelf-*.so) \
174         $RPM_BUILD_ROOT%{_libdir}/libelf.so
175
176 %find_lang libelf
177 %find_lang %{name}
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post   -p /sbin/ldconfig
183 %postun -p /sbin/ldconfig
184
185 %post   libelf -p /sbin/ldconfig
186 %postun libelf -p /sbin/ldconfig
187
188 %files -f %{name}.lang
189 %defattr(644,root,root,755)
190 %doc AUTHORS COPYING NEWS NOTES README THANKS TODO
191 %attr(755,root,root) %{_bindir}/*
192 %attr(755,root,root) %{_libdir}/libasm-*.so
193 %attr(755,root,root) %{_libdir}/libdw-*.so
194 %dir %{_libdir}/elfutils
195 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
196 %{_mandir}/man1/*.1*
197
198 %files devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libasm.so
201 %attr(755,root,root) %{_libdir}/libdw.so
202 %attr(755,root,root) %{_libdir}/libelf.so
203 %{_libdir}/libebl.a
204 %{_includedir}/*
205
206 %files libelf -f libelf.lang
207 %defattr(644,root,root,755)
208 %attr(755,root,root) /%{_lib}/libelf-*.so
209
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/libasm.a
213 %{_libdir}/libdw.a
214 %{_libdir}/libelf.a
This page took 0.040174 seconds and 3 git commands to generate.