]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
12fa64fd755a89502ad4f86848e8c1ad538346b5
[packages/elfutils.git] / elfutils.spec
1 Summary:        A collection of utilities and DSOs to handle compiled objects.
2 Name:           elfutils
3 Version:        0.76
4 Release:        7
5 License:        GPL
6 Group:          Development/Tools
7 #URL: file://home/devel/drepper
8 Source0:        %{name}-%{version}.tar.gz
9 Requires:       elfutils-libelf = %{version}-%{release}
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11 BuildRequires:  gcc >= 3.2
12 BuildRequires:  sharutils
13
14 %define _programprefix eu-
15
16 %description
17 Elfutils is a collection of utilities, including ld (a linker), nm
18 (for listing symbols from object files), size (for listing the section
19 sizes of an object or archive file), strip (for discarding symbols),
20 readline (the see the raw ELF file structures), and elflint (to check
21 for well-formed ELF files). Also included are numerous helper
22 libraries which implement DWARF, ELF, and machine-specific ELF
23 handling.
24
25 %package devel
26 Summary:        Development libraries to handle compiled objects.
27 Group:          Development/Tools
28 Obsoletes:      libelf-devel
29 Requires:       elfutils = %{version}-%{release}
30
31 %description devel
32 The elfutils-devel package contains the libraries to create
33 applications for handling compiled objects. libelf allows you to
34 access the internals of the ELF object file format, so you can see the
35 different sections of an ELF file. libebl provides some higher-level
36 ELF access functionality. libdwarf provides access to the DWARF
37 debugging information. libasm provides a programmable assembler
38 interface.
39
40 %package libelf
41 Summary:        Library to read and write ELF files.
42 Group:          Development/Tools
43 Obsoletes:      libelf
44
45 %description libelf
46 The elfutils-libelf package provides a DSO which allows reading and
47 writing ELF files on a high level. Third party programs depend on this
48 package to read internals of ELF files. The programs of the elfutils
49 package use it also to generate new ELF files.
50
51 %package static
52 Summary:        Development libraries to handle compiled objects - static.
53 Group:          Development/Tools
54 Obsoletes:      libelf-static
55 Requires:       elfutils-devel = %{version}-%{release}
56
57 %description static
58 The elfutils-static package contains the static libraries to create
59 applications for handling compiled objects. libelf allows you to
60 access the internals of the ELF object file format, so you can see the
61 different sections of an ELF file. libebl provides some higher-level
62 ELF access functionality. libdwarf provides access to the DWARF
63 debugging information. libasm provides a programmable assembler
64 interface.
65
66
67 %prep
68 %setup -q
69
70 %build
71 %{__aclocal}
72 %{__autoheader}
73 %{__automake}
74 %{__autoconf}
75 %configure \
76    --program-prefix=%{_programprefix} \
77    --enable-shared
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d ${RPM_BUILD_ROOT}%{_prefix}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
87 chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
88
89 #%%check
90 #make check
91
92 %clean
93 rm -rf ${RPM_BUILD_ROOT}
94
95 %post -p /sbin/ldconfig
96
97 %postun -p /sbin/ldconfig
98
99 %post libelf -p /sbin/ldconfig
100
101 %postun libelf -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc README TODO
106 %attr(755,root,root) %{_bindir}/*
107 %attr(755,root,root) %{_libdir}/lib*-*.so
108 %dir %{_libdir}/elfutils
109 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
110 %exclude %{_libdir}/libelf-*.so
111
112 %files devel
113 %defattr(644,root,root,755)
114 %doc libdwarf/AVAILABLE
115 %{_includedir}/*
116 %{_libdir}/lib*.so
117 %exclude %{_libdir}/lib*-*.so
118
119 %files libelf
120 %defattr(644,root,root,755)
121 %{_libdir}/libelf-*.so
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/lib*.a
This page took 1.363821 seconds and 3 git commands to generate.