]> git.pld-linux.org Git - packages/ekg2.git/blob - ekg2.spec
83ba80c75b876a1a4b5d454b94f8a688aba0aaa3
[packages/ekg2.git] / ekg2.spec
1 #
2 # Conditional build:
3 %bcond_with     yesterday_snapshot      # Build most current ekg2 snapshot
4                                         # (must use ./builder -n5 or plain rpmbuild)
5 %bcond_without  aspell                  # Don't build in spell-checking support with aspell
6 %bcond_without  xosd                    # Don't build xosd plugin
7 %bcond_with     ioctl_daemon            # With (suid-root) ioctl daemon
8
9 %if %{with yesterday_snapshot}
10 %define         _snap %(date +%%Y%%m%%d -d yesterday)
11 %else
12 %define         _snap 20041110
13 %endif
14
15 Summary:        A client compatible with Gadu-Gadu
16 Summary(de):    Einen client kompatibel zu Gadu-Gadu
17 Summary(it):    Esperimentale cliente di Gadu-Gadu
18 Summary(pl):    Eksperymentalny Klient Gadu-Gadu
19 Name:           ekg2
20 Version:        2.0
21 Release:        0.%{_snap}.1
22 License:        GPL v2+
23 Group:          Applications/Communications
24 Source0:        http://www.ekg2.org/archive/%{name}-%{_snap}.tar.gz
25 # Source0-md5:  172ba865b4f77265b68a4bf62d74812e
26 URL:            http://www.ekg2.org/
27 %{?with_aspell:BuildRequires:   aspell-devel}
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  expat-devel
31 BuildRequires:  gettext-devel
32 BuildRequires:  gnutls-devel >= 1.0.0
33 BuildRequires:  gpm-devel
34 BuildRequires:  libgadu-devel
35 BuildRequires:  libgsm-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libltdl-devel
38 BuildRequires:  libtool
39 BuildRequires:  ncurses-devel
40 BuildRequires:  openssl-devel >= 0.9.7d
41 %{?with_xosd:BuildRequires:     xosd-devel}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 A client compatible with Gadu-Gadu and Jabber.
46
47 %description -l de
48 Einen client kompatibel zu Gadu-Gadu und Jabber.
49
50 %description -l it
51 Esperimentale cliente di Gadu-Gadu.
52
53 %description -l pl
54 Eksperymentalny Klient Gadu-Gadu. W wersji drugiej obs³uguje zarówno
55 Gadu-Gadu jak i Jabbera. Planowana tak¿e obs³uga ICQ.
56
57 %prep
58 %setup -q -n %{name}-%{_snap}
59
60 sed -i -e 's/AC_LIBLTDL_CONVENIENCE/AC_LIBLTDL_INSTALLABLE/' configure.ac
61
62 %build
63 %{__libtoolize} --ltdl
64 cd libltdl
65 %{__aclocal}
66 %{__autoconf}
67 %{__autoheader}
68 %{__automake}
69 cd ..
70 %{__aclocal} -I m4
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure \
75         --with%{!?with_aspell:out}-aspell \
76         --with%{!?with_xosd:out}-xosd
77         
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85 %{!?with_ioctl_daemon:rm $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/ioctld.*}
86
87 rm -rf docs/{CVS,.cvsignore,Makefile*}
88 mv -f README README-main
89
90 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
91
92 %find_lang %{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %doc NEWS* README-main docs/*
100 %attr(755,root,root) %{_bindir}/*
101 %dir %{_libdir}/%{name}
102 %dir %{_libdir}/%{name}/plugins
103 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
104 %{?with_ioctl_daemon:%attr(4755,root,root) %{_libdir}/ioctld}
105 %{_datadir}/%{name}
This page took 0.513435 seconds and 2 git commands to generate.