]> git.pld-linux.org Git - packages/ekg2.git/blob - ekg2.spec
1f5406e94fd4e66c33b5d58878cd48837ff18313
[packages/ekg2.git] / ekg2.spec
1 #
2 # Conditional build:
3 %bcond_with     yesterday_snapshot      # Build most current ekg2 snapshot
4                                         # (must use ./builder -n5 or plain rpmbuild)
5 %bcond_with     aspell                  # Build in spell-checking support with aspell
6                                         # (currently leaks memory)
7 %bcond_with     ioctl_daemon            # with (suid-root) ioctl daemon
8 #
9 %if %{with yesterday_snapshot}
10 %define         _snap %(date +%%Y%%m%%d -d yesterday)
11 %else
12 %define         _snap 20040706
13 %endif
14
15 Summary:        A client compatible with Gadu-Gadu
16 Summary(de):    Einen client kompatibel zu Gadu-Gadu
17 Summary(it):    Esperimentale cliente di Gadu-Gadu
18 Summary(pl):    Eksperymentalny Klient Gadu-Gadu
19 Name:           ekg2
20 Version:        2.0
21 Release:        0.%{_snap}.1
22 License:        GPL v2+
23 Group:          Applications/Communications
24 Source0:        http://www.ekg2.org/archive/%{name}-%{_snap}.tar.gz
25 # Source0-md5:  94136ee525ad5a5becce4e40f639f9d0
26 URL:            http://www.ekg2.org/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  libgadu-devel
30 BuildRequires:  libtool
31 BuildRequires:  libltdl-devel
32 BuildRequires:  libgsm-devel
33 BuildRequires:  ncurses-devel
34 BuildRequires:  openssl-devel >= 0.9.7d
35 %if %{with aspell}
36 BuildRequires:  aspell-devel
37 %endif
38 BuildRequires:  gpm-devel
39 BuildRequires:  gnutls-devel
40 BuildRequires:  expat-devel
41 BuildRequires:  libjpeg-devel
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 A client compatible with Gadu-Gadu and Jabber.
46
47 %description -l de
48 Einen client kompatibel zu Gadu-Gadu und Jabber.
49
50 %description -l it
51 Esperimentale cliente di Gadu-Gadu.
52
53 %description -l pl
54 Eksperymentalny Klient Gadu-Gadu. W wersji 2.0 obs³uguje zarówno
55 Gadu-Gadu jak i Jabbera. Planowana tak¿e obs³uga ICQ.
56
57 %prep
58 %setup -q -n %{name}-%{_snap}
59
60 %build
61 %{__libtoolize} --ltdl
62 %{__aclocal} -I m4
63 %{__autoconf}
64 %{__autoheader}
65 %{__automake}
66 %configure \
67         --with%{!?with_aspell:out}-aspell
68 echo '#define HAVE_GNUTLS 1' >> ekg2-config.h # KLUDGE, wait for autoconf update
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 rm -rf docs/{CVS,.cvsignore,Makefile*}
78 mv -f README README-main
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc NEWS* README-main docs/*
86 %attr(755,root,root) %{_bindir}/*
87 %dir %{_libdir}/ekg2
88 %dir %{_libdir}/ekg2/plugins
89 %attr(755,root,root) %{_libdir}/ekg2/plugins/*.so
90 %{?with_ioctl_daemon:%attr(4755,root,root) %{_libdir}/ioctld}
This page took 0.059417 seconds and 3 git commands to generate.