]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
- Version 1.0; Release 3.%%{_snapshot}.1; Epoch 3
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 # _with_ioctl_daemon    - with ioctl_daemon (suid-root!)
4 # _with_python          - with python support
5 # _with_voip            - with voip support (libgsm)
6 #
7
8 %define         snapshot 20030521
9
10 Summary:        A client compatible with Gadu-Gadu
11 Summary(de):    Einen client kompatibel zu Gadu-Gadu
12 Summary(it):    Esperimentale cliente di Gadu-Gadu
13 Summary(pl):    Eksperymentalny Klient Gadu-Gadu
14 Name:           ekg
15 Version:        1.0
16 Release:        3.%{snapshot}.1
17 Epoch:          3
18 License:        GPL
19 Group:          Applications/Communications
20 Source0:        http://dev.null.pl/ekg/%{name}-%{snapshot}.tar.gz
21 # Source0-md5: 7050263dc0b5446bf8abf6ec32eebacc
22 Source1:        %{name}.conf
23 URL:            http://dev.null.pl/ekg/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 %{?_with_voip:BuildRequires: libgsm-devel}
27 BuildRequires:  ncurses-devel
28 BuildRequires:  openssl-devel >= 0.9.7
29 BuildRequires:  %{_bindir}/perl
30 %{?_with_python:BuildRequires: python-devel}
31 BuildRequires:  readline-devel
32 BuildRequires:  zlib-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 A client compatible with Gadu-Gadu.
37
38 %description -l de
39 Einen client kompatibel zu Gadu-Gadu.
40
41 %description -l it
42 Esperimentale cliente di Gadu-Gadu.
43
44 %description -l pl
45 Eksperymentalny Klient Gadu-Gadu.
46
47 %package -n libgadu
48 Summary:        libgadu library
49 Summary(pl):    Biblioteka libgadu
50 Group:          Libraries
51 Obsoletes:      libgg
52 License:        LGPL
53
54 %description -n libgadu
55 libgadu is intended to make it easy to add Gadu-Gadu communication
56 support to your software.
57
58 %description -n libgadu -l de
59 Mit libgadu ist es Ihnen möglich auf einfache Weise Gadu-Gadu
60 Kommunikations-Unterstützung in Ihre Software einzubinden.
61
62 %description -n libgadu -l pl
63 libgadu umo¿liwia ³atwe dodanie do ró¿nych aplikacji komunikacji
64 bazuj±cej na protokole Gadu-Gadu.
65
66 %package -n libgadu-devel
67 Summary:        libgadu library development
68 Summary(pl):    Czê¶æ biblioteki libgadu dla programistów
69 Group:          Development/Libraries
70 Requires:       libgadu = %{version}
71 Obsoletes:      libgg-devel
72 License:        LGPL
73
74 %description -n libgadu-devel
75 The libgadu-devel package contains the header files and some
76 documentation needed to develop application with libgadu.
77
78 %description -n libgadu-devel -l de
79 Das libgadu-devel Paket enthält Header-Files (Kopfzeilenordner) und
80 die Dokumentation die Sie benötigen um mit libgadu Anwendungen zu
81 entwickeln.
82
83 %description -n libgadu-devel -l pl
84 Pakiet libgadu-devel zawiera pliki nag³ówkowe i dokumentacjê,
85 potrzebne do kompilowania aplikacji korzystaj±cych z libgadu.
86
87 %package -n libgadu-static
88 Summary:        Static libgadu Library
89 Summary(pl):    Statyczna biblioteka libgadu
90 Group:          Development/Libraries
91 Requires:       libgadu-devel = %{version}
92 Obsoletes:      libgg-static
93 License:        LGPL
94
95 %description -n libgadu-static
96 Static libgadu library.
97
98 %description -n libgadu-static -l de
99 Statisches libgadu Archiv.
100
101 %description -n libgadu-static -l pl
102 Statyczna biblioteka libgadu.
103
104 %prep
105 %setup -q -n %{name}-%{snapshot}
106
107 %build
108 %{__aclocal}
109 %{__autoheader}
110 %{__autoconf}
111 %configure \
112         --enable-shared \
113         --enable-static \
114         --with-pthread \
115         %{?_with_python:--with-python} \
116         %{?_with_voip:--with-libgsm} \
117         %{?!_with_ioctl_daemon:--disable-ioctld}
118 %{__make}
119
120 %if %{?_with_ioctl_daemon:1}0
121 cd src 
122 %{__make} ioctld
123 cd ..
124 %endif
125
126 cd docs/api
127 ./make.pl
128 cd ..
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT%{_sysconfdir}
133
134 %{__make} install install-ekl2 DESTDIR=$RPM_BUILD_ROOT
135
136 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/
137
138 # For libgadu-devel
139
140 rm examples/Makefile examples/Makefile.in examples/.cvsignore
141
142 %if %{?_with_ioctl_daemon:1}%{?!_with_ioctl_daemon:0}
143 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
144 %endif
145
146 cd $RPM_BUILD_ROOT%{_libdir}
147 ln -sf libgadu.so.*.* libgadu.so
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -n libgadu -p /sbin/ldconfig
153 %postun -n libgadu -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
158 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
159 %attr(755,root,root) %{_bindir}/e*
160 %{?_with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
161 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*.conf
162 %{_datadir}/ekg
163 %{_mandir}/man1/*
164 %lang(pl) %{_mandir}/pl/man1/*
165
166 %files -n libgadu
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libgadu.so.*.*
169
170 %files -n libgadu-devel
171 %defattr(644,root,root,755)
172 %doc docs/{7thguard,api,ui,devel-hints,przenosny-kod}.txt docs/protocol.html docs/api/{functions,index,types}.html
173 %doc ChangeLog docs/{README,TODO} examples
174 %{_libdir}/libgadu.so
175 %{_includedir}/libgadu.h
176 %{_includedir}/libgadu-config.h
177 %{_pkgconfigdir}/*
178
179 %files -n libgadu-static
180 %defattr(644,root,root,755)
181 %attr(644,root,root) %{_libdir}/libgadu.a
This page took 0.481268 seconds and 4 git commands to generate.