]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
-added yesterday_snapshot (patch made by Adam Mikuta)
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_with     yesterday_snapshot      # Build most current ekg snapshot
4                                         # (must use ./builder -n5 or plain rpmbuild)
5
6 %bcond_without  aspell          # without spell checking
7 %bcond_without  voip            # without VoIP support
8 %bcond_without  python          # with python support
9 %bcond_without  pthread         # build with Posix threads support
10 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
11 #
12 %if %{with yesterday_snapshot}
13 %define         _snap %(date +%%Y%%m%%d -d yesterday)
14 %else
15 %define         _pre    rc1
16 %endif
17
18 #
19 Summary:        A client compatible with Gadu-Gadu
20 Summary(de):    Ein Cliente kompatibel mit Gadu-Gadu
21 Summary(es):    Un cliente compatible con Gadu-Gadu
22 Summary(it):    Un cliente compatibile con Gadu-Gadu
23 Summary(pl):    Klient kompatybilny z Gadu-Gadu
24 Name:           ekg
25 Version:        1.6
26 %if %{with yesterday_snapshot} 
27 Release:        0.%{_snap}.1
28 %else   
29 Release:        0.%{_pre}.1
30 %endif 
31 Epoch:          4
32 License:        GPL v2
33 Group:          Applications/Communications
34 %if %{with yesterday_snapshot} 
35 Source0:        http://dev.null.pl/ekg/%{name}-%{_snap}.tar.gz 
36 %else 
37 Source0:        http://dev.null.pl/ekg/%{name}-1.6%{_pre}.tar.gz
38 %endif 
39 # Source0-md5:  bce21bd6e896b71266afc30004f27402
40 Source1:        %{name}.conf
41 URL:            http://dev.null.pl/ekg/
42 %{?with_aspell:BuildRequires:   aspell-devel}
43 BuildRequires:  autoconf
44 BuildRequires:  automake
45 %{?with_voip:BuildRequires:     libgsm-devel}
46 BuildRequires:  libjpeg-devel
47 BuildRequires:  ncurses-devel
48 BuildRequires:  openssl-devel >= 0.9.7d
49 BuildRequires:  %{_bindir}/perl
50 %if %{with python}
51 BuildRequires:  python
52 BuildRequires:  python-devel
53 %endif
54 BuildRequires:  readline-devel
55 BuildRequires:  zlib-devel
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
60 client for UNIX systems. Gadu-Gadu is an instant messaging program,
61 very popular in Poland.
62
63 EKG features include:
64   - irssi-like ncurses interface
65   - sending and receiving files
66   - voice conversations
67   - launching shell commands on certain events
68   - reading input from pipe
69   - python scripting support
70   - speech synthesis (using an external program)
71   - encryption support
72
73 Please note that the program is not internationalized and all messages
74 are in Polish (although the commands are in English). 
75
76 %description -l de
77 Ein Cliente kompatibel mit Gadu-Gadu.
78
79 %description -l es
80 Un cliente compatible con Gadu-Gadu.
81
82 %description -l it
83 Un cliente compatibile con Gadu-Gadu.
84
85 %description -l pl
86 EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
87 klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
88 polsce komunikator internetowy.
89
90 Mo¿liwo¶ci EKG:
91   - interfejs u¿ytkownika podobny do irssi,
92   - wysy³anie i odbieranie plików,
93   - rozmowy g³osowe,
94   - uruchamianie poleceñ pow³oki w okre¶lonych sytuacjach,
95   - wczytywanie wej¶cia z potoku,
96   - wsparcie dla skryptów w jêzyku Python,
97   - synteza mowy (z u¿yciem zewnêtrznego programu),
98   - wsparcie dla szyfrowania.
99
100 Program nie jest umiêdzynarodowiony i wszystkie komunikaty s± po
101 polsku (jednak komendy s± w jêzyku angielskim).
102
103 %package -n libgadu
104 Summary:        libgadu library
105 Summary(es):    Biblioteca libgadu
106 Summary(pl):    Biblioteka libgadu
107 License:        LGPL v2.1
108 Group:          Libraries
109 Obsoletes:      libgg
110
111 %description -n libgadu
112 libgadu is intended to make it easy to add Gadu-Gadu communication
113 support to your software.
114
115 %description -n libgadu -l de
116 Mit libgadu ist es Ihnen möglich auf einfache Weise Gadu-Gadu
117 Kommunikations-Unterstützung in Ihre Software einzubinden.
118
119 %description -n libgadu -l es
120 libgadu está pensada para facilitar añadirle comunicación vía
121 Gadu-Gadu a su software.
122
123 %description -n libgadu -l pl
124 libgadu umo¿liwia ³atwe dodanie do ró¿nych aplikacji komunikacji
125 bazuj±cej na protokole Gadu-Gadu.
126
127 %package -n libgadu-devel
128 Summary:        libgadu development library
129 Summary(es):    Biblioteca de desarrollo de libgadu
130 Summary(pl):    Czê¶æ biblioteki libgadu dla programistów
131 License:        LGPL v2.1
132 Group:          Development/Libraries
133 Requires:       libgadu = %{epoch}:%{version}-%{release}
134 Requires:       openssl-devel
135 Obsoletes:      libgg-devel
136
137 %description -n libgadu-devel
138 The libgadu-devel package contains the header files and some
139 documentation needed to develop application with libgadu.
140
141 %description -n libgadu-devel -l de
142 Das libgadu-devel Paket enthält Header-Files (Kopfzeilenordner) und
143 die Dokumentation die Sie benötigen um mit libgadu Anwendungen zu
144 entwickeln.
145
146 %description -n libgadu-devel -l es
147 El paquete libgadu-devel contiene los ficheros de cabecera, juntos con
148 una documentación, necesarios para desarrollar aplicaciones que usar
149 libgadu.
150
151 %description -n libgadu-devel -l pl
152 Pakiet libgadu-devel zawiera pliki nag³ówkowe i dokumentacjê,
153 potrzebne do kompilowania aplikacji korzystaj±cych z libgadu.
154
155 %package -n libgadu-static
156 Summary:        Static libgadu library
157 Summary(es):    Biblioteca libgadu estática
158 Summary(pl):    Statyczna biblioteka libgadu
159 License:        LGPL v2.1
160 Group:          Development/Libraries
161 Requires:       libgadu-devel = %{epoch}:%{version}-%{release}
162 Obsoletes:      libgg-static
163
164 %description -n libgadu-static
165 Static libgadu library.
166
167 %description -n libgadu-static -l de
168 Statisches libgadu Archiv.
169
170 %description -n libgadu-static -l es
171 Biblioteca libgadu estática.
172
173 %description -n libgadu-static -l pl
174 Statyczna biblioteka libgadu.
175
176 %prep
177 %if %{with yesterday_snapshot}
178 %setup -q -n %{name}-%{_snap}
179 %else
180 %setup -q -n %{name}-%{version}%{_pre}
181 %endif
182
183
184 %build
185 rm -f missing
186 %{__aclocal} -I m4
187 %{__autoheader}
188 %{__autoconf}
189 %configure \
190         --enable-shared \
191         --enable-static \
192 %if %{with pthread}
193         --with-pthread \
194 %else
195         --without-pthread \
196 %endif
197         --without-bind \
198         %{?with_python:--with-python} \
199         %{!?with_voip:--without-libgsm} \
200         %{?with_aspell:--enable-aspell} \
201         %{?with_ioctl_daemon:--enable-ioctld}
202
203 %{__make} \
204         CC="%{__cc} %{rpmcflags} -Wall -I%{_includedir}/ncurses"
205
206 %if %{with ioctl_daemon}
207 %{__make} -C src ioctld
208 %endif
209
210 %install
211 rm -rf $RPM_BUILD_ROOT
212 install -d $RPM_BUILD_ROOT%{_sysconfdir}
213
214 %{__make} install install-ekl2 \
215         DESTDIR=$RPM_BUILD_ROOT
216
217 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
218
219 # For libgadu-devel
220
221 rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
222 rm -rf examples/CVS
223
224 install -d $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
225 cp -af examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
226
227 %if %{with ioctl_daemon}
228 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
229 %endif
230
231 cd $RPM_BUILD_ROOT%{_libdir}
232 ln -sf libgadu.so.*.* libgadu.so
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %post   -n libgadu -p /sbin/ldconfig
238 %postun -n libgadu -p /sbin/ldconfig
239
240 %files
241 %defattr(644,root,root,755)
242 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
243 %{?with_aspell:%doc docs/slownik.txt}
244 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
245 %attr(755,root,root) %{_bindir}/e*
246 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
247 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*.conf
248 %{_datadir}/ekg
249 %{_mandir}/man1/*
250 %lang(pl) %{_mandir}/pl/man1/*
251
252 %files -n libgadu
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_libdir}/libgadu.so.*.*
255
256 %files -n libgadu-devel
257 %defattr(644,root,root,755)
258 %doc docs/{7thguard,ui,devel-hints,przenosny-kod}.txt docs/protocol.html
259 %doc ChangeLog docs/{README,TODO}
260 %attr(755,root,root) %{_libdir}/libgadu.so
261 %{_includedir}/libgadu.h
262 %{_includedir}/libgadu-config.h
263 %{_pkgconfigdir}/*
264 %{_examplesdir}/libgadu-%{version}
265
266 %files -n libgadu-static
267 %defattr(644,root,root,755)
268 %{_libdir}/libgadu.a
This page took 0.044571 seconds and 4 git commands to generate.