]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
- little cleanup
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_without  aspell          # without spell checking
4 %bcond_without  voip            # without VoIP support
5 %bcond_with     python          # with python support
6 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
7 #
8 %define snap    20040628
9
10 Summary:        A client compatible with Gadu-Gadu
11 Summary(de):    Ein Cliente kompatibel mit Gadu-Gadu
12 Summary(es):    Un cliente compatible con Gadu-Gadu
13 Summary(it):    Un cliente compatibile con Gadu-Gadu
14 Summary(pl):    Klient kompatybilny z Gadu-Gadu
15 Name:           ekg
16 Version:        1.5
17 #Release:       0.%{snap}.3
18 Release:        4
19 Epoch:          4
20 License:        GPL v2
21 Group:          Applications/Communications
22 #Source0:       http://dev.null.pl/ekg/%{name}-%{snap}.tar.gz
23 Source0:        http://dev.null.pl/ekg/%{name}-%{version}.tar.gz
24 # Source0-md5:  721ebfe7b13e9531b30d558465e6695f
25 Source1:        %{name}.conf
26 Patch0:         %{name}-kadu-0_3_6.patch
27 URL:            http://dev.null.pl/ekg/
28 %{?with_aspell:BuildRequires:   aspell-devel}
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %{?with_voip:BuildRequires:     libgsm-devel}
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  ncurses-devel
34 BuildRequires:  openssl-devel >= 0.9.7d
35 BuildRequires:  %{_bindir}/perl
36 %{?with_python:BuildRequires:   python-devel}
37 BuildRequires:  readline-devel
38 BuildRequires:  zlib-devel
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 A client compatible with Gadu-Gadu.
43
44 %description -l de
45 Ein Cliente kompatibel mit Gadu-Gadu.
46
47 %description -l es
48 Un cliente compatible con Gadu-Gadu.
49
50 %description -l it
51 Un cliente compatibile con Gadu-Gadu.
52
53 %description -l pl
54 Klient kompatybilny z Gadu-Gadu.
55
56 %package -n libgadu
57 Summary:        libgadu library
58 Summary(es):    Biblioteca libgadu
59 Summary(pl):    Biblioteka libgadu
60 License:        LGPL v2.1
61 Group:          Libraries
62 Obsoletes:      libgg
63
64 %description -n libgadu
65 libgadu is intended to make it easy to add Gadu-Gadu communication
66 support to your software.
67
68 %description -n libgadu -l de
69 Mit libgadu ist es Ihnen möglich auf einfache Weise Gadu-Gadu
70 Kommunikations-Unterstützung in Ihre Software einzubinden.
71
72 %description -n libgadu -l es
73 libgadu está pensada para facilitar añadirle comunicación vía
74 Gadu-Gadu a su software.
75
76 %description -n libgadu -l pl
77 libgadu umo¿liwia ³atwe dodanie do ró¿nych aplikacji komunikacji
78 bazuj±cej na protokole Gadu-Gadu.
79
80 %package -n libgadu-devel
81 Summary:        libgadu development library
82 Summary(es):    Biblioteca de desarrollo de libgadu
83 Summary(pl):    Czê¶æ biblioteki libgadu dla programistów
84 License:        LGPL v2.1
85 Group:          Development/Libraries
86 Requires:       libgadu = %{epoch}:%{version}
87 Requires:       openssl-devel
88 Obsoletes:      libgg-devel
89
90 %description -n libgadu-devel
91 The libgadu-devel package contains the header files and some
92 documentation needed to develop application with libgadu.
93
94 %description -n libgadu-devel -l de
95 Das libgadu-devel Paket enthält Header-Files (Kopfzeilenordner) und
96 die Dokumentation die Sie benötigen um mit libgadu Anwendungen zu
97 entwickeln.
98
99 %description -n libgadu-devel -l es
100 El paquete libgadu-devel contiene los ficheros de cabecera, juntos con
101 una documentación, necesarios para desarrollar aplicaciones que usar
102 libgadu.
103
104 %description -n libgadu-devel -l pl
105 Pakiet libgadu-devel zawiera pliki nag³ówkowe i dokumentacjê,
106 potrzebne do kompilowania aplikacji korzystaj±cych z libgadu.
107
108 %package -n libgadu-static
109 Summary:        Static libgadu library
110 Summary(es):    Biblioteca libgadu estática
111 Summary(pl):    Statyczna biblioteka libgadu
112 License:        LGPL v2.1
113 Group:          Development/Libraries
114 Requires:       libgadu-devel = %{epoch}:%{version}
115 Obsoletes:      libgg-static
116
117 %description -n libgadu-static
118 Static libgadu library.
119
120 %description -n libgadu-static -l de
121 Statisches libgadu Archiv.
122
123 %description -n libgadu-static -l es
124 Biblioteca libgadu estática.
125
126 %description -n libgadu-static -l pl
127 Statyczna biblioteka libgadu.
128
129 %prep
130 #%setup -q -n %{name}-%{snap}
131 %setup -q -n %{name}-%{version}
132 #%patch0 -p1
133
134 %build
135 sed -i -e 's/#define.*GG_LIBGADU_VERSION.*/#define GG_LIBGADU_VERSION "%{version}.%{snap}"/g' lib/libgadu.h
136
137 rm -f missing
138 %{__aclocal} -I m4
139 %{__autoheader}
140 %{__autoconf}
141 %configure \
142         --enable-shared \
143         --enable-static \
144         --with-pthread \
145         --without-bind \
146         %{?with_python:--with-python} \
147         %{!?with_voip:--without-libgsm} \
148         %{?with_aspell:--enable-aspell} \
149         %{!?with_ioctl_daemon:--disable-ioctld}
150
151 %{__make} \
152         CC="%{__cc} %{rpmcflags} -Wall -I%{_includedir}/ncurses"
153
154 %if %{with ioctl_daemon}
155 %{__make} -C src ioctld
156 %endif
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT%{_sysconfdir}
161
162 %{__make} install install-ekl2 \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
166
167 # For libgadu-devel
168
169 rm examples/Makefile examples/Makefile.in examples/.cvsignore
170 rm -r examples/CVS
171
172 install -d $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
173 mv examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
174
175 %if %{with ioctl_daemon}
176 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
177 %endif
178
179 cd $RPM_BUILD_ROOT%{_libdir}
180 ln -sf libgadu.so.*.* libgadu.so
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post   -n libgadu -p /sbin/ldconfig
186 %postun -n libgadu -p /sbin/ldconfig
187
188 %files
189 %defattr(644,root,root,755)
190 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
191 %{?with_aspell:%doc docs/slownik.txt}
192 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
193 %attr(755,root,root) %{_bindir}/e*
194 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
195 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*.conf
196 %{_datadir}/ekg
197 %{_mandir}/man1/*
198 %lang(pl) %{_mandir}/pl/man1/*
199
200 %files -n libgadu
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libgadu.so.*.*
203
204 %files -n libgadu-devel
205 %defattr(644,root,root,755)
206 %doc docs/{7thguard,ui,devel-hints,przenosny-kod}.txt docs/protocol.html
207 %doc ChangeLog docs/{README,TODO}
208 %{_libdir}/libgadu.so
209 %{_includedir}/libgadu.h
210 %{_includedir}/libgadu-config.h
211 %{_pkgconfigdir}/*
212 %dir %{_examplesdir}/libgadu-%{version}
213 %{_examplesdir}/libgadu-%{version}/*
214
215 %files -n libgadu-static
216 %defattr(644,root,root,755)
217 %attr(644,root,root) %{_libdir}/libgadu.a
This page took 0.048344 seconds and 4 git commands to generate.