]> git.pld-linux.org Git - packages/egroupware.git/blob - egroupware.spec
- save changes
[packages/egroupware.git] / egroupware.spec
1 # TODO
2 # - subpackages for applications
3 # - separate htdocs and includedirs
4 # - everything
5 Summary:        eGroupWare - a web-based groupware suite written in PHP
6 Summary(pl):    eGroupWAre - oparte na WWW oprogramowanie do pracy grupowej napisane w PHP
7 Name:           egroupware
8 Version:        1.0.0.009
9 Release:        0.18
10 Epoch:          0
11 License:        GPL
12 Group:          Applications/WWW
13 Source0:        http://dl.sourceforge.net/egroupware/eGroupWare-%{version}.tar.bz2
14 # Source0-md5:  2ed2f3041ab4ff235f56ed23dfa7274b
15 Source1:        %{name}.conf
16 Patch0:         %{name}-setup.patch
17 Patch1:         %{name}-ttfdir.patch
18 URL:            http://www.egroupware.org/
19 BuildRequires:  sed >= 4.0
20 Requires:       %{name}(DB_Driver) = %{version}-%{release}
21 Requires:       php >= 3:4.1.2
22 Requires:       php-gd
23 Requires:       php-mbstring
24 Requires:       php-pcre
25 Requires:       php-cli
26 Requires:       fonts-TTF-bitstream-vera
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _appdir %{_datadir}/%{name}
31 %define         _sysconfdir /etc/%{name}
32 %define         _noautoreqfiles /usr/bin/php
33
34 %description
35 eGroupWare is a multi-user, web-based groupware suite developed on a
36 custom set of PHP-based APIs. Currently available modules include:
37 email, addressbook, calendar, infolog (notes, to-do's, phone calls),
38 content management, forum, bookmarks, wiki.
39
40 %description -l pl
41 eGroupWare to wielou¿ytkownikowe, oparte na WWW oprogramowanie do
42 pracy grupowej stworzone na w³asnym zestawie API opartych na PHP.
43 Aktualnie dostêpne modu³y obejmuj±: pocztê elektroniczn±, ksi±¿kê
44 adresow±, kalendarz, infolog (notatki, rzeczy do zrobienia, rozmowy
45 telefoniczne), zarz±dzanie tre¶ci±, forum, zak³adki, wiki.
46
47 %package setup
48 Summary:        eGroupware setup package
49 Summary(pl):    Pakiet do wstêpnej konfiguracji eGroupware
50 Group:          Applications/WWW
51 PreReq:         %{name} = %{epoch}:%{version}-%{release}
52
53 %description setup
54 Install this package to configure initial eGroupware installation. You
55 should uninstall this package when you're done, as it considered
56 insecure to keep the setup files in place.
57
58 %description setup -l pl
59 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji eGroupware
60 po pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
61 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
62
63 %package db-mysql
64 Summary:        eGroupware DB Driver for MySQL
65 Summary(pl):    Sterownik bazy danych eGroupware dla MySQL-a
66 Group:          Applications/WWW
67 Requires:       php-mysql
68 Provides:       %{name}(DB_Driver) = %{version}-%{release}
69
70 %description db-mysql
71 This virtual package provides MySQL database backend for eGroupware.
72
73 %description db-mysql -l pl
74 Ten wirtualny pakiet dostarcza backend bazy danych MySQL dla
75 eGroupware.
76
77 %package db-pgsql
78 Summary:        eGroupware DB Driver for PostgreSQL
79 Summary(pl):    Sterownik bazy danych eGroupware dla PostgreSQL-a
80 Group:          Applications/WWW
81 Requires:       php-pgsql
82 Provides:       %{name}(DB_Driver) = %{version}-%{release}
83
84 %description db-pgsql
85 This virtual package provides PostgreSQL database backend for
86 eGroupware.
87
88 %description db-pgsql -l pl
89 Ten wirtualny pakiet dostarcza backend bazy danych PostgreSQL dla
90 eGroupware.
91
92 %package db-mssql
93 Summary:        eGroupware DB Driver for MS SQL
94 Summary(pl):    Sterownik bazy danych eGroupware dla MS SQL-a
95 Group:          Applications/WWW
96 Requires:       php-mssql
97 Provides:       %{name}(DB_Driver) = %{version}-%{release}
98
99 %description db-mssql
100 This virtual package provides MS SQL database backend for eGroupware.
101
102 %description db-mssql -l pl
103 Ten wirtualny pakiet dostarcza backend bazy danych MS SQL dla
104 eGroupware.
105
106 %prep
107 %setup -q -n %{name}
108
109 # remove CVS control files
110 find -name CVS -print0 | xargs -0 rm -rf
111 # undos the sources
112 find -regex '.*\.\(php\|inc\|html\|txt\|js\)$' -print0 | xargs -0 sed -i -e 's,
113 $,,'
114
115 %patch0 -p1
116 %patch1 -p1
117
118 # GPL
119 rm -f doc/LICENSE
120
121 # no need.
122 rm -rf doc/rpm-build
123
124 # using PLD package
125 rm -rf projects/ttf-bitstream-vera-1.10
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}
130
131 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
132 cp -a addressbook admin backup bookmarks calendar comic developer_tools \
133 email emailadmin etemplate felamimail filemanager forum ftp fudforum headlines \
134 infolog jinn manual messenger news_admin phpbrain phpgwapi phpldapadmin \
135 phpsysinfo polls preferences projects registration setup sitemgr stocks tts \
136 wiki $RPM_BUILD_ROOT%{_appdir}
137
138 > $RPM_BUILD_ROOT%{_sysconfdir}/header.php
139 ln -s %{_sysconfdir}/header.php $RPM_BUILD_ROOT%{_appdir}/header.inc.php
140
141 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
142
143 # needed by setup script
144 install header.inc.php.template $RPM_BUILD_ROOT%{_appdir}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %triggerin -- apache1 >= 1.3.33-2
150 %apache_config_install -v 1 -c %{_sysconfdir}/apache.conf
151
152 %triggerun -- apache1 >= 1.3.33-2
153 %apache_config_uninstall -v 1
154
155 %triggerin -- apache >= 2.0.0
156 %apache_config_install -v 2 -c %{_sysconfdir}/apache.conf
157
158 %triggerun -- apache >= 2.0.0
159 %apache_config_uninstall -v 2
160
161 %files
162 %defattr(644,root,root,755)
163 %attr(710,root,http) %dir %{_sysconfdir}
164 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
165 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/header.php
166 %doc doc/*
167 %dir %{_appdir}
168 %{_appdir}/*.php
169 %{_appdir}/addressbook
170 %{_appdir}/admin
171 %{_appdir}/backup
172 %{_appdir}/bookmarks
173 %{_appdir}/calendar
174 %{_appdir}/comic
175 %{_appdir}/developer_tools
176 %{_appdir}/email
177 %{_appdir}/emailadmin
178 %{_appdir}/etemplate
179 %{_appdir}/felamimail
180 %{_appdir}/filemanager
181 %{_appdir}/forum
182 %{_appdir}/ftp
183 %{_appdir}/headlines
184 %{_appdir}/infolog
185 %{_appdir}/jinn
186 %{_appdir}/manual
187 %{_appdir}/messenger
188 %{_appdir}/news_admin
189 %{_appdir}/phpbrain
190 %{_appdir}/phpldapadmin
191 %{_appdir}/phpsysinfo
192 %{_appdir}/polls
193 %{_appdir}/preferences
194 %{_appdir}/projects
195 %{_appdir}/registration
196 %{_appdir}/sitemgr
197 %{_appdir}/stocks
198 %{_appdir}/tts
199 %{_appdir}/wiki
200
201 %dir %{_appdir}/phpgwapi
202 %{_appdir}/phpgwapi/*.php
203 %{_appdir}/phpgwapi/cron
204 %{_appdir}/phpgwapi/doc
205 %{_appdir}/phpgwapi/inc
206 %{_appdir}/phpgwapi/js
207 %{_appdir}/phpgwapi/setup
208 %{_appdir}/phpgwapi/templates
209 %{_appdir}/phpgwapi/themes
210 %dir %attr(775,root,http) %{_appdir}/phpgwapi/images
211 %{_appdir}/phpgwapi/images/*
212
213 %dir %attr(775,root,http) %{_appdir}/fudforum
214 %{_appdir}/fudforum/*.php
215 %{_appdir}/fudforum/inc
216 %{_appdir}/fudforum/setup
217 %{_appdir}/fudforum/templates
218
219 %files setup
220 %defattr(644,root,root,755)
221 %{_appdir}/header.inc.php.template
222 %{_appdir}/setup
223
224 %files db-mysql
225 %defattr(644,root,root,755)
226
227 %files db-pgsql
228 %defattr(644,root,root,755)
229
230 %files db-mssql
231 %defattr(644,root,root,755)
This page took 0.095527 seconds and 4 git commands to generate.