]> git.pld-linux.org Git - packages/eggdrop.git/blob - eggdrop.spec
- spec adapterized.
[packages/eggdrop.git] / eggdrop.spec
1 Summary:        Eggdrop is an IRC bot, written in C
2 Summary(pl):    Eggdrop jest botem IRC napisanym w C
3 Name:           eggdrop
4 Version:        2.0.0
5 Release:        1.ALPHA
6 License:        GPL
7 Group:          Applications/Communications
8 Group(pl):      Aplikacje/Komunikacja
9 Source0:        %{name}%{version}-ALPHA.tar.gz
10 Source1:        eggdrop.sh
11 Patch0:         eggdrop-pld.patch
12 URL:            http://www.eggdrop.net/
13 Requires:       tcl
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Eggdrop is an IRC bot, written in C. If you don't know what IRC is,
18 this is probably not whatever you're looking for! Eggdrop, being a
19 bot, sits on a channel and takes protective measures: to keep the
20 channel from being taken over (in the few ways that anything CAN), to
21 recognize banished users or sites and reject them, to recognize
22 privileged users and let them gain ops, etc. Eggdrop also contains
23 many modules and scripts, for example for sending files.
24
25 %description -l pl
26 Eggdrop jest IRCowym botem napisanym w C. Eggdrop, bêd±c botem jest na
27 kanale i zajmuje siê jego ochron±: zabezpieczeniem przed przejêciem,
28 nadawaniem odpowiednich przywilejów zarejestrowanym u¿ytkownikom,
29 pilnowanie tzw. banów itp. Eggdrop poza tymi funkcjami posiada tak¿e
30 wiele dodatków, jak przesy³anie plików czy inne skrypty dla rozrywki.
31
32 %prep
33 %setup -q -n %{name}%{version}-ALPHA
34 %patch -p1
35
36 %build
37 CFLAGS="$RPM_OPT_FLAGS" \
38 ./configure %{_target_platform} \
39         --prefix=%{_bindir}
40
41 # Dziwny problem z -ldir w module filesys
42 cd src/mod/filesys.mod
43 rm -f config.cache config.log
44
45 CFLAGS="$RPM_OPT_FLAGS" \
46 ./configure %{_target_platform}
47
48 cd ../../..
49 CFLAGS="$RPM_OPT_FLAGS" make
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/eggdrop,%{_mandir}/man1}
55
56 make install DEST=$RPM_BUILD_ROOT%{_libdir}/eggdrop
57
58 rm -rf `find $RPM_BUILD_ROOT%{_libdir}/eggdrop -name CVS`
59 rm -rf `find $RPM_BUILD_DIR/%{name}%{version}-ALPHA/doc -name CVS`
60 mv -f $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
61 rm -rf $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/*
62 install $RPM_SOURCE_DIR/eggdrop.sh $RPM_BUILD_ROOT%{_bindir}/eggdrop
63
64 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
65         FEATURES README doc/{patch.howto,tricks,[A-Z]*,*.doc}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files 
71 %defattr(644,root,root,755)
72 %doc FEATURES.gz README.gz doc/*.gz doc/html
73 %attr(755,root,root) %{_bindir}/*
74 %{_libdir}/eggdrop/filesys
75 %{_libdir}/eggdrop/help
76 %{_libdir}/eggdrop/language
77 %ghost %{_libdir}/eggdrop/modules
78 %{_libdir}/eggdrop/modules-%{version}
79 %{_libdir}/eggdrop/scripts
80 %attr(755,root,root) %{_libdir}/eggdrop/eggdrop2-%{version}
81 %ghost %{_libdir}/eggdrop/eggdrop2
82 %{_libdir}/eggdrop/eggdrop2.conf.*
83 %{_libdir}/eggdrop/motd
84 %{_mandir}/man*/*
This page took 0.052607 seconds and 4 git commands to generate.