]> git.pld-linux.org Git - packages/eggdrop.git/blob - eggdrop.spec
- added using CVS keywords in %changelog (for automating them).
[packages/eggdrop.git] / eggdrop.spec
1 Summary:     Eggdrop is an IRC bot, written in C
2 Name:        eggdrop
3 %define versionmajor 2.0.0
4 %define versionminor -ALPHA
5 Version:     %{versionmajor}%{versionminor}
6 Release:     1
7 Copyright:   GPL
8 Group:       Applications/Communications
9 Group(pl):   Aplikacje/Komunikacja
10 Source0:     %{name}%{version}.tar.gz
11 Source1:     eggdrop.sh
12 Patch:       eggdrop-pld.patch
13 URL:         http://www.eggdrop.net/
14 Requires:    tcl
15 BuildRoot:      /tmp/%{name}-%{version}-root
16 Summary(pl): Eggdrop jest botem IRC napisanym w C
17
18 %description
19 Eggdrop is an IRC bot, written in C.  If you don't know what IRC is,
20 this is probably not whatever you're looking for!  Eggdrop, being a
21 bot, sits on a channel and takes protective measures: to keep the
22 channel from being taken over (in the few ways that anything CAN),
23 to recognize banished users or sites and reject them, to recognize
24 privileged users and let them gain ops, etc.
25 Eggdrop also contains many modules and scripts, for example for
26 sending files.
27
28 %description -l pl
29 Eggdrop jest IRCowym botem napisanym w C. Eggdrop, bêd±c botem
30 jest na kanale i zajmuje siê jego ochron±: zabezpieczeniem przed
31 takeover-em, nadawaniem odpowiednich przywilejów zarejestrowanym
32 u¿ytkownikom, pilnowanie tzw. banów. itp.
33 Eggdrop poza tymi funkcjami posiada tak¿e wiele dodatków, jak
34 przesy³anie plików czy inne skrypty dla rozrywki.
35
36 %prep
37 %setup -q -n %{name}%{version}
38 %patch -p1
39
40 %build
41 CFLAGS="$RPM_OPT_FLAGS" \
42 ./configure %{_target_platform} \
43         --prefix=%{_bindir}
44 # Dziwny problem z -ldir w module filesys
45 cd src/mod/filesys.mod
46 rm -f config.cache config.log
47 CFLAGS="$RPM_OPT_FLAGS" \
48 ./configure %{_target_platform}
49 cd ../../..
50 CFLAGS="$RPM_OPT_FLAGS" make
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT/usr/{bin,lib/eggdrop,man/man1}
56 make install DEST=$RPM_BUILD_ROOT%{_libdir}/eggdrop
57 rm -rf `find $RPM_BUILD_ROOT%{_libdir}/eggdrop -name CVS`
58 rm -rf $RPM_SOURCE_DIR/doc/CVS
59 mv $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
60 rm -rf $RPM_BUILD_ROOT%{_libdir}/eggdrop/doc/*
61 install $RPM_SOURCE_DIR/eggdrop.sh $RPM_BUILD_ROOT%{_bindir}/eggdrop
62
63 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/*
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files 
69 %defattr(644,root,root,755)
70 %doc CONTENTS COPYING FEATURES INSTALL README doc/*
71 %attr(755,root,root) %{_bindir}/*
72 %{_libdir}/eggdrop/filesys
73 %{_libdir}/eggdrop/help
74 %{_libdir}/eggdrop/language
75 %ghost %{_libdir}/eggdrop/modules
76 %{_libdir}/eggdrop/modules-%{versionmajor}
77 %{_libdir}/eggdrop/scripts
78 %attr(755,root,root) %{_libdir}/eggdrop/eggdrop2-%{versionmajor}
79 %ghost %{_libdir}/eggdrop/eggdrop2
80 %{_libdir}/eggdrop/eggdrop2.conf.*
81 %{_libdir}/eggdrop/motd
82 %{_mandir}/man*/*
This page took 0.062503 seconds and 4 git commands to generate.