]> git.pld-linux.org Git - packages/ecore.git/blob - ecore.spec
a2cc78e7e1d7ab8601bf5ba79c44ba20d636a73a
[packages/ecore.git] / ecore.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Enlightened Core X interface library
6 Summary(pl):    Biblioteka interfejsu X Enlightened Core
7 Name:           ecore
8 Version:        0.9.9.030
9 Release:        1
10 License:        BSD
11 Group:          X11/Libraries
12 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  cdc01b2ee571bc402e0d5dfd3fd0dc83
14 URL:            http://enlightenment.org/Libraries/Ecore/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  curl-devel
18 BuildRequires:  evas-devel
19 BuildRequires:  libtool
20 BuildRequires:  openssl-devel
21 BuildRequires:  pkgconfig
22 Requires:       %{name}-libs = %{version}-%{release}
23 Requires:       fonts-TTF-bitstream-vera
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %undefine       __cxx
27
28 %description
29 Ecore is the event/X abstraction layer that makes doing selections,
30 Xdnd, general X stuff, event loops, timeouts and idle handlers fast,
31 optimized, and convenient. It's a separate library so anyone can make
32 use of the work put into Ecore to make this job easy for applications.
33
34 %description -l pl
35 Ecore to warstwa abstracji zdarzeñ/X, która powoduje, ¿e dokonywanie
36 zaznaczeñ, Xdnd, ogólne operacje X, pêtle zdarzeñ, obs³uga timeoutów i
37 bezczynno¶ci s± szybkie, zoptymalizowane i wygodne. Jest to wydzielona
38 biblioteka, wiêc ka¿dy mo¿e skorzystaæ z pracy w³o¿onej w Ecore do
39 u³atwienia swojej pracy przy aplikacjach.
40
41 %package libs
42 Summary:        Ecore library
43 Summary(pl):    Biblioteka ecore
44 Group:          X11/Libraries
45
46 %description libs
47 Ecore library.
48
49 %description libs -l pl
50 Biblioteka ecore.
51
52 %package devel
53 Summary:        Ecore header files
54 Summary(pl):    Pliki nag³ówkowe Ecore
55 Group:          Development/Libraries
56 Requires:       %{name}-libs = %{version}-%{release}
57 Requires:       curl-devel
58 Requires:       evas-devel
59 Requires:       openssl-devel
60
61 %description devel
62 Ecore development files.
63
64 %description devel -l pl
65 Pliki programistyczne Ecore.
66
67 %package static
68 Summary:        Static Ecore libraries
69 Summary(pl):    Statyczne biblioteki Ecore
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static Ecore libraries.
75
76 %description static -l pl
77 Statyczne biblioteki Ecore.
78
79 %prep
80 %setup -q
81
82 %build
83 %configure \
84         %{!?with_static_libs:--disable-static} \
85         --enable-ecore-txt      \
86         --enable-ecore-x        \
87         --enable-ecore-job      \
88         --enable-ecore-fb       \
89         --enable-ecore-evas     \
90         --enable-ecore-evas-gl  \
91         --enable-ecore-evas-xrender \
92         --enable-ecore-evas-dfb \
93         --enable-ecore-evas-fb  \
94         --enable-ecore-evas-buffer \
95         --enable-ecore-con      \
96         --enable-openssl        \
97         --enable-ecore-ipc      \
98         --enable-ecore-dbus     \
99         --enable-ecore-config   \
100         --enable-ecore-file     \
101         --enable-inotify        \
102         --enable-poll           \
103         --enable-curl           \
104         --enable-pthreads
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 cd $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
114 VERA=$(ls Vera*.ttf)
115 for FONT in $VERA; do
116         rm -f $FONT
117         ln -s %{_fontsdir}/TTF/$FONT .
118 done
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post libs      -p /sbin/ldconfig
124 %postun libs    -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
129 %attr(755,root,root) %{_bindir}/ecore_*
130 %{_datadir}/%{name}
131
132 %files libs
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libecore*.so.*.*.*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/ecore-config
139 %attr(755,root,root) %{_libdir}/libecore*.so
140 %{_libdir}/libecore*.la
141 %{_pkgconfigdir}/ecore.pc
142 %{_aclocaldir}/ecore.m4
143 %{_includedir}/Ecore*.h
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libecore*.a
149 %endif
This page took 0.103113 seconds and 3 git commands to generate.