]> git.pld-linux.org Git - packages/ecore.git/blob - ecore.spec
519211236ed623e3c8903d58baa09e6078048833
[packages/ecore.git] / ecore.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Enlightened Core X interface library
6 Summary(pl):    Biblioteka interfejsu X Enlightened Core
7 Name:           ecore
8 Version:        0.9.9.022
9 Release:        1
10 License:        BSD
11 Group:          X11/Libraries
12 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  334cf22f033ecb144b77e92455167855
14 #Patch0:                %{name}-missing_m4.patch
15 URL:            http://enlightenment.org/Libraries/Ecore/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  curl-devel
19 BuildRequires:  evas-devel
20 BuildRequires:  libtool
21 BuildRequires:  openssl-devel
22 BuildRequires:  pkgconfig
23 Requires:       %{name}-libs = %{version}-%{release}
24 Requires:       fonts-TTF-bitstream-vera
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %undefine       __cxx
28
29 %description
30 Ecore is the event/X abstraction layer that makes doing selections,
31 Xdnd, general X stuff, event loops, timeouts and idle handlers fast,
32 optimized, and convenient. It's a separate library so anyone can make
33 use of the work put into Ecore to make this job easy for applications.
34
35 %description -l pl
36 Ecore to warstwa abstracji zdarzeñ/X, która powoduje, ¿e dokonywanie
37 zaznaczeñ, Xdnd, ogólne operacje X, pêtle zdarzeñ, obs³uga timeoutów i
38 bezczynno¶ci s± szybkie, zoptymalizowane i wygodne. Jest to wydzielona
39 biblioteka, wiêc ka¿dy mo¿e skorzystaæ z pracy w³o¿onej w Ecore do
40 u³atwienia swojej pracy przy aplikacjach.
41
42 %package libs
43 Summary:        Ecore library
44 Summary(pl):    Biblioteka ecore
45 Group:          X11/Libraries
46
47 %description libs
48 Ecore library.
49
50 %description libs -l pl
51 Biblioteka ecore.
52
53 %package devel
54 Summary:        Ecore header files
55 Summary(pl):    Pliki nag³ówkowe Ecore
56 Group:          Development/Libraries
57 Requires:       %{name}-libs = %{version}-%{release}
58 Requires:       curl-devel
59 Requires:       evas-devel
60 Requires:       openssl-devel
61
62 %description devel
63 Ecore development files.
64
65 %description devel -l pl
66 Pliki programistyczne Ecore.
67
68 %package static
69 Summary:        Static Ecore libraries
70 Summary(pl):    Statyczne biblioteki Ecore
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Ecore libraries.
76
77 %description static -l pl
78 Statyczne biblioteki Ecore.
79
80 %prep
81 %setup -q
82 #%%patch0 -p1
83
84 %build
85 #%%{__libtoolize}
86 #%%{__aclocal}
87 #%%{__autoconf}
88 #%%{__autoheader}
89 #%%{__automake}
90 sed -e  's/^@BUILD_ECORE_DIRECTFB_TRUE@/#/'     \
91     -e  's/^@BUILD_ECORE_DIRECTFB_FALSE@//'     \
92     -i  src/lib/ecore_directfb/Makefile.in      \
93         src/lib/ecore_evas/Makefile.in
94 %configure \
95         %{!?with_static_libs:--disable-static} \
96         --enable-ecore-txt      \
97         --enable-ecore-x        \
98         --enable-ecore-job      \
99         --enable-ecore-fb       \
100         --enable-ecore-evas     \
101         --enable-ecore-evas-gl  \
102         --enable-ecore-evas-xrender \
103         --disable-ecore-evas-dfb        \
104         --enable-ecore-evas-fb  \
105         --enable-ecore-evas-buffer \
106         --enable-ecore-con      \
107         --enable-openssl        \
108         --enable-ecore-ipc      \
109         --enable-ecore-dbus     \
110         --enable-ecore-config   \
111         --enable-ecore-file     \
112         --enable-inotify        \
113         --enable-poll           \
114         --enable-curl           \
115         --enable-pthreads
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 cd $RPM_BUILD_ROOT%{_datadir}/%{name}/fonts
125 VERA=$(ls Vera*.ttf)
126 for FONT in $VERA; do
127         rm -f $FONT
128         ln -s %{_fontsdir}/TTF/$FONT .
129 done
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post libs      -p /sbin/ldconfig
135 %postun libs    -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS COPYING COPYING-PLAIN INSTALL README
140 %attr(755,root,root) %{_bindir}/ecore_*
141 %{_datadir}/%{name}
142
143 %files libs
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libecore*.so.*.*.*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_bindir}/ecore-config
150 %attr(755,root,root) %{_libdir}/libecore*.so
151 %{_libdir}/libecore*.la
152 %{_pkgconfigdir}/ecore.pc
153 %{_aclocaldir}/ecore.m4
154 %{_includedir}/Ecore*.h
155
156 %if %{with static_libs}
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libecore*.a
160 %endif
This page took 0.035668 seconds and 3 git commands to generate.