]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- up to 2.0.1
[packages/ecasound.git] / ecasound.spec
1
2 %define python_sitepkgsdir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`)
3 %define python_ver %(echo `python -c "import sys; print sys.version[:3]"`)
4 %define python_basedir %(echo `python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3])"`)
5 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
6 %define python_compile python -c "import compileall; compileall.compile_dir('.')"
7
8 Summary:        Software package for multitrack audio processing
9 Summary(pl):    Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
10 Name:           ecasound
11 Version:        2.0.1
12 Release:        1
13 License:        GPL
14 Group:          Applications/Sound
15 Group(de):      Applikationen/Laut
16 Group(pl):      Aplikacje/D¼wiêk
17 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
18 Patch0:         %{name}-am_fix.patch
19 Patch1:         %{name}-ac_fix.patch
20 Patch2:         %{name}-readline.patch
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 BuildRequires:  readline-devel >= 4.2
25 %ifnarch sparc sparc64
26 BuildRequires:  alsa-lib-devel
27 %endif
28 BuildRequires:  audiofile-devel >= 0.2.0
29 BuildRequires:  python-devel >= 2.1
30 Requires:       lame
31 Requires:       mpg123
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Ecasound is a software package designed for multitrack audio
36 processing. It can be used for simple tasks like audio playback,
37 recording and format conversions, as well as for multitrack effect
38 processing, mixing, recording and signal recycling. Ecasound supports
39 a wide range of audio inputs, outputs and effect algorithms. Several
40 open-source audio packages, like for instance ALSA, OSS, mpg123, lame,
41 libaudiofile and MikMod, are directly supported. One of the advantages
42 of ecasound's chain-based design is that effects can easily be
43 combined both in series and in parallel. Oscillators and MIDI-CCs can
44 be used for controlling effect parameters. Included user-interfaces
45 are ecasound - a versatile console mode interface, qtecasound - a
46 Qt-based X-interface and various command-line utils suitable for batch
47 processing.
48
49 %description -l pl
50 Ecasound jest programem do wielo¶cie¿kowej edycji d¼wiêku, który mo¿e
51 byæ u¿ywany tak do prostych zadañ typu odtwarzanie i nagrywanie muzyki
52 czy te¿ konwersji pomiêdzy formatami plików muzycznych jak i do
53 wielo¶cie¿kowego nak³adania efektów, miksowania (przenikania,
54 wyciszania), nagrywania i odzyskiwania (w domy¶le odszumiania lub
55 wyrzucania zniekszta³ceñ) sygna³u.
56
57 Ecasound wspiera szerok± gamê ¼róde³ i wyj¶æ d¼wiêku oraz algorytmów
58 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
59 projektów, takich jak ALSA, OSS, mpg123, lame, libaudiofile czy te¿
60 MikMod. Jedn± z zalet programu ecasound jest mo¿liwo¶æ ³añcuchowego
61 (szeregowego) lub równoleg³ego ³±czenia efektów, które mog± byæ
62 kontrolowane poprzez oscylatory lub MIDI-CC. Pakiet ten zawiera
63 tekstowy interfejs u¿ytkownika oraz kilka innych narzêdzi nadaj±cych
64 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
65 interfejs u¿ytkownika - qtecasound.
66
67 %package -n libecasound
68 Summary:        Ecasound libraries
69 Summary(pl):    Biblioteki programu ecasound
70 Group:          Development/Libraries
71 Group(de):      Entwicklung/Libraries
72 Group(fr):      Development/Librairies
73 Group(pl):      Programowanie/Biblioteki
74
75 %description -n libecasound
76 Ecasound libraries.
77
78 %description -l pl -n libecasound
79 Biblioteki programu ecasound.
80
81 %package -n libecasound-devel
82 Summary:        Ecasound headers
83 Summary(pl):    Pliki nag³ówkowe bibliotek programu ecasound
84 Group:          Development/Libraries
85 Group(de):      Entwicklung/Libraries
86 Group(fr):      Development/Librairies
87 Group(pl):      Programowanie/Biblioteki
88 Requires:       libecasound = %{version}
89
90 %description -n libecasound-devel
91 Ecasound headers.
92
93 %description -l pl -n libecasound-devel
94 Pliki nag³ówkowe bibliotek programu ecasound.
95
96 %package -n libecasound-static
97 Summary:        Ecasound static libraries
98 Summary(pl):    Biblioteki statyczne programu ecasound
99 Group:          Development/Libraries
100 Group(de):      Entwicklung/Libraries
101 Group(fr):      Development/Librairies
102 Group(pl):      Programowanie/Biblioteki
103 Requires:       libecasound-devel = %{version}
104
105 %description -n libecasound-static
106 Ecasound static libraries.
107
108 %description -l pl -n libecasound-static
109 Biblioteki statyczne programu ecasound.
110
111 %package plugins
112 Summary:        Ecasound plugins (ALSA, Audio File Library, aRts)
113 Summary(pl):    Wtyczki dla programu ecasound (ALSA, Audio File Library, aRts)
114 Group:          Applications/Sound
115 Group(de):      Applikationen/Laut
116 Group(pl):      Aplikacje/D¼wiêk
117 Requires:       ecasound = %{version}
118
119 %description plugins
120 This package contains ecasound plugins, which give support for ALSA,
121 Audio File Library and aRts.
122
123 %description -l pl plugins
124 Pakiet ten zawiera wtyczki dla programu ecasound, które umo¿liwiaj±
125 wspó³pracê z bibliotekami takich projektów jak ALSA, Audio File
126 Library oraz aRts.
127
128 %package -n python-%{name}
129 Summary:        Python module for Ecasound
130 Summary(pl):    Modu³ jêzyka Python dla biblioteki programu ecasound
131 Group:          Development/Languages/Python
132 Group(de):      Entwicklung/Sprachen/Python
133 Group(pl):      Programowanie/Jêzyki/Python
134 %requires_eq    python
135
136 %description -n python-%{name}
137 Python module for Ecasound library.
138
139 %description -l pl -n python-%{name}
140 Modu³ jêzyka Python dla biblioteki programu ecasound.
141
142 %prep
143 %setup -q
144 %patch0 -p1
145 %patch1 -p1
146 %patch2 -p1
147
148 %build
149 rm missing
150 %ifarch sparc sparc64
151 libtoolize --copy --force
152 %endif
153 aclocal
154 autoconf
155 automake -a -c
156 CXXFLAGS="%{rpmcflags} -D_REENTRANT"
157 %configure \
158         --enable-sys-readline \
159         --with-python-includes=%{_includedir}/python%{python_ver} \
160         --with-python-modules=%{python_basedir}
161 %{__make}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 %{__install} -d $RPM_BUILD_ROOT%{_libdir}/python2.0/site-packages
166
167 %{__make} DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
168
169 ( cd pyecasound
170   %python_compile_opt
171   %python_compile
172   install *.pyc *.pyo $RPM_BUILD_ROOT%{python_sitepkgsdir}
173 )
174
175 %post   -n libecasound -p /sbin/ldconfig
176 %postun -n libecasound -p /sbin/ldconfig
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %files
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_bindir}/ecaconvert
184 %attr(755,root,root) %{_bindir}/ecafixdc
185 %attr(755,root,root) %{_bindir}/ecanormalize
186 %attr(755,root,root) %{_bindir}/ecaplay
187 %attr(755,root,root) %{_bindir}/ecasignalview
188 %attr(755,root,root) %{_bindir}/ecasound
189 %{_mandir}/man1/eca*
190 %{_mandir}/man5/eca*
191
192 %files -n libecasound
193 %defattr(644,root,root,755)
194 %dir %{_datadir}/ecasound
195 %{_datadir}/ecasound/*
196 %attr(755,root,root) %{_libdir}/libkvutils*.so.*.*
197 %attr(755,root,root) %{_libdir}/libecasound*.so.*.*
198
199 %files -n libecasound-devel
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_bindir}/ecasound-config
202 %attr(755,root,root) %{_bindir}/ecasoundc-config
203 %{_includedir}/ecasound/*
204 %{_includedir}/kvutils/*
205 %attr(755,root,root) %{_libdir}/libkvutils.so
206 %attr(755,root,root) %{_libdir}/libkvutils.la
207 %attr(755,root,root) %{_libdir}/libecasound*.so
208 %attr(755,root,root) %{_libdir}/libecasound*.la
209
210 %files -n libecasound-static
211 %defattr(644,root,root,755)
212 %{_libdir}/libkvutils.a
213 %{_libdir}/libecasound.a
214 %{python_sitepkgsdir}/*.a
215
216 %files plugins
217 %defattr(644,root,root,755)
218 %dir %{_libdir}/ecasound-plugins
219 %attr(755,root,root) %{_libdir}/ecasound-plugins/lib*.so*
220 %{_libdir}/ecasound-plugins/lib*.la
221 %{_libdir}/ecasound-plugins/lib*.a
222
223 %files -n python-%{name}
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{python_sitepkgsdir}/*.so
226 %{python_sitepkgsdir}/*.py[co]
This page took 0.043751 seconds and 4 git commands to generate.