]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- next part of small fixes inpired by kloczek :)
[packages/ecasound.git] / ecasound.spec
1 # todo:
2 # - jack-audio-connection-kit support
3 #
4 # Conditional build:
5 # _without_alsa - without ALSA support
6 #
7 %include        /usr/lib/rpm/macros.python
8 Summary:        Software package for multitrack audio processing
9 Summary(pl):    Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
10 Name:           ecasound
11 Version:        2.2.3
12 Release:        1
13 License:        GPL
14 Group:          Applications/Sound
15 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
16 # Source0-md5:  40a3f0213c30b18e1b4e7879faa6b454
17 Patch0:         %{name}-link.patch
18 %ifnarch sparc sparc64
19 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
20 %endif
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  ladspa-devel
24 BuildRequires:  libsamplerate-devel
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:1.4d
27 BuildRequires:  python-devel >= 2.2
28 BuildRequires:  python-modules >= 2.2
29 BuildRequires:  readline-devel >= 4.2
30 BuildRequires:  rpm-pythonprov
31 Obsoletes:      libecasound
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Ecasound is a software package designed for multitrack audio
36 processing. It can be used for simple tasks like audio playback,
37 recording and format conversions, as well as for multitrack effect
38 processing, mixing, recording and signal recycling. Ecasound supports
39 a wide range of audio inputs, outputs and effect algorithms. Several
40 open-source audio packages, like for instance ALSA, OSS, mpg123, lame,
41 libaudiofile and MikMod, are directly supported. One of the advantages
42 of ecasound's chain-based design is that effects can easily be
43 combined both in series and in parallel. Oscillators and MIDI-CCs can
44 be used for controlling effect parameters. Included user-interfaces
45 are ecasound - a versatile console mode interface, qtecasound - a
46 Qt-based X-interface and various command-line utils suitable for batch
47 processing.
48
49 %description -l pl
50 Ecasound jest programem do wielo¶cie¿kowej edycji d¼wiêku, który mo¿e
51 byæ u¿ywany tak do prostych zadañ typu odtwarzanie i nagrywanie muzyki
52 czy te¿ konwersji pomiêdzy formatami plików muzycznych jak i do
53 wielo¶cie¿kowego nak³adania efektów, miksowania (przenikania,
54 wyciszania), nagrywania i odzyskiwania (w domy¶le odszumiania lub
55 wyrzucania zniekszta³ceñ) sygna³u.
56
57 Ecasound wspiera szerok± gamê ¼róde³ i wyj¶æ d¼wiêku oraz algorytmów
58 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
59 projektów, takich jak ALSA, OSS, mpg123, lame, libaudiofile czy te¿
60 MikMod. Jedn± z zalet programu ecasound jest mo¿liwo¶æ ³añcuchowego
61 (szeregowego) lub równoleg³ego ³±czenia efektów, które mog± byæ
62 kontrolowane poprzez oscylatory lub MIDI-CC. Pakiet ten zawiera
63 tekstowy interfejs u¿ytkownika oraz kilka innych narzêdzi nadaj±cych
64 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
65 interfejs u¿ytkownika - qtecasound.
66
67 %package devel
68 Summary:        Header files for ecasound libraries
69 Summary(pl):    Pliki nag³ówkowe bibliotek ecasound
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}
72 Obsoletes:      libecasound-devel
73
74 %description devel
75 Header files for ecasound libraries.
76
77 %description devel -l pl
78 Pliki nag³ówkowe bibliotek ecasound.
79
80 %package static
81 Summary:        Static ecasound libraries
82 Summary(pl):    Statyczne biblioteki ecasound
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}
85 Obsoletes:      libecasound-static
86
87 %description static
88 Static ecasound libraries.
89
90 %description static -l pl
91 Statyczne biblioteki ecasound.
92
93 %package -n python-%{name}
94 Summary:        Python module for Ecasound
95 Summary(pl):    Modu³ jêzyka Python dla programu ecasound
96 Group:          Libraries/Python
97 %pyrequires_eq  python-modules
98
99 %description -n python-%{name}
100 Python module for Ecasound.
101
102 %description -n python-%{name} -l pl
103 Modu³ jêzyka Python dla programu ecasound.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108
109 %build
110 rm -f missing
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoconf}
114 %{__automake}
115 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
116 # disable audiofile - ecasound has native support for wav and raw formats
117 # disable oss       - ecasound works nicely with alsa oss emulation;
118 #                     in case of alsa building conditional, the oss should
119 #                     be enabled
120 # disable arts      - 'not really useful' as said by ecasound author
121 %configure \
122         %{?_without_alsa:--disable-alsa} \
123         --disable-arts \
124         --disable-audiofile \
125         %{!?_without_alsa:--disable-oss} \
126         --enable-samplerate \
127         --enable-sys-readline \
128         --enable-pyecasound \
129         --with-largefile \
130         --with-python-includes=%{py_incdir} \
131         --with-python-modules=%{py_libdir}
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT%{py_sitedir}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT \
141         mandir=%{_mandir}
142
143 install pyecasound/*.py $RPM_BUILD_ROOT%{py_sitedir}
144 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
145 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc BUGS NEWS README TODO
156 %attr(755,root,root) %{_bindir}/eca*
157 %attr(755,root,root) %{_libdir}/lib*.so.*.*
158 %{_datadir}/ecasound
159 %{_mandir}/man1/eca*
160 %{_mandir}/man5/eca*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/*-config
165 %attr(755,root,root) %{_libdir}/lib*.so
166 %{_libdir}/lib*.la
167 %{_includedir}/kvutils
168 %{_includedir}/libecasound
169 %{_includedir}/libecasoundc
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/lib*.a
174
175 %files -n python-%{name}
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{py_sitedir}/*.so
178 %{py_sitedir}/*.py[co]
This page took 0.061898 seconds and 3 git commands to generate.