]> git.pld-linux.org Git - packages/ecasound.git/blob - ecasound.spec
- rel. 2
[packages/ecasound.git] / ecasound.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # without ALSA support (implies without JACK)
4 %bcond_without  jack            # without JACK support
5 %bcond_with     arts            # with aRts support
6 #
7 %if %{without alsa}
8 %undefine       with_jack
9 %endif
10 Summary:        Software package for multitrack audio processing
11 Summary(pl):    Oprogramowanie do wielo¶cie¿kowego przetwarzania d¼wiêku
12 Name:           ecasound
13 Version:        2.3.2
14 Release:        2
15 License:        GPL
16 Group:          Applications/Sound
17 Source0:        http://ecasound.seul.org/download/%{name}-%{version}.tar.gz
18 # Source0-md5:  624ea41e87dc0cca73cf2057c053d4a7
19 Patch0:         %{name}-link.patch
20 %{?with_alsa:BuildRequires:     alsa-lib-devel}
21 %{?with_arts:BuildRequires:     arts-devel}
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
25 BuildRequires:  ladspa-devel
26 BuildRequires:  libsamplerate-devel
27 BuildRequires:  libsndfile-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtool >= 2:1.4d
30 BuildRequires:  python-devel >= 2.2
31 BuildRequires:  python-modules >= 2.2
32 BuildRequires:  readline-devel >= 4.2
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  ruby
35 Obsoletes:      libecasound
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         ruby_sitelibdir %(ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]')
39
40 %description
41 Ecasound is a software package designed for multitrack audio
42 processing. It can be used for simple tasks like audio playback,
43 recording and format conversions, as well as for multitrack effect
44 processing, mixing, recording and signal recycling. Ecasound supports
45 a wide range of audio inputs, outputs and effect algorithms. Several
46 open-source audio packages, like for instance ALSA, OSS, mpg123, lame,
47 libaudiofile and MikMod, are directly supported. One of the advantages
48 of ecasound's chain-based design is that effects can easily be
49 combined both in series and in parallel. Oscillators and MIDI-CCs can
50 be used for controlling effect parameters. Included user-interfaces
51 are ecasound - a versatile console mode interface, qtecasound - a
52 Qt-based X-interface and various command-line utils suitable for batch
53 processing.
54
55 %description -l pl
56 Ecasound jest programem do wielo¶cie¿kowej edycji d¼wiêku, który mo¿e
57 byæ u¿ywany tak do prostych zadañ typu odtwarzanie i nagrywanie muzyki
58 czy te¿ konwersji pomiêdzy formatami plików muzycznych jak i do
59 wielo¶cie¿kowego nak³adania efektów, miksowania (przenikania,
60 wyciszania), nagrywania i odzyskiwania (w domy¶le odszumiania lub
61 wyrzucania zniekszta³ceñ) sygna³u.
62
63 Ecasound wspiera szerok± gamê ¼róde³ i wyj¶æ d¼wiêku oraz algorytmów
64 do jego przetwarzania. Ecasound wspiera wiele wolnych (open source)
65 projektów, takich jak ALSA, OSS, mpg123, lame, libaudiofile czy te¿
66 MikMod. Jedn± z zalet programu ecasound jest mo¿liwo¶æ ³añcuchowego
67 (szeregowego) lub równoleg³ego ³±czenia efektów, które mog± byæ
68 kontrolowane poprzez oscylatory lub MIDI-CC. Pakiet ten zawiera
69 tekstowy interfejs u¿ytkownika oraz kilka innych narzêdzi nadaj±cych
70 siê do przetwarzania wsadowego. Dostêpny jest tak¿e graficzny
71 interfejs u¿ytkownika - qtecasound.
72
73 %package devel
74 Summary:        Header files for ecasound libraries
75 Summary(pl):    Pliki nag³ówkowe bibliotek ecasound
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}
78 Requires:       libsamplerate-devel
79 Requires:       libstdc++-devel
80 Obsoletes:      libecasound-devel
81
82 %description devel
83 Header files for ecasound libraries.
84
85 %description devel -l pl
86 Pliki nag³ówkowe bibliotek ecasound.
87
88 %package static
89 Summary:        Static ecasound libraries
90 Summary(pl):    Statyczne biblioteki ecasound
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}
93 Obsoletes:      libecasound-static
94
95 %description static
96 Static ecasound libraries.
97
98 %description static -l pl
99 Statyczne biblioteki ecasound.
100
101 %package -n python-%{name}
102 Summary:        Python module for Ecasound
103 Summary(pl):    Modu³ jêzyka Python dla programu ecasound
104 Group:          Libraries/Python
105 Requires:       %{name} = %{version}
106 %pyrequires_eq  python-modules
107
108 %description -n python-%{name}
109 Python module for Ecasound.
110
111 %description -n python-%{name} -l pl
112 Modu³ jêzyka Python dla programu ecasound.
113
114 %package -n ruby-%{name}
115 Summary:        Ruby module for Ecasound
116 Summary(pl):    Modu³ jêzyka Ruby dla programu ecasound
117 Group:          Libraries
118 Requires:       %{name} = %{version}
119 %requires_eq    ruby
120
121 %description -n ruby-%{name}
122 Ruby module for Ecasound.
123
124 %description -n ruby-%{name} -l pl
125 Modu³ jêzyka Ruby dla programu ecasound.
126
127 %prep
128 %setup -q
129 %patch0 -p1
130
131 %build
132 %{__libtoolize}
133 %{__aclocal}
134 %{__autoconf}
135 %{__automake}
136 CXXFLAGS="%{rpmcflags} -D_REENTRANT %{!?debug:-DNDEBUG} -I/usr/include/ncurses"
137 # disable audiofile - ecasound has native support for wav and raw formats
138 # disable oss       - ecasound works nicely with alsa oss emulation;
139 #                     in case of alsa building conditional, the oss should
140 #                     be enabled
141 # disable arts      - 'not really useful' as said by ecasound author
142 %configure \
143         %{!?with_alsa:--disable-alsa} \
144         %{!?with_arts:--disable-arts} \
145         --disable-audiofile \
146         %{!?with_jack:--disable-jack} \
147         %{?with_alsa:--disable-oss} \
148         --enable-samplerate \
149         --enable-shared \
150         --enable-sys-readline \
151         --enable-pyecasound \
152         --with-largefile \
153         --with-python-includes=%{py_incdir} \
154         --with-python-modules=%{py_libdir}
155
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT%{py_sitedir}
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT \
164         mandir=%{_mandir}
165
166 install pyecasound/*.py $RPM_BUILD_ROOT%{py_sitedir}
167 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
168 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files
177 %defattr(644,root,root,755)
178 %doc BUGS NEWS README TODO
179 %attr(755,root,root) %{_bindir}/eca*
180 %attr(755,root,root) %{_libdir}/lib*.so.*.*
181 %{_datadir}/ecasound
182 %{_mandir}/man1/eca*
183 %{_mandir}/man5/eca*
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/*-config
188 %attr(755,root,root) %{_libdir}/lib*.so
189 %{_libdir}/lib*.la
190 %{_includedir}/kvutils
191 %{_includedir}/libecasound
192 %{_includedir}/libecasoundc
193
194 %files static
195 %defattr(644,root,root,755)
196 %{_libdir}/lib*.a
197
198 %files -n python-%{name}
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{py_sitedir}/*.so
201 %{py_sitedir}/*.py[co]
202
203 %files -n ruby-%{name}
204 %defattr(644,root,root,755)
205 %{ruby_sitelibdir}/ecasound.rb
This page took 0.065755 seconds and 3 git commands to generate.