]> git.pld-linux.org Git - packages/dx.git/blob - dx.spec
- rel 7
[packages/dx.git] / dx.spec
1 #
2 # TODO: - add samples
3 #
4 Summary:        Excellent tool for making visualization of data
5 Summary(pl):    Doskona³e narzêdzie do wizualizacji danych
6 Name:           dx
7 Version:        4.3.2
8 Release:        7
9 License:        IPL
10 Group:          Applications
11 Source0:        http://opendx.npaci.edu/source/%{name}-%{version}.tar.gz
12 # Source0-md5:  201afdd86a5ddcfda0dc60fc7b6d3fea
13 Source1:        http://opendx.npaci.edu/source/%{name}samples-%{version}.tar.gz
14 # Source1-md5:  940eece74fc2bf001a8017f9df18daac
15 Source2:        %{name}.desktop
16 Patch0:         %{name}-DESTDIR.patch
17 Patch1:         %{name}-nolibs.patch
18 Patch2:         dxsamples-DESTDIR.patch
19 URL:            http://www.opendx.org/
20 BuildRequires:  ImageMagick-devel
21 BuildRequires:  OpenGL-devel-base
22 BuildRequires:  autoconf >= 2.57
23 BuildRequires:  automake
24 BuildRequires:  bison
25 BuildRequires:  flex
26 BuildRequires:  hdf-devel
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libtool
29 BuildRequires:  libtiff-devel
30 BuildRequires:  motif-devel
31 BuildRequires:  netcdf-devel
32 Requires:       %{name}-libs = %{version}-%{release}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         specflags_ia32  -fomit-frame-pointer
36
37 %description
38 OpenDX is a uniquely powerful, full-featured software package for the
39 visualization of scientific, engineering and analytical data: Its open
40 system design is built on a standard interface environments. And its
41 sophisticated data model provides users with great flexibility in
42 creating visualizations.
43
44 %description -l pl
45 OpenDX jest w pe³ni funkcjonalnym, o unikalnych mo¿liwo¶ciach,
46 pakietem do wizualizacji danych naukowych, in¿ynierskich i
47 analitycznych. Zosta³ zaprojektowany w sposób otwarty, w oparciu o
48 standardowe ¶rodowiska interfejsów. Jego przemy¶lany model danych
49 daje u¿ytkownikom du¿± elastyczno¶æ w tworzeniu wizualizacji.
50
51 %package libs
52 Summary:        OpenDX shared libraries
53 Summary(pl):    Biblioteki wspó³dzielone OpenDX
54 Group:          Libraries
55
56 %description libs
57 OpenDX shared libraries.
58
59 %description libs -l pl
60 Biblioteki wspó³dzielone OpenDX.
61
62 %package devel
63 Summary:        OpenDX development files
64 Summary(pl):    Pliki nag³ówkowe OpenDX
65 Group:          Development/Libraries
66 Requires:       %{name}-libs = %{version}-%{release}
67
68 %description devel
69 OpenDX development files.
70
71 %description devel -l pl
72 Pliki nag³ówkowe OpenDX oraz inne pliki, potrzebne do budowania.
73
74 %package static
75 Summary:        OpenDX static libraries
76 Summary(pl):    Biblioteki statyczne OpenDX
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 OpenDX static libraries.
82
83 %description static -l pl
84 Biblioteki statyczne OpenDX.
85
86 %package doc
87 Summary:        OpenDX documentation
88 Summary(pl):    Dokumentacja OpenDX
89 Group:          Documentation
90
91 %description doc
92 Online help and html documentation for OpenDX.
93
94 %description doc -l pl
95 Podrêczna pomoc oraz dokumentacja html dla OpenDX.
96
97 %prep
98 %setup  -q
99 #%patch0 -p1
100 %patch1 -p1
101
102 %build
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoheader}
106 %{__autoconf}
107 %{__automake}
108 %configure \
109         --prefix=%{_datadir} \
110         --enable-shared \
111         --enable-static \
112         --disable-dependency-tracking \
113         --enable-smp-linux \
114         --enable-new-keylayout \
115         --without-javadx
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
126
127 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
128 install src/uipp/ui/icon50.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/dx.xpm
129 mv $RPM_BUILD_ROOT%{_datadir}/bin/dx $RPM_BUILD_ROOT%{_bindir}
130 mv $RPM_BUILD_ROOT%{_datadir}/dx/man/manl $RPM_BUILD_ROOT%{_mandir}
131 mv $RPM_BUILD_ROOT%{_datadir}/dx/include/* $RPM_BUILD_ROOT%{_includedir}
132 mv $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux $RPM_BUILD_ROOT%{_libdir}/dx
133 mv $RPM_BUILD_ROOT%{_datadir}/dx/bin_linux $RPM_BUILD_ROOT%{_libdir}/dx
134 ln -s %{_libdir}/dx $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux
135 ln -s %{_libdir}/dx/bin_linux $RPM_BUILD_ROOT%{_datadir}/dx
136 rm -rf $RPM_BUILD_ROOT%{_datadir}/{bin,dx/{bin/dx,man,include,doc}}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %doc doc/README*
144 %attr(755,root,root) %{_bindir}/*
145 %dir %{_datadir}/dx
146 %attr(755,root,root) %{_datadir}/dx/bin
147 %{_datadir}/dx/bin_linux
148 %{_datadir}/dx/fonts
149 %{_datadir}/dx/lib
150 %{_datadir}/dx/lib_linux
151 %{_datadir}/dx/ui
152 %{_mandir}/manl/*
153 %{_desktopdir}/*
154 %{_pixmapsdir}/*
155
156 %files libs
157 %defattr(644,root,root,755)
158 %dir %{_libdir}/dx
159 %attr(755,root,root) %{_libdir}/dx/bin_linux
160 %attr(755,root,root) %{_libdir}/dx/lib*.so.*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %{_includedir}/*
165 %{_libdir}/dx/*.mak
166 %{_libdir}/dx/*.la
167 %{_libdir}/dx/*.so
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/dx/*.a
172
173 %files doc
174 %defattr(644,root,root,755)
175 %{_datadir}/dx/h*
This page took 0.038939 seconds and 4 git commands to generate.