]> git.pld-linux.org Git - packages/dx.git/blob - dx.spec
- rel 11
[packages/dx.git] / dx.spec
1 Summary:        Excellent tool for making visualization of data
2 Summary(pl.UTF-8):      Doskonałe narzędzie do wizualizacji danych
3 Name:           dx
4 Version:        4.4.4
5 Release:        11
6 License:        IPL
7 Group:          Applications
8 Source0:        http://opendx.npaci.edu/source/%{name}-%{version}.tar.gz
9 # Source0-md5:  6da0c4cd21d3c08f97b7662e3aee5b7b
10 Source1:        http://opendx.npaci.edu/source/%{name}samples-4.4.0.tar.gz
11 # Source1-md5:  e8f43722ca0a66282608bded7c0e4f93
12 Source2:        %{name}.desktop
13 Patch0:         %{name}-DESTDIR.patch
14 Patch1:         %{name}-nolibs.patch
15 Patch2:         dxsamples-DESTDIR.patch
16 Patch3:         dxsamples-unused_bin.patch
17 Patch4:         %{name}-include.patch
18 Patch5:         %{name}-ac.patch
19 Patch6:         %{name}-ImageMagic.patch
20 Patch7:         %{name}-open.patch
21 Patch8:         %{name}-gcc43.patch
22 URL:            http://www.opendx.org/
23 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  OpenGL-GLU-devel
26 BuildRequires:  autoconf >= 2.57
27 BuildRequires:  automake
28 BuildRequires:  bison
29 BuildRequires:  flex
30 BuildRequires:  hdf-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libtool
33 BuildRequires:  libtiff-devel
34 BuildRequires:  motif-devel
35 BuildRequires:  netcdf-devel
36 BuildRequires:  xorg-lib-libXinerama-devel
37 BuildRequires:  xorg-lib-libXpm-devel
38 Requires:       openssh-clients
39 Requires:       %{name}-libs = %{version}-%{release}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         specflags_ia32  -fomit-frame-pointer
43 %define         skip_post_check_so      libDXL.so.*
44
45 %description
46 OpenDX is a uniquely powerful, full-featured software package for the
47 visualization of scientific, engineering and analytical data: Its open
48 system design is built on a standard interface environments. And its
49 sophisticated data model provides users with great flexibility in
50 creating visualizations.
51
52 %description -l pl.UTF-8
53 OpenDX jest w pełni funkcjonalnym, o unikalnych możliwościach,
54 pakietem do wizualizacji danych naukowych, inżynierskich i
55 analitycznych. Został zaprojektowany w sposób otwarty, w oparciu o
56 standardowe środowiska interfejsów. Jego przemyślany model danych
57 daje użytkownikom dużą elastyczność w tworzeniu wizualizacji.
58
59 %package libs
60 Summary:        OpenDX shared libraries
61 Summary(pl.UTF-8):      Biblioteki współdzielone OpenDX
62 Group:          Libraries
63
64 %description libs
65 OpenDX shared libraries.
66
67 %description libs -l pl.UTF-8
68 Biblioteki współdzielone OpenDX.
69
70 %package devel
71 Summary:        OpenDX development files
72 Summary(pl.UTF-8):      Pliki nagłówkowe OpenDX
73 Group:          Development/Libraries
74 Requires:       %{name}-libs = %{version}-%{release}
75
76 %description devel
77 OpenDX development files.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe OpenDX oraz inne pliki, potrzebne do budowania.
81
82 %package static
83 Summary:        OpenDX static libraries
84 Summary(pl.UTF-8):      Biblioteki statyczne OpenDX
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 OpenDX static libraries.
90
91 %description static -l pl.UTF-8
92 Biblioteki statyczne OpenDX.
93
94 %package doc
95 Summary:        OpenDX documentation
96 Summary(pl.UTF-8):      Dokumentacja OpenDX
97 Group:          Documentation
98
99 %description doc
100 Online help and html documentation for OpenDX.
101
102 %description doc -l pl.UTF-8
103 Podręczna pomoc oraz dokumentacja html dla OpenDX.
104
105 %package examples
106 Summary:        OpenDX Examples
107 Summary(pl.UTF-8):      Przykłady dla OpenDX
108 Group:          Documentation
109
110 %description examples
111 Examples for OpenDX.
112
113 %description examples -l pl.UTF-8
114 Przykłady dla OpenDX.
115
116 %prep
117 %setup  -q -a 1
118 #%patch0 -p1
119 %patch1 -p1
120 %patch2 -p0
121 %patch3 -p1
122 %patch4 -p1
123 %patch5 -p1
124 %patch6 -p1
125 %patch7 -p1
126 %patch8 -p1
127
128 %build
129 %{__libtoolize}
130 %{__aclocal} -I m4
131 %{__autoheader}
132 %{__autoconf}
133 %{__automake}
134 %configure \
135         --prefix=%{_datadir} \
136         --enable-shared \
137         --enable-static \
138         --disable-dependency-tracking \
139         --enable-smp-linux \
140         --enable-new-keylayout \
141         --without-javadx \
142         --with-rsh=%{_bindir}/ssh
143
144 cd %{name}samples-4.4.0
145 %{__aclocal}
146 %{__autoheader}
147 %{__autoconf}
148 %{__automake}
149 %configure \
150         --prefix=%{_examplesdir} \
151         --without-javadx
152 cd ..
153
154 %{__make} -j1
155
156 %{__make} -j1 -C %{name}samples-4.4.0
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %{__make} -C %{name}samples-4.4.0 install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
168 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
169
170 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
171 install src/uipp/ui/icon50.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/dx.xpm
172 mv $RPM_BUILD_ROOT%{_datadir}/bin/dx $RPM_BUILD_ROOT%{_bindir}
173 mv $RPM_BUILD_ROOT%{_datadir}/dx/man/manl $RPM_BUILD_ROOT%{_mandir}
174 mv $RPM_BUILD_ROOT%{_datadir}/dx/include/* $RPM_BUILD_ROOT%{_includedir}
175 mv $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux $RPM_BUILD_ROOT%{_libdir}/dx
176 mv $RPM_BUILD_ROOT%{_datadir}/dx/bin_linux $RPM_BUILD_ROOT%{_libdir}/dx
177 mv $RPM_BUILD_ROOT%{_examplesdir}/dx/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
178 ln -s %{_libdir}/dx $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux
179 ln -s %{_libdir}/dx/bin_linux $RPM_BUILD_ROOT%{_datadir}/dx
180 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{bin,dx/{bin/dx,man,include,doc}}
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %files
186 %defattr(644,root,root,755)
187 %doc doc/README*
188 %attr(755,root,root) %{_bindir}/*
189 %dir %{_datadir}/dx
190 %attr(755,root,root) %{_datadir}/dx/bin
191 %{_datadir}/dx/bin_linux
192 %{_datadir}/dx/fonts
193 %{_datadir}/dx/lib
194 %{_datadir}/dx/lib_linux
195 %{_datadir}/dx/ui
196 %{_mandir}/manl/*
197 %{_desktopdir}/*.desktop
198 %{_pixmapsdir}/*
199
200 %files libs
201 %defattr(644,root,root,755)
202 %dir %{_libdir}/dx
203 %attr(755,root,root) %{_libdir}/dx/bin_linux
204 %attr(755,root,root) %{_libdir}/dx/lib*.so.*
205
206 %files devel
207 %defattr(644,root,root,755)
208 %{_includedir}/*
209 %{_libdir}/dx/*.mak
210 %{_libdir}/dx/*.la
211 %{_libdir}/dx/*.so
212
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/dx/*.a
216
217 %files doc
218 %defattr(644,root,root,755)
219 %{_datadir}/dx/h*
220
221 %files examples
222 %defattr(644,root,root,755)
223 %{_examplesdir}/%{name}-%{version}
This page took 0.070485 seconds and 4 git commands to generate.