]> git.pld-linux.org Git - packages/dx.git/blob - dx.spec
- reverted last change, added required symlink
[packages/dx.git] / dx.spec
1 #
2 # TODO: - add samples
3 #       - make static subpackage
4 #
5 Summary:        Excellent tool for making visualization of data
6 Summary(pl):    Doskona³e narzêdzie do wizualizacji danych
7 Name:           dx
8 Version:        4.3.2
9 Release:        2
10 License:        IPL
11 Group:          Applications
12 Source0:        http://opendx.npaci.edu/source/%{name}-%{version}.tar.gz
13 # Source0-md5:  201afdd86a5ddcfda0dc60fc7b6d3fea
14 Source1:        http://opendx.npaci.edu/source/%{name}samples-%{version}.tar.gz
15 # Source1-md5:  940eece74fc2bf001a8017f9df18daac
16 Patch0:         %{name}-DESTDIR.patch
17 URL:            http://www.opendx.org/
18 BuildRequires:  ImageMagick-devel
19 BuildRequires:  OpenGL-devel-base
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  flex
24 BuildRequires:  hdf-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libtool
27 BuildRequires:  libtiff-devel
28 BuildRequires:  motif-devel
29 BuildRequires:  netcdf-devel
30 Requires:       %{name}-libs = %{version}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         specflags_ia32  -fomit-frame-pointer
34
35 %description
36 OpenDX is a uniquely powerful, full-featured software package for the
37 visualization of scientific, engineering and analytical data: Its open
38 system design is built on a standard interface environments. And its
39 sophisticated data model provides users with great flexibility in
40 creating visualizations.
41
42 %description -l pl
43 OpenDX jest w pe³ni funkcjonalnym, o unikalnych mo¿liwo¶ciach,
44 pakietem do wizualizacji danych naukowych, in¿ynierskich i
45 analitycznych. Zosta³ zaprojektowany w sposób otwarty, w oparciu o
46 standardowe ¶rodowiska interfejstów. Jego przemy¶lany model danych
47 daje u¿ytkownikom du¿± elastyczno¶æ w tworzeniu wizualizacji.
48
49 %package libs
50 Summary:        OpenDX shared libraries
51 Summary(pl):    Biblioteki wspó³dzielone OpenDX
52 Group:          Libraries
53
54 %description libs
55 OpenDX shared libraries.
56
57 %description libs -l pl
58 Biblioteki wspó³dzielone OpenDX.
59
60 %package devel
61 Summary:        OpenDX development files
62 Summary(pl):    Pliki nag³ówkowe OpenDX
63 Group:          Development/Libraries
64 Requires:       %{name}-libs = %{version}
65
66 %description devel
67 OpenDX development files.
68
69 %description devel -l pl
70 Pliki nag³ówkowe OpenDX oraz inne pliki, potrzebne do budowania.
71
72 %package doc
73 Summary:        OpenDX documentation
74 Summary(pl):    Dokumentacja OpenDX
75 Group:          Documentation
76
77 %description doc
78 Online help and html documentation for OpenDX.
79
80 %description doc -l pl
81 Podrêczna pomoc oraz dokumentacja html dla OpenDX.
82
83 %prep
84 %setup  -q
85 #%patch0 -p1
86
87 %build
88 rm -f missing aclocal.m4
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoheader}
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         --prefix=%{_datadir} \
96         --enable-shared \
97         --disable-static \
98         --disable-dependency-tracking \
99         --enable-smp-linux \
100         --enable-new-keylayout \
101         --without-javadx
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_mandir}} \
112         $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
113
114 mv $RPM_BUILD_ROOT%{_datadir}/bin/dx $RPM_BUILD_ROOT%{_bindir}
115 mv $RPM_BUILD_ROOT%{_datadir}/dx/man/manl $RPM_BUILD_ROOT%{_mandir}
116 mv $RPM_BUILD_ROOT%{_datadir}/dx/include/* $RPM_BUILD_ROOT%{_includedir}
117 mv $RPM_BUILD_ROOT%{_datadir}/dx/h* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
118 mv $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux $RPM_BUILD_ROOT%{_libdir}/dx
119 mv $RPM_BUILD_ROOT%{_datadir}/dx/bin_linux $RPM_BUILD_ROOT%{_libdir}/dx
120 ln -s %{_libdir}/dx $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux
121 ln -s %{_libdir}/dx/bin_linux $RPM_BUILD_ROOT%{_datadir}/dx
122 ln -s %{_docdir}/%{name}-doc-%{version}/help $RPM_BUILD_ROOT%{_datadir}/dx/help
123 ln -s %{_docdir}/%{name}-doc-%{version}/html $RPM_BUILD_ROOT%{_datadir}/dx/html
124 rm -rf $RPM_BUILD_ROOT%{_datadir}/{bin,dx/{bin/dx,man,include,doc}}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/*
132 %dir %{_datadir}/dx
133 %attr(755,root,root) %{_datadir}/dx/bin
134 %{_datadir}/dx/bin_linux
135 %{_datadir}/dx/fonts
136 %{_datadir}/dx/lib
137 %{_datadir}/dx/lib_linux
138 %{_datadir}/dx/ui
139 %doc doc/README*
140 %{_mandir}/manl/*
141
142 %files libs
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/*
145 %exclude %{_libdir}/dx/*.mak
146 %exclude %{_libdir}/dx/*.la
147 %exclude %{_libdir}/dx/*.so
148
149 %files devel
150 %defattr(644,root,root,755)
151 %{_includedir}/*
152 %{_libdir}/dx/*.mak
153 %{_libdir}/dx/*.la
154 %{_libdir}/dx/*.so
155
156 %files doc
157 %defattr(644,root,root,755)
158 %{_docdir}/%{name}-doc-%{version}
159 %{_datadir}/dx/h*
This page took 0.077701 seconds and 4 git commands to generate.