]> git.pld-linux.org Git - packages/dx.git/blob - dx.spec
- ImageMagick renamed it's function from DestroyConstitute to ConstituteComponentTerm...
[packages/dx.git] / dx.spec
1 Summary:        Excellent tool for making visualization of data
2 Summary(pl.UTF-8):      Doskonałe narzędzie do wizualizacji danych
3 Name:           dx
4 Version:        4.4.4
5 Release:        8
6 License:        IPL
7 Group:          Applications
8 Source0:        http://opendx.npaci.edu/source/%{name}-%{version}.tar.gz
9 # Source0-md5:  6da0c4cd21d3c08f97b7662e3aee5b7b
10 Source1:        http://opendx.npaci.edu/source/%{name}samples-4.4.0.tar.gz
11 # Source1-md5:  e8f43722ca0a66282608bded7c0e4f93
12 Source2:        %{name}.desktop
13 Patch0:         %{name}-DESTDIR.patch
14 Patch1:         %{name}-nolibs.patch
15 Patch2:         dxsamples-DESTDIR.patch
16 Patch3:         dxsamples-unused_bin.patch
17 Patch4:         %{name}-include.patch
18 Patch5:         %{name}-ac.patch
19 Patch6:         %{name}-ImageMagic.patch
20 Patch7:         %{name}-open.patch
21 Patch8:         %{name}-gcc43.patch
22 URL:            http://www.opendx.org/
23 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  OpenGL-GLU-devel
26 BuildRequires:  autoconf >= 2.57
27 BuildRequires:  automake
28 BuildRequires:  bison
29 BuildRequires:  flex
30 BuildRequires:  hdf-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libtool
33 BuildRequires:  libtiff-devel
34 BuildRequires:  motif-devel
35 BuildRequires:  netcdf-devel
36 BuildRequires:  xorg-lib-libXinerama-devel
37 BuildRequires:  xorg-lib-libXpm-devel
38 Requires:       openssh-clients
39 Requires:       %{name}-libs = %{version}-%{release}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         specflags_ia32  -fomit-frame-pointer
43
44 %description
45 OpenDX is a uniquely powerful, full-featured software package for the
46 visualization of scientific, engineering and analytical data: Its open
47 system design is built on a standard interface environments. And its
48 sophisticated data model provides users with great flexibility in
49 creating visualizations.
50
51 %description -l pl.UTF-8
52 OpenDX jest w pełni funkcjonalnym, o unikalnych możliwościach,
53 pakietem do wizualizacji danych naukowych, inżynierskich i
54 analitycznych. Został zaprojektowany w sposób otwarty, w oparciu o
55 standardowe środowiska interfejsów. Jego przemyślany model danych
56 daje użytkownikom dużą elastyczność w tworzeniu wizualizacji.
57
58 %package libs
59 Summary:        OpenDX shared libraries
60 Summary(pl.UTF-8):      Biblioteki współdzielone OpenDX
61 Group:          Libraries
62
63 %description libs
64 OpenDX shared libraries.
65
66 %description libs -l pl.UTF-8
67 Biblioteki współdzielone OpenDX.
68
69 %package devel
70 Summary:        OpenDX development files
71 Summary(pl.UTF-8):      Pliki nagłówkowe OpenDX
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74
75 %description devel
76 OpenDX development files.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe OpenDX oraz inne pliki, potrzebne do budowania.
80
81 %package static
82 Summary:        OpenDX static libraries
83 Summary(pl.UTF-8):      Biblioteki statyczne OpenDX
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 OpenDX static libraries.
89
90 %description static -l pl.UTF-8
91 Biblioteki statyczne OpenDX.
92
93 %package doc
94 Summary:        OpenDX documentation
95 Summary(pl.UTF-8):      Dokumentacja OpenDX
96 Group:          Documentation
97
98 %description doc
99 Online help and html documentation for OpenDX.
100
101 %description doc -l pl.UTF-8
102 Podręczna pomoc oraz dokumentacja html dla OpenDX.
103
104 %package examples
105 Summary:        OpenDX Examples
106 Summary(pl.UTF-8):      Przykłady dla OpenDX
107 Group:          Documentation
108
109 %description examples
110 Examples for OpenDX.
111
112 %description examples -l pl.UTF-8
113 Przykłady dla OpenDX.
114
115 %prep
116 %setup  -q -a 1
117 #%patch0 -p1
118 %patch1 -p1
119 %patch2 -p0
120 %patch3 -p1
121 %patch4 -p1
122 %patch5 -p1
123 %patch6 -p1
124 %patch7 -p1
125 %patch8 -p1
126
127 %build
128 %{__libtoolize}
129 %{__aclocal} -I m4
130 %{__autoheader}
131 %{__autoconf}
132 %{__automake}
133 %configure \
134         --prefix=%{_datadir} \
135         --enable-shared \
136         --enable-static \
137         --disable-dependency-tracking \
138         --enable-smp-linux \
139         --enable-new-keylayout \
140         --without-javadx \
141         --with-rsh=%{_bindir}/ssh
142
143 cd %{name}samples-4.4.0
144 %{__aclocal}
145 %{__autoheader}
146 %{__autoconf}
147 %{__automake}
148 %configure \
149         --prefix=%{_examplesdir} \
150         --without-javadx
151 cd ..
152
153 %{__make} -j1
154
155 %{__make} -j1 -C %{name}samples-4.4.0
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159
160 %{__make} install \
161         DESTDIR=$RPM_BUILD_ROOT
162
163 %{__make} -C %{name}samples-4.4.0 install \
164         DESTDIR=$RPM_BUILD_ROOT
165
166 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
167 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
168
169 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
170 install src/uipp/ui/icon50.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/dx.xpm
171 mv $RPM_BUILD_ROOT%{_datadir}/bin/dx $RPM_BUILD_ROOT%{_bindir}
172 mv $RPM_BUILD_ROOT%{_datadir}/dx/man/manl $RPM_BUILD_ROOT%{_mandir}
173 mv $RPM_BUILD_ROOT%{_datadir}/dx/include/* $RPM_BUILD_ROOT%{_includedir}
174 mv $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux $RPM_BUILD_ROOT%{_libdir}/dx
175 mv $RPM_BUILD_ROOT%{_datadir}/dx/bin_linux $RPM_BUILD_ROOT%{_libdir}/dx
176 mv $RPM_BUILD_ROOT%{_examplesdir}/dx/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
177 ln -s %{_libdir}/dx $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux
178 ln -s %{_libdir}/dx/bin_linux $RPM_BUILD_ROOT%{_datadir}/dx
179 rm -rf $RPM_BUILD_ROOT%{_datadir}/{bin,dx/{bin/dx,man,include,doc}}
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %doc doc/README*
187 %attr(755,root,root) %{_bindir}/*
188 %dir %{_datadir}/dx
189 %attr(755,root,root) %{_datadir}/dx/bin
190 %{_datadir}/dx/bin_linux
191 %{_datadir}/dx/fonts
192 %{_datadir}/dx/lib
193 %{_datadir}/dx/lib_linux
194 %{_datadir}/dx/ui
195 %{_mandir}/manl/*
196 %{_desktopdir}/*.desktop
197 %{_pixmapsdir}/*
198
199 %files libs
200 %defattr(644,root,root,755)
201 %dir %{_libdir}/dx
202 %attr(755,root,root) %{_libdir}/dx/bin_linux
203 %attr(755,root,root) %{_libdir}/dx/lib*.so.*
204
205 %files devel
206 %defattr(644,root,root,755)
207 %{_includedir}/*
208 %{_libdir}/dx/*.mak
209 %{_libdir}/dx/*.la
210 %{_libdir}/dx/*.so
211
212 %files static
213 %defattr(644,root,root,755)
214 %{_libdir}/dx/*.a
215
216 %files doc
217 %defattr(644,root,root,755)
218 %{_datadir}/dx/h*
219
220 %files examples
221 %defattr(644,root,root,755)
222 %{_examplesdir}/%{name}-%{version}
This page took 0.048292 seconds and 4 git commands to generate.