]> git.pld-linux.org Git - packages/dx.git/blob - dx.spec
- fixed packing examples
[packages/dx.git] / dx.spec
1 Summary:        Excellent tool for making visualization of data
2 Summary(pl):    Doskona³e narzêdzie do wizualizacji danych
3 Name:           dx
4 Version:        4.3.2
5 Release:        9
6 License:        IPL
7 Group:          Applications
8 Source0:        http://opendx.npaci.edu/source/%{name}-%{version}.tar.gz
9 # Source0-md5:  201afdd86a5ddcfda0dc60fc7b6d3fea
10 Source1:        http://opendx.npaci.edu/source/%{name}samples-%{version}.tar.gz
11 # Source1-md5:  940eece74fc2bf001a8017f9df18daac
12 Source2:        %{name}.desktop
13 Patch0:         %{name}-DESTDIR.patch
14 Patch1:         %{name}-nolibs.patch
15 Patch2:         dxsamples-DESTDIR.patch
16 Patch3:         dxsamples-unused_bin.patch
17 URL:            http://www.opendx.org/
18 BuildRequires:  ImageMagick-devel >= 1:6.2.4.0
19 BuildRequires:  OpenGL-devel-base
20 BuildRequires:  autoconf >= 2.57
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  flex
24 BuildRequires:  hdf-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libtool
27 BuildRequires:  libtiff-devel
28 BuildRequires:  motif-devel
29 BuildRequires:  netcdf-devel
30 Requires:       %{name}-libs = %{version}-%{release}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         specflags_ia32  -fomit-frame-pointer
34
35 %description
36 OpenDX is a uniquely powerful, full-featured software package for the
37 visualization of scientific, engineering and analytical data: Its open
38 system design is built on a standard interface environments. And its
39 sophisticated data model provides users with great flexibility in
40 creating visualizations.
41
42 %description -l pl
43 OpenDX jest w pe³ni funkcjonalnym, o unikalnych mo¿liwo¶ciach,
44 pakietem do wizualizacji danych naukowych, in¿ynierskich i
45 analitycznych. Zosta³ zaprojektowany w sposób otwarty, w oparciu o
46 standardowe ¶rodowiska interfejsów. Jego przemy¶lany model danych
47 daje u¿ytkownikom du¿± elastyczno¶æ w tworzeniu wizualizacji.
48
49 %package libs
50 Summary:        OpenDX shared libraries
51 Summary(pl):    Biblioteki wspó³dzielone OpenDX
52 Group:          Libraries
53
54 %description libs
55 OpenDX shared libraries.
56
57 %description libs -l pl
58 Biblioteki wspó³dzielone OpenDX.
59
60 %package devel
61 Summary:        OpenDX development files
62 Summary(pl):    Pliki nag³ówkowe OpenDX
63 Group:          Development/Libraries
64 Requires:       %{name}-libs = %{version}-%{release}
65
66 %description devel
67 OpenDX development files.
68
69 %description devel -l pl
70 Pliki nag³ówkowe OpenDX oraz inne pliki, potrzebne do budowania.
71
72 %package static
73 Summary:        OpenDX static libraries
74 Summary(pl):    Biblioteki statyczne OpenDX
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 OpenDX static libraries.
80
81 %description static -l pl
82 Biblioteki statyczne OpenDX.
83
84 %package doc
85 Summary:        OpenDX documentation
86 Summary(pl):    Dokumentacja OpenDX
87 Group:          Documentation
88
89 %description doc
90 Online help and html documentation for OpenDX.
91
92 %description doc -l pl
93 Podrêczna pomoc oraz dokumentacja html dla OpenDX.
94
95 %package examples
96 Summary:        OpenDX Examples
97 Summary(pl):    Przyk³ady dla OpenDX
98 Group:          Documentation
99
100 %description examples
101 Examples for OpenDX.
102
103 %description examples -l pl
104 Przyk³ady dla OpenDX.
105
106 %prep
107 %setup  -q -a 1
108 #%patch0 -p1
109 %patch1 -p1
110 %patch2 -p0
111 %patch3 -p1
112
113 %build
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoheader}
117 %{__autoconf}
118 %{__automake}
119 %configure \
120         --prefix=%{_datadir} \
121         --enable-shared \
122         --enable-static \
123         --disable-dependency-tracking \
124         --enable-smp-linux \
125         --enable-new-keylayout \
126         --without-javadx
127
128 cd %{name}samples-%{version}
129 %{__aclocal}
130 %{__autoheader}
131 %{__autoconf}
132 %{__automake}
133 %configure \
134         --prefix=%{_examplesdir} \
135         --without-javadx
136 cd ..
137
138 %{__make}
139
140 cd %{name}samples-%{version}
141 %{__make}
142 cd ..
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 cd %{name}samples-%{version}
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT
153 cd ..
154
155 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
156 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
157
158 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
159 install src/uipp/ui/icon50.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/dx.xpm
160 mv $RPM_BUILD_ROOT%{_datadir}/bin/dx $RPM_BUILD_ROOT%{_bindir}
161 mv $RPM_BUILD_ROOT%{_datadir}/dx/man/manl $RPM_BUILD_ROOT%{_mandir}
162 mv $RPM_BUILD_ROOT%{_datadir}/dx/include/* $RPM_BUILD_ROOT%{_includedir}
163 mv $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux $RPM_BUILD_ROOT%{_libdir}/dx
164 mv $RPM_BUILD_ROOT%{_datadir}/dx/bin_linux $RPM_BUILD_ROOT%{_libdir}/dx
165 mv $RPM_BUILD_ROOT%{_examplesdir}/dx/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
166 ln -s %{_libdir}/dx $RPM_BUILD_ROOT%{_datadir}/dx/lib_linux
167 ln -s %{_libdir}/dx/bin_linux $RPM_BUILD_ROOT%{_datadir}/dx
168 rm -rf $RPM_BUILD_ROOT%{_datadir}/{bin,dx/{bin/dx,man,include,doc}}
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %files
174 %defattr(644,root,root,755)
175 %doc doc/README*
176 %attr(755,root,root) %{_bindir}/*
177 %dir %{_datadir}/dx
178 %attr(755,root,root) %{_datadir}/dx/bin
179 %{_datadir}/dx/bin_linux
180 %{_datadir}/dx/fonts
181 %{_datadir}/dx/lib
182 %{_datadir}/dx/lib_linux
183 %{_datadir}/dx/ui
184 %{_mandir}/manl/*
185 %{_desktopdir}/*
186 %{_pixmapsdir}/*
187
188 %files libs
189 %defattr(644,root,root,755)
190 %dir %{_libdir}/dx
191 %attr(755,root,root) %{_libdir}/dx/bin_linux
192 %attr(755,root,root) %{_libdir}/dx/lib*.so.*
193
194 %files devel
195 %defattr(644,root,root,755)
196 %{_includedir}/*
197 %{_libdir}/dx/*.mak
198 %{_libdir}/dx/*.la
199 %{_libdir}/dx/*.so
200
201 %files static
202 %defattr(644,root,root,755)
203 %{_libdir}/dx/*.a
204
205 %files doc
206 %defattr(644,root,root,755)
207 %{_datadir}/dx/h*
208
209 %files examples
210 %defattr(644,root,root,755)
211 %{_examplesdir}/%{name}-%{version}
This page took 0.196664 seconds and 3 git commands to generate.