]> git.pld-linux.org Git - packages/dtc.git/blob - dtc.spec
8190a9f7ff8c45f195521b14315585b554435056
[packages/dtc.git] / dtc.spec
1 # Conditional build:
2 %bcond_without  verbose         # verbose build (V=1)
3
4 Summary:        The Device Tree Compiler
5 Name:           dtc
6 Version:        1.1.0
7 Release:        0.1
8 License:        GPL v2 (dtc), GPL/BSD (fdt library)
9 Group:          Libraries
10 Source0:        http://www.jdl.com/software/%{name}-v%{version}.tgz
11 # Source0-md5:  46bcff355b60d85bd311fc95b9ff0630
12 URL:            http://git.jdl.com/gitweb/
13 BuildRequires:  bison
14 BuildRequires:  flex
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %{?debug:%define with_verbose 1}
18
19 %description
20 The Device Tree Compiler, dtc, takes as input a device-tree in a given
21 format and outputs a device-tree in another format. Typically, the
22 input format is "dts", a human readable source format, and creates a
23 "dtb", or binary format as output.
24
25 %package devel
26 Summary:        Header files for fdt library
27 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki fdt
28 Group:          Development/Libraries
29 # does not require base. see README.license
30
31 %description devel
32 Header files for fdt library.
33
34 %description devel -l pl.UTF-8
35 Pliki nagłówkowe biblioteki fdt.
36
37 %package static
38 Summary:        Static fdt library
39 Summary(pl.UTF-8):      Statyczna biblioteka fdt
40 Group:          Development/Libraries
41 Requires:       %{name}-devel = %{version}-%{release}
42
43 %description static
44 Static fdt library.
45
46 %description static -l pl.UTF-8
47 Statyczna biblioteka fdt.
48
49 %prep
50 %setup -q -n %{name}-v%{version}
51
52 %build
53 %{__make} \
54         %{?with_verbose:V=1} \
55         CC="%{__cc}" \
56         CFLAGS="%{rpmcflags}"
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} install \
61         %{?with_verbose:V=1} \
62         PREFIX=%{_prefix} \
63         LIBDIR=%{_libdir} \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc TODO README.license Documentation/manual.txt
72 %attr(755,root,root) %{_bindir}/dtc
73
74 %files devel
75 %defattr(644,root,root,755)
76 %doc README.license
77 %{_includedir}/fdt.h
78 %{_includedir}/libfdt.h
79
80 %files static
81 %defattr(644,root,root,755)
82 %{_libdir}/libfdt.a
This page took 0.024914 seconds and 3 git commands to generate.