]> git.pld-linux.org Git - packages/dtc.git/blob - dtc.spec
246253d5c047b84681915120934da8edaa7ef87f
[packages/dtc.git] / dtc.spec
1 #
2 # Conditional build:
3 %bcond_without  verbose         # verbose build (V=1)
4
5 Summary:        The Device Tree Compiler
6 Summary(pl.UTF-8):      Kompilator drzewiastej struktury urządzeń
7 Name:           dtc
8 Version:        1.4.4
9 Release:        1
10 License:        GPL v2+ (dtc), GPL v2+ or BSD (fdt library)
11 Group:          Libraries
12 Source0:        https://www.kernel.org/pub/software/utils/dtc/%{name}-%{version}.tar.xz
13 # Source0-md5:  290318bab4d9e61e7fb7426b4666ad4d
14 URL:            http://www.devicetree.org/Device_Tree_Compiler
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  tar >= 1:1.22
18 BuildRequires:  xz
19 Requires:       libfdt = %{version}-%{release}
20 Obsoletes:      dtc-doc < 1.3.0-2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %{?debug:%define with_verbose 1}
24
25 %description
26 The Device Tree Compiler, dtc, takes as input a device-tree in a given
27 format and outputs a device-tree in another format. Typically, the
28 input format is "dts", a human readable source format, and creates a
29 "dtb", or binary format as output.
30
31 %description -l pl.UTF-8
32 Kompilator drzewiastej struktury urządzeń, dtc, przyjmuje na wejściu
33 dane w jednym formacie by na wyjściu wyprodukować strukturę danych w
34 innym. Najczęściej format wejściowy to "dts", intuicyjny i łatwy w
35 odczycie (tzw. human readable), natomiast wyjściowy to "dtb" lub
36 inaczej format binarny.
37
38 %package -n libfdt
39 Summary:        Device tree library
40 Summary(pl.UTF-8):      Biblioteka drzewiastej struktury urządzeń
41 License:        GPL v2+ or BSD
42 Group:          Libraries
43 Obsoletes:      dtc-doc < 1.3.0-2
44 # does not require base. see README.license
45
46 %description -n libfdt
47 Device tree library.
48
49 %description -n libfdt -l pl.UTF-8
50 Biblioteka drzewiastej struktury urządzeń.
51
52 %package -n libfdt-devel
53 Summary:        Header files for fdt library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki fdt
55 License:        GPL v2+ or BSD
56 Group:          Development/Libraries
57 Requires:       libfdt = %{version}-%{release}
58 Obsoletes:      dtc-devel
59 Obsoletes:      dtc-doc < 1.3.0-2
60
61 %description -n libfdt-devel
62 Header files for fdt library.
63
64 %description -n libfdt-devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki fdt.
66
67 %package -n libfdt-static
68 Summary:        Static fdt library
69 Summary(pl.UTF-8):      Statyczna biblioteka fdt
70 License:        GPL v2+ or BSD
71 Group:          Development/Libraries
72 Requires:       libfdt-devel = %{version}-%{release}
73 Obsoletes:      dtc-static
74
75 %description -n libfdt-static
76 Static fdt library.
77
78 %description -n libfdt-static -l pl.UTF-8
79 Statyczna biblioteka fdt.
80
81 %prep
82 %setup -q
83
84 %build
85 %{__make} \
86         %{?with_verbose:V=1} \
87         CC="%{__cc}" \
88         CFLAGS="%{rpmcflags} -fPIC"
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT \
94         %{?with_verbose:V=1} \
95         PREFIX=%{_prefix} \
96         LIBDIR=%{_libdir}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -n libfdt -p /sbin/ldconfig
102 %postun -n libfdt -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc README README.license
107 %attr(755,root,root) %{_bindir}/convert-dtsv0
108 %attr(755,root,root) %{_bindir}/dtc
109 %attr(755,root,root) %{_bindir}/dtdiff
110 %attr(755,root,root) %{_bindir}/fdtdump
111 %attr(755,root,root) %{_bindir}/fdtget
112 %attr(755,root,root) %{_bindir}/fdtput
113
114 %files -n libfdt
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libfdt-%{version}.so
117 %attr(755,root,root) %ghost %{_libdir}/libfdt.so.1
118
119 %files -n libfdt-devel
120 %defattr(644,root,root,755)
121 %doc TODO Documentation/manual.txt
122 %attr(755,root,root) %{_libdir}/libfdt.so
123 %{_includedir}/fdt.h
124 %{_includedir}/libfdt.h
125 %{_includedir}/libfdt_env.h
126
127 %files -n libfdt-static
128 %defattr(644,root,root,755)
129 %{_libdir}/libfdt.a
This page took 0.070485 seconds and 3 git commands to generate.