]> git.pld-linux.org Git - packages/dss.git/blob - dss.spec
edff5d5f50e785d130e0dcad4307cf379d617a9f
[packages/dss.git] / dss.spec
1 Summary:        Darwin Streaming Server
2 Name:           dss
3 Version:        6.0.3
4 Release:        0.1
5 License:        Apple Public Source License
6 Group:          Applications
7 Source0:        http://dss.macosforge.org/downloads/DarwinStreamingSrvr%{version}-Source.tar
8 # Source0-md5:  ca676691db8417d05121699c0ca3d549
9 Patch0:         %{name}.patch
10 Patch1:         %{name}-x86_64.patch
11 URL:            http://dss.macosforge.org/
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Darwin Streaming Server lets you stream digital video on the Internet
16 using industry-standard Internet protocols RTP and RTSP.
17
18 Using Darwin Streaming Server you can serve stored files (video on
19 demand) or reflect live broadcasts to thousands of QuickTime 4 or
20 later users. With its combination of industry-standard streaming
21 protocols and cutting-edge compression technologies, QuickTime
22 delivers perfectly synchronized audio and video streams ideal for
23 Internet video and live events.
24
25 %package Proxy
26 Summary:        Apple's Darwin Streaming Proxy
27 Group:          Daemons
28
29 %description Proxy
30 The Darwin Streaming Proxy is an application specific proxy which
31 would normally be run in a border zone or perimeter network. It is
32 used to give client machines within a protected network access to
33 streaming servers outside that network, in the case when the firewall
34 blocks RTSP connections or RTP/UDP data flow. The firewall perimeter
35 network is usually configured to allow:
36
37 - RTSP connections from within the network, as long as the destination
38   is the proxy
39
40 - RTSP connections to outside the network, as long as the source is
41   the proxy
42
43 - RTP datagrams to and from the proxy to the inner network
44
45 - RTP datagrams to and from the proxy to the outside
46
47 %package Utils
48 Summary:        Apple's Darwin Streaming Server Movie inspection utilities
49 Group:          Daemons
50
51 %description Utils
52 - QTBroadcaster Requires a target ip address, a source movie, one or
53   more source hint track ids in movie, and an initial port. Every packet
54   referenced by the hint track(s) is broadcasted to the specified ip
55   address.
56
57 - QTFileInfo Requires a movie name. Displays each track id, name,
58   create date, and mod date. If the track is a hint track, additional
59   information is displayed: the total rtp bytes and packets, the average
60   bit rate and packet size, and the total header percentage of the
61   stream.
62
63 - QTFileTest Requires a movie name. Parses the Movie Header Atom and
64   displays a trace of the output.
65
66 - QTRTPFileTest Requires a movie and a hint track id in the movie.
67   Displays the RTP header (TransmitTime, Cookie, SeqNum, and TimeStamp)
68   for each packet.
69
70 - QTRTPGen Requires a movie and a hint track id. Displays the number
71   of packets in each hint track sample and writes the RTP packets to
72   file "track.cache"
73
74 - QTSampleLister Requires a movie and a track id. Displays track media
75   sample number, media time, Data offset, and sample size for each
76   sample in the track.
77
78 - QTSDPGen Requires a list of 1 or more movies. Displays the SDP
79   information for all of the hinted tracks in each movie. Use -f to save
80   the SDP information to the file [movie].sdp in the same directory as
81   the source movie.
82
83 - QTTrackInfo Requires a movie, sample table atom type, and track id.
84   Displays the information in the sample table atom of the specified
85   track. Supports "stco", "stsc", "stsz", "stts" as the atom type.
86
87 Example: "./QTTrackInfo -T stco /movies/mystery.mov 3" dumps the chunk
88 offset sample table in track 3.
89
90 - StreamingLoadTool
91
92 %package Samples
93 Summary:        Apple's Darwin Streaming Samples
94 Group:          Daemons
95
96 %description Samples
97 Sample files for the Darwin Streaming Server.
98
99 %prep
100 %setup -q -n DarwinStreamingSrvr%{version}-Source
101 %patch0 -p1
102 %patch1 -p1
103
104 # patch streamingadminserver.pl
105 %{__sed} -i -e  "s|/usr/local/|/usr/|g" WebAdmin/src/streamingadminserver.pl
106 %{__sed} -i -e  "s|/etc/streaming/|/etc/dss/|g" WebAdmin/src/streamingadminserver.pl
107 %{__sed} -i -e  "s|/var/streaming/logs/|/var/log/dss/|g" WebAdmin/src/streamingadminserver.pl
108 %{__sed} -i -e  "s|/var/streaming/|/var/dss/|g" WebAdmin/src/streamingadminserver.pl
109 %{__sed} -i -e  "s|/usr/local/|/usr/|g" WebAdmin/src/streamingadminserver.pl
110
111 # patch manpages
112 %{__sed} -i -e  "s|/Library/QuickTimeStreaming/Config/|/etc/dss/|g" Documentation/man/qtss/*
113 %{__sed} -i -e  "s|/Library/QuickTimeStreaming/Modules|/usr/lib/dss|g" Documentation/man/qtss/*
114 %{__sed} -i -e  "s|/Library/QuickTimeStreaming/Movies|/var/dss/movies|g" Documentation/man/qtss/*
115 %{__sed} -i -e  "s|/Library/QuickTimeStreaming/Playlists|/var/dss/playlists|g" Documentation/man/qtss/*
116 %{__sed} -i -e  "s|/Library/QuickTimeStreaming/Logs|/var/log/dss|g" Documentation/man/qtss/*
117 %{__sed} -i -e  "s|/Library/QuickTimeStreaming/Docs|%{_docdir}/%{name}-%{version}|g" Documentation/man/qtss/*
118 %{__sed} -i -e  "s|QuickTimeStreamingServer|DarwinStreamingServer|g" Documentation/man/qtss/*
119
120 cat > defaultPaths.h << EOF
121 #define DEFAULTPATHS_DIRECTORY_SEPARATOR        "/"
122 #define DEFAULTPATHS_ROOT_DIR                   "%{_localstatedir}/dss/"
123 #define DEFAULTPATHS_ETC_DIR                    "%{_sysconfdir}/dss/"
124 #define DEFAULTPATHS_ETC_DIR_OLD                "%{_sysconfdir}/"
125 #define DEFAULTPATHS_SSM_DIR                    "%{_libdir}/dss/"
126 #define DEFAULTPATHS_LOG_DIR                    "%{_localstatedir}/log/dss/"
127 #define DEFAULTPATHS_PID_DIR                    "%{_localstatedir}/run/"
128 #define DEFAULTPATHS_MOVIES_DIR                 "%{_localstatedir}/dss/movies/"
129 EOF
130
131 %build
132 export RPM_OPT_FLAGS="%{rpmcflags}"
133 export ARCH="%{_target_cpu}"
134 export CC="%{__cc}"
135 export CXX="%{__cxx}"
136
137 jobs=$(echo %{_smp_mflags} | cut -dj -f2)
138 ./Buildit ${jobs:+--jobs=$jobs}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 ./DSS_MakeRoot \
143         $RPM_BUILD_ROOT
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files
149 %defattr(644,root,root,755)
150 %doc APPLE_LICENSE ReleaseNotes.txt
This page took 0.057656 seconds and 3 git commands to generate.