]> git.pld-linux.org Git - packages/dshowserver.git/blob - dshowserver.spec
- grzegorz - you should pldize external specs, not just add them
[packages/dshowserver.git] / dshowserver.spec
1 # TODO
2 # - err, get rid of name mungling and create real -static package or some other subpackages
3 # - static bcond and BR mismatches
4
5 # Conditional build:
6 %bcond_with     static  # static package for use with x86_64 systems
7
8 %define         snap            svn
9 %define         extraver        82
10 %define         pname           dshowserver
11 Summary:        Win32 CoreAVC H.264 codec helper
12 Summary(pl.UTF-8):      Serwer windowsowego kodeka CoreAVC H.264.
13 Name:           %{pname}%{?with_static:-static}
14 Version:        %{snap}%{extraver}
15 Release:        0.1
16 License:        GPL
17 Group:          X11/Applications/Multimedia
18 Source0:        %{pname}-%{version}.tar.bz2
19 # Source0-md5:
20 Patch0:         %{pname}-codecspath.patch
21 URL:            http://code.google.com/
22 BuildRequires:  glibc-static
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 CoreAVC is a proprietary Windows codec for H.264 video decoding. It is
27 much faster than any currently available open-source codecs. Being
28 multi-threaded, and able to play PAFF streams, it can handle HD
29 H.264/AVC streams that no freely available codecs can. CoreAVC is
30 reasonably priced, but it is Windows only. Dshowserver serves CoreAVC
31 for mythtv, mplayer and xine. Dshowserver can work under 32 or 64 bits
32 linux system. For 64 bits use static binary compiled in 32 bits
33 environement.
34
35 %description -l pl.UTF-8
36 CoreAVC to komercyjny kodek H.264 dla systemu Windows. Jest znacznie
37 szybszy od dowolnego wolnego kodeka. ObsÅ‚ugujac wielowatkowosc moze
38 odtwarzac strumienie zakodowane z uzyciem interlacingu PAFF. Odtwarza
39 strumienie HD H.264/AVC. Kosztuje rozsadnie, ale dostepny jest tylko
40 dla Windows. Dhowserevr implementuje obsluge tego kodeka przez mythtv,
41 mplayer i xine. Dshowserver moze byc uzyty w architekturach x86 i
42 x86_64. Jezeli twoj system jest 64 bitowy. Uzyj statycznych binariow
43 zbudowanych w 32 bitowym srodowisku.
44
45
46 %package -n registercodec%{?with_static:-static}
47 Summary:        Utility to register win32 CoreAVC H.264 codec
48 Summary(pl.UTF-8):      Narzedzie do rejestracji windowsowego kodeka CoreAVC H.264.
49 Group:          X11/Applications/Multimedia
50
51 %description -n registercodec%{?with_static:-static}
52 Utility to register win32 CoreAVC H.264 codec for usage with
53 mythtv/mplayer/xine.
54
55 %description -n registercodec%{?with_static:-static} -l pl.UTF-8
56 Narzedzie do przeprowadzenia rejestracji komercyjnego kodeka CoreAVC
57 H.264.
58
59 %prep
60 %setup -q -n %{pname}-%{version}
61 %patch0 -p1
62
63 %build
64 %{__make} -C dshowserver %{?with_static:STATIC=1}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{_bindir}
69 install -d $RPM_BUILD_ROOT%{_mandir}/man1
70 install dshowserver/dshowserver $RPM_BUILD_ROOT%{_bindir}/dshowserver
71 install dshowserver/registercodec $RPM_BUILD_ROOT%{_bindir}/registercodec
72
73 cp -a man/* $RPM_BUILD_ROOT%{_mandir}/man1
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %attr(755,root,video) %{_bindir}/dshowserver
81 %{_mandir}/man1/ds*
82
83 %files -n registercodec%{?with_static:-static}
84 %defattr(644,root,root,755)
85 %attr(755,root,video) %{_bindir}/registercodec
86 %{_mandir}/man1/re*
This page took 0.083833 seconds and 3 git commands to generate.