]> git.pld-linux.org Git - packages/drupal.git/blob - drupal.spec
- pl, cosmetics
[packages/drupal.git] / drupal.spec
1 Summary:        Open source content management platform
2 Summary(pl):    Platforma do zarz±dzania tre¶ci± o otwartych ¼ród³ach
3 Name:           drupal
4 Version:        4.6.0
5 Release:        0.33
6 Epoch:          0
7 License:        GPL
8 Group:          Applications/WWW
9 Source0:        http://drupal.org/files/projects/%{name}-%{version}.tar.gz
10 # Source0-md5:  cba80c4f511284b09d6a0a2def5cb250
11 Source1:        %{name}.conf
12 Source2:        %{name}.cron
13 Patch0:         %{name}-config.patch
14 Patch1:         %{name}-includedir.patch
15 Patch2:         %{name}-module-themedir.patch
16 Patch3:         %{name}-emptypass.patch
17 Patch4:         %{name}-themedir.patch
18 Patch5:         %{name}-sitesdir.patch
19 Patch6:         %{name}-topdir.patch
20 URL:            http://drupal.org/
21 BuildRequires:  rpmbuild(macros) >= 1.194
22 BuildRequires:  sed >= 4.0
23 Requires:       apache >= 1.3.33-3
24 Requires:       apache(mod_dir)
25 Requires:       apache(mod_access)
26 Requires:       apache(mod_expires)
27 Requires:       apache(mod_rewrite)
28 Requires:       apache(mod_alias)
29 Requires:       php >= 3:4.3.3
30 Requires:       php-mysql
31 Requires:       php-pcre
32 #Requires:      php-pgsql
33 Requires:       php-xml
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _appdir         %{_datadir}/%{name}
38 %define         _sysconfdir     /etc/%{name}
39
40 %description
41 Drupal is software that allows an individual or a community of users
42 to easily publish, manage and organize a great variety of content on a
43 website. Tens of thousands of people and organizations have used
44 Drupal to set up scores of different kinds of web sites, including
45 - community web portals and discussion sites
46 - corporate web sites/intranet portals
47 - personal web sites
48 - afficionado sites
49 - e-commerce applications
50 - resource directories
51
52 Drupal includes features to enable
53 - content management systems
54 - blogs
55 - collaborative authoring environments
56 - forums
57 - newsletters
58 - picture galleries
59 - file uploads and download
60
61 and much more.
62
63 %description -l pl
64 Drupal to oprogramowanie pozwalaj±ce osobie lub spo³eczno¶ci
65 u¿ytkowników na ³atwe publikowanie, zarz±dzanie i organizowanie ró¿nej
66 tre¶ci na stronie WWW. Dziesi±tki tysiêcy ludzi i organizacji u¿ywali
67 Drupala do ustawiania wyników ró¿nych rodzajów stron WWW, w tym:
68 - portale WWW i strony dyskusyjne spo³eczno¶ci
69 - korporacyjne strony WWW/portale intranetowe
70 - osobiste strony WWW
71 - strony mi³o¶ników
72 - aplikacje e-commerce
73 - s³owniki zasobów
74
75 Drupal zawiera zasoby umo¿liwiaj±ce tworzenie:
76 - systemów zarz±dzania tre¶ci±
77 - blogów
78 - ¶rodowisk pracy grupowej
79 - forów
80 - nowin
81 - galerii zdjêæ
82 - wrzucania i ¶ci±gania plików
83
84 i wiele wiêcej.
85
86 %package cron
87 Summary:        Drupal cron
88 Summary(pl):    Us³uga cron dla Drupala
89 Group:          Applications/WWW
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       crondaemon
92 Requires:       php-cli >= 3:4.3.3
93
94 %description cron
95 This package contains script which invokes cron hooks for Drupal.
96
97 %description cron -l pl
98 Ten pakiet zawiera skrypt wywo³uj±cy uchwyty crona dla Drupala.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 #%patch1 -p1
104 #%patch2 -p1
105 %patch3 -p1
106 %patch4 -p1
107 %patch5 -p1
108 %patch6 -p1
109
110 #grep -rl 'include_once .includes/' . | xargs sed -i -e '
111 #       s,include_once \(.\)includes/,include_once \1%{_appdir}/includes/,g
112 #'
113
114 find -name '*~' | xargs -r rm -v
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_appdir}/htdocs,%{_sysconfdir},/etc/cron.d}
119
120 cp -a *.ico index.php $RPM_BUILD_ROOT%{_appdir}/htdocs
121 cp -a misc $RPM_BUILD_ROOT%{_appdir}/htdocs
122
123 cp -a cron.php $RPM_BUILD_ROOT%{_appdir}
124 cp -a includes modules scripts $RPM_BUILD_ROOT%{_appdir}
125 cp -a sites $RPM_BUILD_ROOT%{_sysconfdir}
126
127 cp -a themes $RPM_BUILD_ROOT%{_appdir}/htdocs
128 # move .xtmpl out of htdocs
129 (cd $RPM_BUILD_ROOT%{_appdir}/htdocs && tar cf - --remove-files themes/*/*.xtmpl) | tar -xf - -C $RPM_BUILD_ROOT%{_appdir}
130 mv $RPM_BUILD_ROOT%{_appdir}/{htdocs/,}themes/engines
131
132 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache-%{name}.conf
133 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post
139 if [ "$1" = 1 ]; then
140 %banner -e %{name} <<EOF
141 If this is your first install of Drupal, you need to create drupal database:
142 shell$ mysqladmin create drupal
143
144 and import initial schema:
145 shell$ zcat %{_docdir}/%{name}-%{version}/database/database.mysql.gz | mysql drupal
146
147 (anyway, read INSTALL file from documentation).
148
149 EOF
150 fi
151
152 %triggerin -- apache1 >= 1.3.33-2
153 %apache_config_install -v 1 -c %{_sysconfdir}/apache-%{name}.conf
154
155 %triggerun -- apache1 >= 1.3.33-2
156 %apache_config_uninstall -v 1
157
158 %triggerin -- apache >= 2.0.0
159 %apache_config_install -v 2 -c %{_sysconfdir}/apache-%{name}.conf
160
161 %triggerun -- apache >= 2.0.0
162 %apache_config_uninstall -v 2
163
164 %files
165 %defattr(644,root,root,755)
166 %doc *.txt database
167
168 %attr(750,root,http) %dir %{_sysconfdir}
169 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache-%{name}.conf
170
171 %attr(750,root,http) %dir %{_sysconfdir}/sites
172 %attr(750,root,http) %dir %{_sysconfdir}/sites/default
173 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sites/default/*
174
175 %dir %{_appdir}
176 %{_appdir}/htdocs
177 %{_appdir}/includes
178 %{_appdir}/modules
179 %{_appdir}/scripts
180 %{_appdir}/themes
181
182 %files cron
183 %defattr(644,root,root,755)
184 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
185 %{_appdir}/cron.php
This page took 0.127815 seconds and 4 git commands to generate.