]> git.pld-linux.org Git - packages/drupal.git/blob - drupal.spec
1af13dcef1e3972283db562b966041867786f844
[packages/drupal.git] / drupal.spec
1 Summary:        Open source content management platform
2 Summary(pl):    Platforma do zarz±dzania tre¶ci± o otwartych ¼ród³ach
3 Name:           drupal
4 Version:        4.6.2
5 Release:        0.1
6 Epoch:          0
7 License:        GPL
8 Group:          Applications/WWW
9 Source0:        http://drupal.org/files/projects/%{name}-%{version}.tar.gz
10 # Source0-md5:  7bbee605d6b57052e27adb1a61685ec1
11 Source1:        %{name}.conf
12 Source2:        %{name}.cron
13 Patch0:         %{name}-config.patch
14 Patch1:         %{name}-includedir.patch
15 Patch2:         %{name}-module-themedir.patch
16 Patch3:         %{name}-emptypass.patch
17 Patch4:         %{name}-themedir.patch
18 Patch5:         %{name}-sitesdir.patch
19 Patch6:         %{name}-topdir.patch
20 Patch7:         %{name}-themedir2.patch
21 URL:            http://drupal.org/
22 BuildRequires:  rpmbuild(macros) >= 1.194
23 BuildRequires:  sed >= 4.0
24 Requires:       apache >= 1.3.33-3
25 Requires:       apache(mod_dir)
26 Requires:       apache(mod_access)
27 Requires:       apache(mod_expires)
28 Requires:       apache(mod_rewrite)
29 Requires:       apache(mod_alias)
30 Requires:       php >= 3:4.3.3
31 Requires:       php-mysql
32 Requires:       php-pcre
33 #Requires:      php-pgsql
34 Requires:       php-xml
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _appdir         %{_datadir}/%{name}
39 %define         _sysconfdir     /etc/%{name}
40
41 %description
42 Drupal is software that allows an individual or a community of users
43 to easily publish, manage and organize a great variety of content on a
44 website. Tens of thousands of people and organizations have used
45 Drupal to set up scores of different kinds of web sites, including
46 - community web portals and discussion sites
47 - corporate web sites/intranet portals
48 - personal web sites
49 - afficionado sites
50 - e-commerce applications
51 - resource directories
52
53 Drupal includes features to enable
54 - content management systems
55 - blogs
56 - collaborative authoring environments
57 - forums
58 - newsletters
59 - picture galleries
60 - file uploads and download
61
62 and much more.
63
64 %description -l pl
65 Drupal to oprogramowanie pozwalaj±ce osobie lub spo³eczno¶ci
66 u¿ytkowników na ³atwe publikowanie, zarz±dzanie i organizowanie ró¿nej
67 tre¶ci na stronie WWW. Dziesi±tki tysiêcy ludzi i organizacji u¿ywali
68 Drupala do ustawiania wyników ró¿nych rodzajów stron WWW, w tym:
69 - portale WWW i strony dyskusyjne spo³eczno¶ci
70 - korporacyjne strony WWW/portale intranetowe
71 - osobiste strony WWW
72 - strony mi³o¶ników
73 - aplikacje e-commerce
74 - s³owniki zasobów
75
76 Drupal zawiera zasoby umo¿liwiaj±ce tworzenie:
77 - systemów zarz±dzania tre¶ci±
78 - blogów
79 - ¶rodowisk pracy grupowej
80 - forów
81 - nowin
82 - galerii zdjêæ
83 - wrzucania i ¶ci±gania plików
84
85 i wiele wiêcej.
86
87 %package cron
88 Summary:        Drupal cron
89 Summary(pl):    Us³uga cron dla Drupala
90 Group:          Applications/WWW
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       crondaemon
93 Requires:       php-cli >= 3:4.3.3
94
95 %description cron
96 This package contains script which invokes cron hooks for Drupal.
97
98 %description cron -l pl
99 Ten pakiet zawiera skrypt wywo³uj±cy uchwyty crona dla Drupala.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 #%patch1 -p1
105 #%patch2 -p1
106 %patch3 -p1
107 #%patch4 -p1
108 %patch5 -p1
109 %patch6 -p1
110 %patch7 -p1
111
112 #grep -rl 'include_once .includes/' . | xargs sed -i -e '
113 #       s,include_once \(.\)includes/,include_once \1%{_appdir}/includes/,g
114 #'
115
116 find -name '*~' | xargs -r rm -v
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_appdir}/{htdocs,files},%{_sysconfdir},/etc/cron.d}
121
122 cp -a *.ico index.php $RPM_BUILD_ROOT%{_appdir}/htdocs
123 cp -a misc $RPM_BUILD_ROOT%{_appdir}/htdocs
124
125 cp -a cron.php $RPM_BUILD_ROOT%{_appdir}
126 cp -a includes modules scripts $RPM_BUILD_ROOT%{_appdir}
127 cp -a sites $RPM_BUILD_ROOT%{_sysconfdir}
128
129 cp -a themes $RPM_BUILD_ROOT%{_appdir}/htdocs
130 # move .xtmpl out of htdocs
131 (cd $RPM_BUILD_ROOT%{_appdir}/htdocs && tar cf - --remove-files themes/*/*.xtmpl) | tar -xf - -C $RPM_BUILD_ROOT%{_appdir}
132 mv $RPM_BUILD_ROOT%{_appdir}/{htdocs/,}themes/engines
133
134 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache-%{name}.conf
135 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 if [ "$1" = 1 ]; then
142 %banner -e %{name} <<EOF
143 If this is your first install of Drupal, you need to create drupal database:
144 shell$ mysqladmin create drupal
145
146 and import initial schema:
147 shell$ zcat %{_docdir}/%{name}-%{version}/database/database.mysql.gz | mysql drupal
148
149 (anyway, read INSTALL file from documentation).
150
151 EOF
152 fi
153
154 %triggerin -- apache1 >= 1.3.33-2
155 %apache_config_install -v 1 -c %{_sysconfdir}/apache-%{name}.conf
156
157 %triggerun -- apache1 >= 1.3.33-2
158 %apache_config_uninstall -v 1
159
160 %triggerin -- apache >= 2.0.0
161 %apache_config_install -v 2 -c %{_sysconfdir}/apache-%{name}.conf
162
163 %triggerun -- apache >= 2.0.0
164 %apache_config_uninstall -v 2
165
166 %files
167 %defattr(644,root,root,755)
168 %doc *.txt database
169
170 %attr(750,root,http) %dir %{_sysconfdir}
171 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache-%{name}.conf
172
173 %attr(750,root,http) %dir %{_sysconfdir}/sites
174 %attr(750,root,http) %dir %{_sysconfdir}/sites/default
175 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sites/default/*
176
177 %dir %{_appdir}
178 %{_appdir}/htdocs
179 %{_appdir}/includes
180 %{_appdir}/modules
181 %{_appdir}/scripts
182 %{_appdir}/themes
183
184 %dir %attr(775,root,http) %{_appdir}/files
185
186 %files cron
187 %defattr(644,root,root,755)
188 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
189 %{_appdir}/cron.php
This page took 0.074868 seconds and 3 git commands to generate.