]> git.pld-linux.org Git - packages/drupal-mod-image.git/blob - drupal-mod-image.spec
32272ff05bb22afec22840f1924357941b38be88
[packages/drupal-mod-image.git] / drupal-mod-image.spec
1 %define         modname image
2 Summary:        Drupal Image Module
3 Name:           drupal-mod-%{modname}
4 Version:        4.6.0
5 Release:        0.14
6 Epoch:          0
7 License:        GPL
8 Group:          Applications/WWW
9 Source0:        http://drupal.org/files/projects/%{modname}-%{version}.tar.gz
10 # Source0-md5:  0d218124ee86584375d4981ee1646a06
11 URL:            http://drupal.org/project/image
12 Requires:       drupal >= 4.6.0
13 Requires:       ImageMagick
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _moddir         %{_datadir}/drupal/modules
18 %define         _htmldir        %{_datadir}/drupal/htdocs/modules
19 %define         _podir          %{_moddir}/po/%{modname}
20
21 %description
22 This module allow users with proper permissions to upload images into
23 drupal. Thumbnails are created automaticaly.
24
25 Images could be posted individualy to the front page, included in
26 stories or grouped in galleries.
27
28 %prep
29 %setup -q -n %{modname}
30 rm -f LICENSE.txt # pure GPL
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT{%{_moddir},%{_podir},%{_htmldir}}
35
36 install *.module $RPM_BUILD_ROOT%{_moddir}
37 install *.inc *.module $RPM_BUILD_ROOT%{_moddir}
38 install *.css $RPM_BUILD_ROOT%{_htmldir}
39 cp -a po/*.po $RPM_BUILD_ROOT%{_podir}
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %post
45 if [ "$1" = 1 ]; then
46 %banner -e %{name} <<EOF
47 If you want to use localization, then you need to upload .po files
48 from %{_podir} via drupal locatization admin.
49
50 EOF
51 fi
52
53 %files
54 %defattr(644,root,root,755)
55 %doc *.txt po/*.pot *.php
56 %{_moddir}/*.module
57 %{_moddir}/*.inc
58 %{_podir}
59 %{_htmldir}/*.css
This page took 0.116087 seconds and 3 git commands to generate.