]> git.pld-linux.org Git - packages/droidbattles.git/blob - droidbattles.spec
- initial release
[packages/droidbattles.git] / droidbattles.spec
1 Summary:        A game of programming
2 Summary(pl):    Gra w programowanie
3 Name:           droidbattles
4 Version:        1.0.4
5 Release:        1
6 License:        GPL
7 Group:          X11/Applications/Games
8 Group(de):      X11/Applikationen/Spiele
9 Group(pl):      X11/Aplikacje/Gry
10 Source0:        http://www.bluefire.nu/%{name}/%{name}-%{version}.tar.gz
11 Source1:        http://www.bluefire.nu/%{name}/bots-light-01-06-11.tar.gz
12 Source2:        %{name}.desktop
13 Source3:        %{name}.png
14 URL:            http://www.bluefire.nu/droidbattles/
15 BuildRequires:  qt-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _prefix         /usr/X11R6
19 %define         _mandir         %{_prefix}/man
20
21 %description
22 So, you're having this argument about who's the best programmer? Or
23 you just want to have some programming fun? What better way to do it
24 than a little game of AI programming.
25
26 In DroidBattles you design the bots by choosing which hardware they
27 should contain. Each bot can have up to 32 hardware devices that you
28 can choose freely from a list of available types. Examples include
29 weapons, armor, CPU:s, engines... etc.
30
31 When you have chosen the hardware it's time to program it. You make a
32 program (in an assembler like language) that is loaded into a virtual
33 RAM of the bot and then executed by the CPU device(s) you've included
34 with the bot. You communicate with your devices through simple in/out
35 instruktions.
36
37 Other features of DroidBattles includes team-battle and set up of
38 "rules" for a game, (you can enable/disable hardware devices and also
39 set the costs).
40
41 You can make the bot have it's own graphics that is shown when the
42 simulation runs. When everyhing is ready you assemble the program and
43 a .bot file is created. You can now test this bot against other bots
44 in the simulator, and hopefully your bot will crush it's opponents.
45
46 %description -l pl
47 A wiêc spierasz siê o to, kto jest najlepszym programist±? Lub po
48 prostu chcesz zaznaæ przyjemno¶ci programowania? Có¿ lepszego mo¿e byæ
49 od gry, w której programujesz Sztuczn± Inteligencjê.
50
51 W DroidBattles projektujesz boty wybieraj±c jaki hardware powinny
52 zawieraæ. Ka¿dy bot mo¿e pomie¶ciæ do 32 urz±dzeñ sprzêtowych, które
53 mo¿esz dowolnie wybieraæ z dostêpnej listy. Mog± to byæ bronie,
54 pancerz, CPU, silniki... etc.
55
56 Gdy wybra³e¶ ju¿ sprzêt, nadszed³ czas na zaprogramowanie. Tworzysz
57 program (w jêzyku podobnym do assemblera), który jest ³adowany do
58 wirtualnego RAMu bota, a nastêpnie wykonywany przez jednostki
59 przetwarzania, które zainstalowa³e¶ w bocie. Komunikujesz siê ze
60 swoimi urz±dzeniami za pomoc± prostych instrukcji wej¶cia/wyj¶cia.
61
62 W¶ród innych zalet DroidBattles mo¿na wymieniæ bitwy dru¿ynowe, jak i
63 zestawy "zasad" dla gry (mo¿esz w³±czaæ/wy³±czaæ urz±dzenia sprzêtowe,
64 a tak¿e ustawiaæ koszt.)
65
66 Mo¿esz stworzyæ dla bota jego w³asn± grafikê, która bêdzie pokazywana
67 podczas symulacji. Gdy wszystko jest gotowe, assemblujesz program i
68 utworzony zostaje plik .bot. Mo¿esz wtedy przetestowaæ bota w starciu
69 z innymi botami w symulatorze i przy dozie szczê¶cia zostaæ zwyciêzc±.
70
71 %prep
72 %setup -q
73 mkdir bots
74 cd bots
75 tar zxvf %{SOURCE1}
76
77 %build
78 find . -exec touch \{\} \;
79 %configure2_13 \
80         --enable-final
81
82 cd %{name}
83 cat installdir.cpp | sed 's@/usr/local/droidbattles@%{_datadir}/droidbattles@' > installdir.cpp.new
84 mv -f installdir.cpp.new installdir.cpp
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_applnkdir}/Games}
90
91 gzip -9nf AUTHORS ChangeLog TODO
92
93 cd %{name}
94 %{__make} install DESTDIR=$RPM_BUILD_ROOT
95 rm docs/en/Makefile*
96 cd ..
97 for i in bots/*
98 do
99         mv $i $RPM_BUILD_ROOT/usr/local/%{name}/bots/
100 done
101 cd $RPM_BUILD_ROOT/usr
102 mv local/%{name} X11R6/share/
103 rm -rf X11R6/share/%{name}/doc
104 ln -s /usr/share/doc/%{name}-%{version} X11R6/share/%{name}/doc
105
106 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Games
107 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc *.gz
115 %doc %{name}/docs/en/*.html
116 %attr(755,root,root) %{_bindir}/*
117 %{_datadir}/droidbattles
118 %{_pixmapsdir}/*
119 %{_applnkdir}/Games/*
This page took 0.067142 seconds and 3 git commands to generate.