]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
18bfbd648c0261f7bf2c27ffece55ebdd896d28f
[packages/dpkg.git] / dpkg.spec
1 Summary:        Package maintenance system for Debian Linux
2 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
3 Name:           dpkg
4 Version:        1.15.8.8
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications/File
8 Source0:        ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.bz2
9 # Source0-md5:  39600c01d03c997bc12898ff85424377
10 URL:            http://packages.debian.org/search?keywords=dpkg
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  bzip2-devel
14 BuildRequires:  gettext-devel
15 BuildRequires:  libselinux-devel
16 BuildRequires:  libtool
17 BuildRequires:  perl-tools-pod
18 BuildRequires:  zlib-devel
19 Requires:       perl-base
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This package contains the programs to handle deb packages known from
24 Debian.
25
26 %description -l pl.UTF-8
27 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
28 Debiana.
29
30 %package -n libdpkg-devel
31 Summary:        dpkg library and header files
32 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
33 Group:          Development/Libraries
34
35 %description -n libdpkg-devel
36 dpkg library and header files.
37
38 %description -n libdpkg-devel -l pl.UTF-8
39 Biblioteka i pliki nagłówkowe dpkg.
40
41 %prep
42 %setup -q
43
44 %build
45 %configure \
46         --disable-silent-rules \
47         --enable-shared \
48         --without-dselect \
49         --without-install-info \
50         --without-start-stop-daemon \
51         --with-zlib \
52         --with-bz2 \
53         --with-selinux \
54         --with-admindir=/var/lib/%{name}
55 #       SELINUX_LIBS=-lselinux
56
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
66
67 # dpkg for main part, dpkg-dev for perl-based build script
68 # don't use --all-name to avoid e.g. dselect inclusion
69 %find_lang dpkg
70 %find_lang dpkg-dev
71 cat dpkg-dev.lang >>dpkg.lang
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files -f dpkg.lang
77 %defattr(644,root,root,755)
78 %doc AUTHORS ChangeLog README THANKS TODO
79 %attr(755,root,root) %{_bindir}/dpkg*
80 %attr(755,root,root) %{_bindir}/update-alternatives
81 %dir %{_sysconfdir}/alternatives
82 %dir %{_sysconfdir}/dpkg
83 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
84
85 %dir %{_libdir}/dpkg
86 %dir %{_libdir}/dpkg/parsechangelog
87 %attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
88 %dir %{_datadir}/dpkg
89 %{_datadir}/dpkg/cputable
90 %{_datadir}/dpkg/ostable
91 %{_datadir}/dpkg/triplettable
92
93 %{perl_vendorlib}/Dpkg.pm
94 %{perl_vendorlib}/Dpkg
95
96 %dir /var/lib/dpkg
97 %dir /var/lib/dpkg/alternatives
98 %dir /var/lib/dpkg/info
99 %dir /var/lib/dpkg/parts
100 %dir /var/lib/dpkg/updates
101
102 %{_mandir}/man1/dpkg*.1*
103 %{_mandir}/man3/Dpkg::*.3*
104 %{_mandir}/man5/deb*.5*
105 %{_mandir}/man5/dpkg.cfg.5*
106 %{_mandir}/man8/dpkg-*.8*
107 %{_mandir}/man8/update-alternatives.8*
108 %lang(de) %{_mandir}/de/man1/dpkg*.1*
109 %lang(de) %{_mandir}/de/man5/deb*.5*
110 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
111 %lang(de) %{_mandir}/de/man8/dpkg-*.8*
112 %lang(de) %{_mandir}/de/man8/update-alternatives.8*
113 %lang(es) %{_mandir}/es/man1/dpkg*.1*
114 %lang(es) %{_mandir}/es/man5/deb*.5*
115 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
116 %lang(es) %{_mandir}/es/man8/dpkg-*.8*
117 %lang(es) %{_mandir}/es/man8/update-alternatives.8*
118 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
119 %lang(fr) %{_mandir}/fr/man5/deb*.5*
120 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
121 %lang(fr) %{_mandir}/fr/man8/dpkg-*.8*
122 %lang(fr) %{_mandir}/fr/man8/update-alternatives.8*
123 %lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
124 %lang(ja) %{_mandir}/ja/man5/deb-old.5*
125 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
126 %lang(pl) %{_mandir}/pl/man5/deb*.5*
127 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
128 %lang(pl) %{_mandir}/pl/man8/dpkg-*.8*
129 %lang(pl) %{_mandir}/pl/man8/update-alternatives.8*
130 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
131 %lang(sv) %{_mandir}/sv/man5/deb*.5*
132 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
133 %lang(sv) %{_mandir}/sv/man8/dpkg-*.8*
134 %lang(sv) %{_mandir}/sv/man8/update-alternatives.8*
135
136 %files -n libdpkg-devel
137 %defattr(644,root,root,755)
138 %{_libdir}/libdpkg.a
139 %{_includedir}/dpkg
140 %{_pkgconfigdir}/libdpkg.pc
This page took 0.074611 seconds and 3 git commands to generate.