]> git.pld-linux.org Git - packages/doxygen.git/blob - doxygen.spec
- updated to 1.2.14.
[packages/doxygen.git] / doxygen.spec
1 Summary:        Doxygen is the documentation system for C/C++
2 Summary(pl):    System dokumentowania dla C/C++
3 Summary(pt_BR): Um sistema de documentação para C/C++
4 Name:           doxygen
5 Version:        1.2.14
6 Release:        1
7 Epoch:          1
8 License:        GPL
9 Group:          Development/Tools
10 Group(cs):      Vývojové prostøedky/Nástroje
11 Group(da):      Udvikling/Værktøj
12 Group(de):      Entwicklung/Tools
13 Group(es):      Desarrollo/Herramientas
14 Group(fr):      Development/Outils
15 Group(is):      Þróunartól/Tól
16 Group(it):      Sviluppo/Tool
17 Group(ja):      ³«È¯/¥Ä¡¼¥ë
18 Group(no):      Utvikling/Verktøy
19 Group(pl):      Programowanie/Narzêdzia
20 Group(pt):      Desenvolvimento/Ferramentas
21 Group(ru):      òÁÚÒÁÂÏÔËÁ/éÎÓÔÒÕÍÅÎÔÙ
22 Group(sl):      Razvoj/Orodja
23 Group(sv):      Utveckling/Verktyg
24 Group(uk):      òÏÚÒÏÂËÁ/¶ÎÓÔÒÕÍÅÎÔÉ
25 Source0:        ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
26 URL:            http://www.stack.nl/~dimitri/doxygen/
27 BuildRequires:  qt-devel => 2.1
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  tetex
30 BuildRequires:  ghostscript
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Doxygen is a documentation system for C, C++ and IDL. It can generate
35 an on-line class browser (in HTML) and/or an off-line reference manual
36 (in LaTeX) from a set of documented source files. There is also
37 support for generating man pages and for converting the generated
38 output into Postscript, hyperlinked PDF or compressed HTML. The
39 documentation is extracted directly from the sources.
40
41 Doxygen can also be configured to extract the code-structure from
42 undocumented source files. This can be very useful to quickly find
43 your way in large source distributions.
44
45 %description -l pl
46 Doxygen to system dokumentowania dla C, C++ i IDL. Mo¿e generowaæ
47 dokumentacjê klas on-line (w HTML) lub podrêcznik off-line (w LaTeX-u)
48 z zestawu udokumentowanych plików ¼ród³owych. Ma tak¿e mo¿liwo¶æ
49 generowania stron man i konwersji na Postscript, PDF z hiper³±czami
50 oraz skompresowany HTML. Dokumentacja jest wyci±gana bezpo¶rednio ze
51 ¼róde³.
52
53 Doxygen mo¿e byæ skonfigurowany tak¿e do wyci±gania struktury kodu z
54 nieudokumentowanych plików ¼ród³owych. Mo¿e byæ to przydatne do
55 szybkiego odnalezienia siê w du¿ych ¼ród³ach.
56
57 %description -l pt_BR
58 Doxygen é uma sistema de documentação para C e C++ que gera um class
59 browser on-line (em HTML) e/ou um manual de referencia off-line (em
60 LaTeX) a partir de um conjunto de fontes documentados. A documentação
61 é extraida diretamente a partir dos fontes.
62
63 %package doxywizard
64 Summary:        A GUI front-end for creating and editing configuration files
65 Summary(pl):    GUI do tworzenia i edycji plików konfiguracyjnych
66 Group:          X11/Applications
67 Group(cs):      X11/Aplikace
68 Group(da):      X11/Programmer
69 Group(de):      X11/Applikationen
70 Group(es):      X11/Aplicaciones
71 Group(fr):      X11/Applications
72 Group(id):      X11/Aplikasi
73 Group(is):      X11/Forrit
74 Group(it):      X11/Applicazioni
75 Group(ja):      X11/¥¢¥×¥ê¥±¡¼¥·¥ç¥ó
76 Group(no):      X11/Applikasjoner
77 Group(pl):      X11/Aplikacje
78 Group(pt_BR):   X11/Aplicações
79 Group(pt):      X11/Aplicações
80 Group(ru):      X11/ðÒÉÌÏÖÅÎÉÑ
81 Group(sl):      X11/Programi
82 Group(sv):      X11/Tillämpningar
83 Group(uk):      X11/ðÒÉËÌÁÄΦ ðÒÏÇÒÁÍÉ
84 Requires:       %{name} = %{version}
85 Requires:       qt >= 2.2 
86
87 %description doxywizard
88 Doxywizard is a GUI front-end for creating and editing configuration
89 files that are used by doxygen.
90
91 %description doxywizard -l pl
92 Doxywizard to frontend z graficznym interfejsem do tworzenia i edycji
93 plików konfiguracyjnych u¿ywanych przez doxygen.
94
95 %prep
96 %setup -q
97
98 %build
99 export QTDIR=%{_prefix}
100 ## don't change it to %%configure!!!
101 ./configure \
102         --prefix %{_prefix} \
103         --perl %{_bindir}/perl \
104 #       --with-doxywizard
105
106 %{__make} \
107         CFLAGS="%{rpmcflags}" \
108         CXXFLAGS="%{rpmcflags} \
109         -DQT_NO_CODECS -DQT_LITE_UNICODE -fno-rtti -fno-exceptions"
110
111 %{__make} docs
112 %{__make} ps
113 mkdir ps
114 mv -f latex/doxygen_manual.ps ps
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d ${RPM_BUILD_ROOT}%{_bindir}
119
120 install bin/doxy* ${RPM_BUILD_ROOT}%{_bindir}
121
122 gzip -9nf README LICENSE
123
124 %clean
125 rm -rf ${RPM_BUILD_ROOT}
126
127 %files
128 %defattr(644,root,root,755)
129 %doc html examples *.gz
130 %attr(755,root,root) %{_bindir}/doxygen
131 %attr(755,root,root) %{_bindir}/doxytag
132 %attr(755,root,root) %{_bindir}/doxysearch
133
134 #%files doxywizard
135 #%defattr(644,root,root,755)
136 #%attr(755,root,root) %{_bindir}/doxywizard
This page took 0.190481 seconds and 4 git commands to generate.