]> git.pld-linux.org Git - packages/doxygen.git/blob - doxygen.spec
73be18eeb3a20c8990b0511452e3c616e902cbd4
[packages/doxygen.git] / doxygen.spec
1 Summary:        Doxygen is the documentation system for C/C++
2 Summary(pl):    System dokumentowania dla C/C++
3 Summary(pt_BR): Um sistema de documentação para C/C++
4 Name:           doxygen
5 Version:        1.2.11
6 Release:        1
7 Epoch:          1
8 License:        GPL
9 Group:          Development/Tools
10 Group(de):      Entwicklung/Werkzeuge
11 Group(fr):      Development/Outils
12 Group(pl):      Programowanie/Narzêdzia
13 Source0:        http://www.stack.nl/~dimitri/doxygen/dl/%{name}-%{version}.src.tar.gz
14 URL:            http://www.stack.nl/~dimitri/doxygen/
15 BuildRequires:  qt-devel => 2.1
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  tetex
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Doxygen is a documentation system for C, C++ and IDL. It can generate
22 an on-line class browser (in HTML) and/or an off-line reference manual
23 (in LaTeX) from a set of documented source files. There is also
24 support for generating man pages and for converting the generated
25 output into Postscript, hyperlinked PDF or compressed HTML. The
26 documentation is extracted directly from the sources.
27
28 Doxygen can also be configured to extract the code-structure from
29 undocumented source files. This can be very useful to quickly find
30 your way in large source distributions.
31
32 %description -l pl
33 Doxygen to system dokumentowania dla C, C++ i IDL. Mo¿e generowaæ
34 dokumentacjê klas on-line (w HTML) lub podrêcznik off-line (w LaTeX-u)
35 z zestawu udokumentowanych plików ¼ród³owych. Ma tak¿e mo¿liwo¶æ
36 generowania stron man i konwersji na Postscript, PDF z hiper³±czami
37 oraz skompresowany HTML. Dokumentacja jest wyci±gana bezpo¶rednio ze
38 ¼róde³.
39
40 Doxygen mo¿e byæ skonfigurowany tak¿e do wyci±gania struktury kodu z
41 nieudokumentowanych plików ¼ród³owych. Mo¿e byæ to przydatne do
42 szybkiego odnalezienia siê w du¿ych ¼ród³ach.
43
44 %description -l pt_BR
45 Doxygen é uma sistema de documentação para C e C++ que gera um class
46 browser on-line (em HTML) e/ou um manual de referencia off-line (em
47 LaTeX) a partir de um conjunto de fontes documentados. A documentação
48 é extraida diretamente a partir dos fontes.
49
50 %package doxywizard
51 Summary:        A GUI front-end for creating and editing configuration files
52 Summary(pl):    GUI do tworzenia i edycji plików konfiguracyjnych
53 Group:          X11/Applications
54 Group(de):      X11/Applikationen
55 Group(pl):      X11/Aplikacje
56 Requires:       %{name} = %{version}, qt >= 2.2 
57
58 %description doxywizard
59 Doxywizard is a GUI front-end for creating and editing configuration
60 files that are used by doxygen.
61
62 %description doxywizard -l pl
63 Doxywizard to frontend z graficznym interfejsem do tworzenia i edycji
64 plików konfiguracyjnych u¿ywanych przez doxygen.
65
66 %prep
67 %setup -q
68
69 %build
70 export QTDIR=%{_prefix}
71 ## don't change it to %%configure!!!
72 ./configure \
73         --prefix %{_prefix} \
74         --perl %{_bindir}/perl
75 #       --with-doxywizard
76
77 %{__make} CFLAGS="%{rpmcflags}" \
78         CXXFLAGS="%{rpmcflags} \
79         -DQT_NO_CODECS -DQT_LITE_UNICODE -fno-rtti -fno-exceptions"
80
81 %{__make} docs
82 %{__make} ps
83 mkdir ps
84 mv -f latex/doxygen_manual.ps ps
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d ${RPM_BUILD_ROOT}%{_bindir}
89
90 install bin/doxy* ${RPM_BUILD_ROOT}%{_bindir}
91
92 gzip -9nf README LICENSE
93
94 %clean
95 rm -rf ${RPM_BUILD_ROOT}
96
97 %files
98 %defattr(644,root,root,755)
99 %doc html examples *.gz
100 %attr(755,root,root) %{_bindir}/doxygen
101 %attr(755,root,root) %{_bindir}/doxytag
102 %attr(755,root,root) %{_bindir}/doxysearch
103
104 #%files doxywizard
105 #%defattr(644,root,root,755)
106 #%attr(755,root,root) %{_bindir}/doxywizard
This page took 0.065772 seconds and 3 git commands to generate.