]> git.pld-linux.org Git - packages/doxygen.git/blob - doxygen.spec
68ccb344f10c586bd88b29e983a3598c75ba34a6
[packages/doxygen.git] / doxygen.spec
1 Summary:        Doxygen is THE documentation system for C/C++
2 Name:           doxygen
3 Version:        1.2.3
4 Release:        1
5 License:        GPL
6 Group:          Development/Tools
7 Group(de):      Entwicklung/Werkzeuge
8 Group(fr):      Development/Outils
9 Group(pl):      Programowanie/Narzêdzia
10 Source0:        http://www.stack.nl/~dimitri/doxygen/dl/%{name}-%{version}.src.tar.gz
11 URL:            http://www.stack.nl/~dimitri/doxygen/
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  tetex
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15 ExcludeArch:    alpha
16
17 %description
18 Doxygen is a documentation system for C, C++ and IDL. It can generate
19 an on-line class browser (in HTML) and/or an off-line reference manual
20 (in LaTeX) from a set of documented source files. There is also
21 support for generating man pages and for converting the generated
22 output into Postscript, hyperlinked PDF or compressed HTML. The
23 documentation is extracted directly from the sources.
24
25 Doxygen can also be configured to extract the code-structure from
26 undocumented source files. This can be very useful to quickly find
27 your way in large source distributions.
28
29 %prep
30 %setup -q
31
32 %build
33 export QTDIR=%{_prefix}
34 ## don't change it to %%configure!!!
35 ./configure \
36         --prefix %{_prefix} \
37         --perl %{_bindir}/perl \
38
39 %{__make} CFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS}" \
40         CXXFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS} \
41         -DQT_NO_CODECS -DQT_LITE_UNICODE -fno-rtti -fno-exceptions"
42
43 %{__make} docs
44 %{__make} ps
45 mkdir ps
46 mv -f latex/doxygen_manual.ps ps
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d ${RPM_BUILD_ROOT}%{_bindir}
51
52 install bin/doxy* ${RPM_BUILD_ROOT}%{_bindir}
53
54 %clean
55 rm -rf ${RPM_BUILD_ROOT}
56
57 %files
58 %defattr(644,root,root,755)
59 %doc html examples ps
60 %doc README LICENSE
61 %attr(755,root,root) %{_bindir}/doxygen
62 %attr(755,root,root) %{_bindir}/doxytag
63 %attr(755,root,root) %{_bindir}/doxysearch
This page took 0.091746 seconds and 3 git commands to generate.