]> git.pld-linux.org Git - packages/dosemu.git/blob - dosemu.spec
3b0644c6e8cc70414982b684609b3645febdd3dd
[packages/dosemu.git] / dosemu.spec
1 # NOTE: if /dev/shm is mounted, it cannot be mounted with noexec
2 #
3 # Conditional build:
4 %bcond_with     static          # link statically
5 %bcond_without  x               # X support
6 #
7 Summary:        A DOS emulator
8 Summary(de):    DOS-Emulator
9 Summary(es):    Emulador DOS
10 Summary(fr):    Emulateur DOS
11 Summary(pl):    Emulator DOS-a
12 Summary(pt_BR): Emulador DOS
13 Summary(tr):    DOS öykünümcüsü
14 Name:           dosemu
15 Version:        1.3.3
16 Release:        1
17 License:        GPL v2
18 Group:          Applications/Emulators
19 Source0:        http://dl.sourceforge.net/dosemu/%{name}-%{version}.tgz
20 # Source0-md5:  f3b27a9326e5c95e59093fcb79a61023
21 #Source2:       %{name}-sys.tar.gz
22 Source3:        %{name}-PRZECZYTAJ_TO
23 Source4:        %{name}-README.PLD
24 Source5:        %{name}.desktop
25 Source6:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
26 # Source6-md5:  7a8abf5c656e6b99bdd03a4783751895
27 Patch0:         %{name}-man-pages.patch
28 Patch1:         %{name}-make-new.patch
29 Patch2:         %{name}-%{name}_conf.patch
30 Patch3:         %{name}-doSgmlTools.patch
31 Patch4:         %{name}-makehtml.patch
32 URL:            http://www.dosemu.org/
33 BuildRequires:  SDL-devel
34 %if %{with x}
35 BuildRequires:  XFree86-devel
36 %{?with_static:BuildRequires:   XFree86-static}
37 %endif
38 BuildRequires:  autoconf >= 2.57
39 BuildRequires:  bin86
40 BuildRequires:  bison
41 BuildRequires:  docbook-dtd30-sgml
42 BuildRequires:  docbook-style-dsssl
43 BuildRequires:  flex
44 %{?with_static:BuildRequires:   glibc-static}
45 BuildRequires:  gpm-devel
46 BuildRequires:  lynx
47 BuildRequires:  openjade
48 BuildRequires:  perl
49 BuildRequires:  sgml-tools
50 BuildRequires:  slang-devel
51 %{?with_static:BuildRequires:   slang-static}
52 BuildRequires:  unzip
53 BuildRequires:  util-linux
54 Obsoletes:      xdosemu
55 Conflicts:      dosemu-freedos-minimal < 2.0.33
56 Conflicts:      kernel < 2.0.28
57 Conflicts:      mtools < 3.6
58 ExclusiveArch:  %{ix86}
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %define         _dosemudir      /var/lib/dosemu
62 %define         specflags       -fomit-frame-pointer
63
64 %description
65 Dosemu is a DOS emulator. Once you've installed dosemu, start the DOS
66 emulator by typing in the "dos" command.
67
68 You need to install dosemu if you use DOS programs and you want to be
69 able to run them on your GNU/Linux system. You may also need to
70 install the dosemu-freedos-* packages.
71
72 %description -l pl
73 Dosemu to Emulator systemu DOS. Po zainstalowaniu mo¿esz go uruchomiæ
74 komend± "dos".
75
76 Je¶li korzystasz z dosowych programów i chcia³by¶ je uruchamiaæ na
77 twoim linuksowym systemie zainstaluj dosemu. Mo¿esz te¿ potrzebowaæ
78 pakietów dosemu-freedos-*.
79
80 %description -l pt_BR
81 Essa é uma versão do emulador DOS que foi projetada para rodar em
82 sessões X Window. Oferece suporte para gráficos VGA bem como suporte
83 para mouse.
84
85 %package utils
86 Summary:        Utilities for dosemu
87 Summary(pl):    Programy pomocnicze do dosemu
88 Group:          Applications/Emulators
89 Requires:       %{name} = %{version}-%{release}
90
91 %description utils
92 Utilities for dosemu: dexeconfig, hdinfo, mkhdimage, mkfatimage16.
93
94 %description utils -l pl
95 Programy pomocnicze dla dosemu: dexeconfig, hdinfo, mkhdimage,
96 mkfatimage16.
97
98 %package SDL
99 Summary:        SDL plugin for dosemu
100 Summary(pl):    Wtyczka SDL dla dosemu
101 Group:          Libraries
102 Requires:       %{name} = %{version}-%{release}
103
104 %description SDL
105 SDL plugin for dosemu.
106
107 %description SDL -l pl
108 Wtyczka SDL dla dosemu.
109
110 %package X
111 Summary:        X plugin for dosemu
112 Summary(pl):    Wtyczka X dla dosemu
113 Group:          Libraries
114 Requires:       %{name} = %{version}-%{release}
115
116 %description X
117 X plugin for dosemu.
118
119 %description X -l pl
120 Wtyczka X dla dosemu.
121
122 %prep
123 %setup -q -a6
124 #sh tmp/do_patch
125 %patch0 -p1
126 %patch1 -p1
127 %patch2 -p1
128 %patch3 -p1
129 %patch4 -p1
130
131 %build
132 OPTFLAGS="%{rpmcflags}"; export OPTFLAGS
133
134 ./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
135 plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
136
137 %{__autoconf}
138 # configure2_13 must be used though because of ./default-configure
139
140 # non-X version
141 %configure2_13 \
142         %{?with_static:--enable-linkstatic} \
143         --enable-new-intcode \
144         --enable-aspi \
145         %{!?with_x:--without-x}
146
147 %{__make} \
148         WAIT=no
149
150 %{__make} -C man
151 mv -f man/dosemu.bin.1 man/dosemu.1
152 echo '.so dosemu.1' > man/dos.1
153 mv -f man/ru/dosemu.bin.1 man/ru/dosemu.1
154 echo '.so dosemu.1' > man/ru/dos.1
155
156 mv -f pl/man1/dos.1 pl/man1/dosemu.1
157 echo '.so dosemu.1' > pl/man1/dos.1
158 echo '.so dosemu.1' > pl/man1/xdosemu.1
159 echo '.so dosemu.1' > pl/man1/dosdebug.1
160
161 # documentation
162 %{__make} -C src/doc/DANG html
163 %{__make} -C src/doc/HOWTO html
164 %{__make} -C src/doc/README html
165
166 find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}} \
171         $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/{pl,ru}/man1} \
172         $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
173         $RPM_BUILD_ROOT%{_libdir}/dosemu
174
175 #%%{__make} install \
176 #       DESTDIR=$RPM_BUILD_ROOT
177
178 install bin/midid $RPM_BUILD_ROOT%{_bindir}/midid
179 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dosemu
180 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/dos
181 %if %{with x}
182 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdos
183 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosemu
184 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosexec
185 %endif
186
187 install bin/libplugin*.so  $RPM_BUILD_ROOT%{_libdir}/dosemu
188
189 install bin/dosdebug $RPM_BUILD_ROOT%{_bindir}/dosdebug
190 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage,mkfatimage16} $RPM_BUILD_ROOT%{_bindir}
191 ln -sf dos $RPM_BUILD_ROOT%{_bindir}/dosexec
192
193 install etc/dosemu.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
194 install etc/dosemu.users.example $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
195 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
196 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
197
198 install man/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
199 install pl/man1/{dosemu.1,dosdebug.1,xdosemu.1,dos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
200 install man/ru/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/ru/man1
201
202 install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
203 install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
204 cp %{SOURCE3} PRZECZYTAJ_TO
205 cp %{SOURCE4} README.PLD
206 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
207
208 rm -f doc/{configuration,dosemu.lsm}
209
210 %clean
211 rm -rf $RPM_BUILD_ROOT
212
213 %files
214 %defattr(644,root,root,755)
215 %doc QuickStart COPYING ChangeLog* doc/* README.PLD
216 %lang(pl) %doc PRZECZYTAJ_TO
217 %dir %{_dosemudir}
218 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.conf
219 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.users
220 %config(noreplace) %verify(not md5 mtime size) %{_dosemudir}/global.conf
221 %attr(755,root,root) %{_bindir}/dos
222 %attr(755,root,root) %{_bindir}/dosdebug
223 %attr(755,root,root) %{_bindir}/dosemu
224 %attr(755,root,root) %{_bindir}/dosexec
225 %attr(755,root,root) %{_bindir}/midid
226 %dir %{_libdir}/dosemu
227 %{_libdir}/dosemu/libplugin_gpm.so
228 %{_libdir}/dosemu/libplugin_term.so
229 %dir %{_dosemudir}/bootdir
230 %dir %{_dosemudir}/bootdir/dosemu
231 %{_dosemudir}/bootdir/dosemu/*
232 %{_mandir}/man1/d*
233 %lang(pl) %{_mandir}/pl/man1/d*
234 %lang(ru) %{_mandir}/ru/man1/d*
235 %{_pixmapsdir}/dosemu.xpm
236 %if %{with x}
237 %attr(755,root,root) %{_bindir}/xdos*
238 %{_mandir}/man1/xdosemu.1*
239 %lang(pl) %{_mandir}/pl/man1/xdosemu.1*
240 %lang(ru) %{_mandir}/ru/man1/xdosemu.1*
241 %{_desktopdir}/dosemu.desktop
242 %endif
243
244 %files utils
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_bindir}/dexeconfig
247 %attr(755,root,root) %{_bindir}/hdinfo
248 %attr(755,root,root) %{_bindir}/mkhdimage
249 %attr(755,root,root) %{_bindir}/mkfatimage16
250 %{_mandir}/man1/mkfatimage16.1*
251 %lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
252
253 %files SDL
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_libdir}/dosemu/libplugin_sdl.so
256
257 %if %{with x}
258 %files X
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_libdir}/dosemu/libplugin_X.so
261 %endif
This page took 0.037051 seconds and 3 git commands to generate.