]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
03df7662d86edd8a1f51f562167c455eff5b54f2
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - icons for desktop files
3 # - (CVE-2006-1618) http://security.gentoo.org/glsa/glsa-200604-05.xml
4
5 %define         subver  beta6.4
6 %define         rel             0.1
7 Summary:        jDoom, jHeretic and jHexen for Linux
8 Summary(pl.UTF-8):      jDoom, jHeretic i jHexen dla Linuksa
9 Name:           doomsday
10 Version:        1.9.0
11 Release:        0.%{subver}.%{rel}
12 License:        GPL v2
13 Group:          Applications/Games
14 Source0:        http://dl.sourceforge.net/deng/deng-%{version}-%{subver}.tar.gz
15 # Source0-md5:  63fdbc11f0473535f7206f62952a1e2e
16 URL:            http://www.doomsdayhq.com/
17 BuildRequires:  OpenAL-devel
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  SDL-devel >= 1.2.0
20 BuildRequires:  SDL_mixer-devel
21 BuildRequires:  SDL_net-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  cmake >= 2.4
25 BuildRequires:  rpmbuild(macros) >= 1.213
26 BuildRequires:  zip
27 Requires:       TiMidity++
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 jDoom, jHeretic and jHexen for Linux.
32
33 %description -l pl.UTF-8
34 jDoom, jHeretic i jHexen dla Linuksa.
35
36 %prep
37 %setup -q -n deng-%{version}-%{subver}
38
39 %build
40 install -d build
41 cd build
42 %cmake \
43         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
44         -DCURSES_INCLUDE_PATH=/usr/include/ncurses \
45         ../doomsday
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_desktopdir}
51
52 %{__make} -C build install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
56 [Desktop Entry]
57 Name=Doom
58 Comment=Doom for linux
59 Exec=doomsday -game jdoom
60 #Icon=hexen.png
61 Terminal=false
62 Type=Application
63 Categories=Game;FirstPersonGame;
64 Encoding=UTF-8
65 # vi: encoding=utf-8
66 EOF
67
68 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
69 [Desktop Entry]
70 Name=Hexen
71 Comment=Hexen for linux
72 Exec=doomsday -game jhexen
73 #Icon=heretic.png
74 Terminal=false
75 Type=Application
76 Categories=Game;FirstPersonGame;
77 Encoding=UTF-8
78 # vi: encoding=utf-8
79 EOF
80
81 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
82 [Desktop Entry]
83 Name=Heretic
84 Comment=Heretic for linux
85 Exec=doomsday -game jheretic
86 #Icon=heretic.png
87 Terminal=false
88 Type=Application
89 Categories=Game;FirstPersonGame;
90 Encoding=UTF-8
91 # vi: encoding=utf-8
92 EOF
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post
98 if [ "$1" = "1" ]; then
99         %banner -e %{name} <<-EOF
100         To run doomsday you need some WAD file: either freedoom package
101         or some shareware or commercial WAD from Doom or Heretic:
102         Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
103         Heretic.wad or Heretic1.wad.
104         When you have them, run doomsday with:
105         doomsday -game [ jdoom | jheretic | jhexen ]
106 EOF
107 fi
108
109 %files
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_bindir}/doomsday
112 %attr(755,root,root) %{_libdir}/libdpdehread.so
113 %attr(755,root,root) %{_libdir}/libdpwadmapconverter.so
114 %attr(755,root,root) %{_libdir}/libjdoom.so
115 %attr(755,root,root) %{_libdir}/libjheretic.so
116 %attr(755,root,root) %{_libdir}/libjhexen.so
117 %{_datadir}/deng
118 %{_desktopdir}/*.desktop
This page took 0.073231 seconds and 3 git commands to generate.