]> git.pld-linux.org Git - packages/docker-compose.git/blob - docker-compose.spec
up to 1.25.4
[packages/docker-compose.git] / docker-compose.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define         module          compose
6 %define         egg_name        docker_compose
7 %define         pypi_name       docker-compose
8 Summary:        Multi-container orchestration for Docker
9 Name:           docker-compose
10 Version:        1.25.4
11 Release:        1
12 License:        Apache v2.0
13 Group:          Applications/System
14 # https://github.com/docker/compose/releases
15 Source0:        https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
16 # Source0-md5:  893fbb804a9057d6c470b5312407e0d1
17 Patch0:         remove-requires-upper-bound.patch
18 URL:            https://docs.docker.com/compose/
19 %if %{with tests}
20 BuildRequires:  python-PyYAML
21 BuildRequires:  python-docker
22 BuildRequires:  python-docopt
23 BuildRequires:  python-paramiko
24 BuildRequires:  python-requests
25 BuildRequires:  python-setuptools
26 BuildRequires:  python-texttable
27 BuildRequires:  python-websocket-client
28 %endif
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.714
31 Requires:       docker(engine) >= 1.10.0
32 Requires:       python-docker >= 3.6.0
33 Requires:       python-setuptools
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Multi-container orchestration for Docker
39
40 Docker-compose allows you to:
41 - Define your application's environment with Docker so it can be
42   reproduced anywhere.
43 - Define the services that make up your app so they can be run
44   together in an isolated environment.
45 - Run 'docker-compose up', and docker-compose will start and run your
46   entire app.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51
52 rm -r docker_compose.egg-info
53
54 %build
55 %py_build
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %py_install
60 %py_postclean
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc CHANGELOG.md CONTRIBUTING.md README.md SWARM.md LICENSE
68 %attr(755,root,root) %{_bindir}/%{name}
69 %{py_sitescriptdir}/%{module}
70 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.027469 seconds and 3 git commands to generate.