]> git.pld-linux.org Git - packages/dnf.git/blob - dnf.spec
f154e28870e5bc3fa28c26e271ce34adb6d8971f
[packages/dnf.git] / dnf.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 #
5 %define hawkey_ver      0.59.0
6 %define libcomps_ver    0.1.8
7 %define libmodulemd_ver 2.9.3
8 %define rpm_ver         4.14.0
9
10 Summary:        Package manager
11 Summary(pl.UTF-8):      Zarządca pakietów
12 Name:           dnf
13 Version:        4.6.1
14 Release:        5
15 Group:          Base
16 # GPL v2+ with GPL v2 and GPL parts; for a breakdown of the licensing, see PACKAGE-LICENSING
17 License:        GPL v2 (parts on GPL v2+ or GPL)
18 Source0:        https://github.com/rpm-software-management/dnf/archive/%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  21880d44905d6aa67ab6bee1e86380b3
20 Patch0:         install.patch
21 URL:            https://github.com/rpm-software-management/dnf
22 BuildRequires:  bash-completion-devel
23 BuildRequires:  cmake >= 2.4
24 BuildRequires:  gettext-tools
25 BuildRequires:  python3
26 BuildRequires:  python3-gpg
27 BuildRequires:  python3-hawkey >= %{hawkey_ver}
28 BuildRequires:  python3-libcomps >= %{libcomps_ver}
29 BuildRequires:  python3-libdnf >= %{hawkey_ver}
30 BuildRequires:  python3-modules
31 BuildRequires:  python3-nose
32 BuildRequires:  python3-rpm >= %{rpm_ver}
33 BuildRequires:  libmodulemd >= %{libmodulemd_ver}
34 BuildRequires:  rpmbuild(macros) >= 1.647
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  sed >= 4.0
37 BuildRequires:  sphinx-pdg
38 BuildRequires:  systemd-devel
39 Requires(post,preun,postun):    systemd-units >= 38
40 Requires:       python3-gpg
41 Requires:       python3-hawkey >= %{hawkey_ver}
42 Requires:       python3-libcomps >= %{libcomps_ver}
43 Requires:       python3-libdnf >= %{hawkey_ver}
44 Requires:       python3-rpm
45 Requires:       systemd-units >= 0.38
46 Requires:       libmodulemd >= %{libmodulemd_ver}
47 Recommends:     deltarpm
48 Recommends:     python3-dbus
49 Recommends:     python3-unbound
50 Recommends:     rpm-plugin-systemd-inhibit
51 BuildArch:      noarch
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 Utility that allows users to manage packages on their systems. It
56 supports RPMs, modules and comps groups & environments.
57
58 %description -l pl.UTF-8
59 Marzędzie umożliwiające użytkownikom zarządzanie pakietami w systemie.
60
61 %package common
62 Summary:        Common data and configuration files for DNF
63 Summary(pl.UTF-8):      Wspólne dane i pliki konfiguracyjne dla DNF-a
64 Requires:       libreport-filesystem
65
66 %description common
67 Common data and configuration files for DNF.
68
69 %description common -l pl.UTF-8
70 Wspólne dane i pliki konfiguracyjne dla DNF-a.
71
72 %package automatic
73 Summary:        Alternative CLI to "dnf upgrade" suitable for automatic, regular execution
74 Summary(pl.UTF-8):      Alternatywny interfejs do "dnf upgrade" nadający się do automatycznego wywoływania
75 Group:          Base
76 Requires(post): systemd
77 Requires(preun):        systemd
78 Requires(postun):       systemd
79 Requires:       %{name} = %{version}-%{release}
80
81 %description automatic
82 Alternative CLI to "dnf upgrade" suitable for automatic, regular
83 execution.
84
85 %description automatic -l pl.UTF-8
86 Alternatywny interfejs linii poleceń do "dnf upgrade", nadający się do
87 automatycznego, regularnego wywoływania.
88
89 %package -n bash-completion-dnf
90 Summary:        Bash completion for dnf command
91 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia dnf
92 Group:          Applications/Shells
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       bash-completion
95
96 %description -n bash-completion-dnf
97 Bash completion for dnf command.
98
99 %description -n bash-completion-dnf -l pl.UTF-8
100 Bashowe uzupełnianie parametrów dla polecenia dnf.
101
102 %package -n yum
103 Summary:        Package manager
104 Summary(pl.UTF-8):      Zarządca pakietów
105 Requires:       %{name} = %{version}-%{release}
106 Recommends:     sqlite3
107 Conflicts:      yum < 3.4.3-505
108
109 %description -n yum
110 Utility that allows users to manage packages on their systems. It
111 supports RPMs, modules and comps groups & environments.
112
113 %description -n yum -l pl.UTF-8
114 Marzędzie umożliwiające użytkownikom zarządzanie pakietami w systemie.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119
120 %build
121 install -d build
122 cd build
123 %cmake .. \
124         -DPYTHON_DESIRED:FILEPATH=%{__python3} \
125         -DPYTHON_INSTALL_DIR:PATH=%{py3_sitescriptdir} \
126         -DDNF_VERSION=%{version} \
127         -DSYSTEMD_DIR=%{systemdunitdir}
128
129 %{__make}
130 %{__make} doc-man
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/{vars,aliases.d,plugins,modules.d,modules.defaults.d},yum} \
135         -d $RPM_BUILD_ROOT{%{_localstatedir}/log/,%{_var}/cache/dnf} \
136         -d $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf-plugins/__pycache__
137
138 %{__make} -C build install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 touch $RPM_BUILD_ROOT%{_localstatedir}/log/%{name}.log
142
143 %{__mv} $RPM_BUILD_ROOT%{_bindir}/dnf-3 $RPM_BUILD_ROOT%{_bindir}/dnf
144 %{__mv} $RPM_BUILD_ROOT%{_bindir}/dnf-automatic-3 $RPM_BUILD_ROOT%{_bindir}/dnf-automatic
145
146 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{%{name}-strict.conf,aliases.d/zypper.conf}
147
148 # YUM compat layer
149 ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/%{name}.conf,yum.conf}
150 ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/plugins,yum/pluginconf.d}
151 ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/protected.d,yum/protected.d}
152 ln -sr $RPM_BUILD_ROOT%{_sysconfdir}/{%{name}/vars,yum/vars}
153 ln -s dnf-3 $RPM_BUILD_ROOT%{_bindir}/yum
154
155 %py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf
156 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}/dnf
157
158 %find_lang %{name}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post
164 %systemd_post dnf-makecache.timer
165
166 %preun
167 %systemd_preun dnf-makecache.timer
168
169 %postun
170 %systemd_reload
171
172 %post automatic
173 %systemd_post dnf-automatic.timer dnf-automatic-download.timer dnf-automatic-install.timer dnf-automatic-notifyonly.timer
174
175 %preun automatic
176 %systemd_preun dnf-automatic.timer dnf-automatic-download.timer dnf-automatic-install.timer dnf-automatic-notifyonly.timer
177
178 %postun automatic
179 %systemd_reload
180
181 %files -f %{name}.lang
182 %defattr(644,root,root,755)
183 %doc AUTHORS PACKAGE-LICENSING README.rst
184 %attr(755,root,root) %{_bindir}/dnf
185 %dir %{_sysconfdir}/%{name}
186 %dir %{_sysconfdir}/%{name}/plugins
187 %dir %{_sysconfdir}/%{name}/protected.d
188 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/dnf.conf
189 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/protected.d/dnf.conf
190 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/collect_dnf.conf
191 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
192 %{_mandir}/man5/dnf.conf.5*
193 %{_mandir}/man5/dnf-transaction-json.5*
194 %{_mandir}/man7/dnf.modularity.7*
195 %{_mandir}/man8/dnf.8*
196 %{_mandir}/man8/yum2dnf.8*
197 %{systemdunitdir}/dnf-makecache.service
198 %{systemdunitdir}/dnf-makecache.timer
199 %{systemdtmpfilesdir}/dnf.conf
200 %{py3_sitescriptdir}/dnf
201 %{py3_sitescriptdir}/dnf-plugins
202 %exclude %{py3_sitescriptdir}/dnf/automatic
203 %dir %{_var}/cache/dnf
204 %ghost %{_localstatedir}/log/%{name}.log
205
206 %files automatic
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_bindir}/dnf-automatic
209 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/automatic.conf
210 %{_mandir}/man8/dnf-automatic.8*
211 %{systemdunitdir}/dnf-automatic-download.service
212 %{systemdunitdir}/dnf-automatic-download.timer
213 %{systemdunitdir}/dnf-automatic-install.service
214 %{systemdunitdir}/dnf-automatic-install.timer
215 %{systemdunitdir}/dnf-automatic-notifyonly.service
216 %{systemdunitdir}/dnf-automatic-notifyonly.timer
217 %{systemdunitdir}/dnf-automatic.service
218 %{systemdunitdir}/dnf-automatic.timer
219 %{py3_sitescriptdir}/dnf/automatic
220
221 %files -n bash-completion-dnf
222 %defattr(644,root,root,755)
223 %{bash_compdir}/dnf
224
225 %files -n yum
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_bindir}/yum
228 %{_sysconfdir}/yum.conf
229 %dir %{_sysconfdir}/yum
230 %{_sysconfdir}/yum/pluginconf.d
231 %{_sysconfdir}/yum/protected.d
232 %{_sysconfdir}/yum/vars
233 %{_mandir}/man8/yum.8*
234 %{_mandir}/man5/yum.conf.5.*
235 %{_mandir}/man8/yum-shell.8*
236 %{_mandir}/man1/yum-aliases.1*
237 %config(noreplace) %{_sysconfdir}/%{name}/protected.d/yum.conf
This page took 0.105352 seconds and 3 git commands to generate.