]> git.pld-linux.org Git - packages/djvulibre.git/blob - djvulibre.spec
- cleanup
[packages/djvulibre.git] / djvulibre.spec
1 # TODO
2 # - test and add other browsers
3 #
4 # Conditional build:
5 %bcond_without  qt      # disable qt wrapper
6 #
7 Summary:        DjVu viewers, encoders and utilities
8 Summary(pl):    DjVu - przegl±darki, dekodery oraz narzêdzia
9 Name:           djvulibre
10 Version:        3.5.15
11 Release:        2
12 License:        GPL
13 Group:          Applications/Graphics
14 Source0:        http://dl.sourceforge.net/djvu/%{name}-%{version}.tar.gz
15 # Source0-md5:  4a4c5a36799e73bd93afc4fa5d69b315
16 Patch0:         %{name}-opt.patch
17 Patch1:         %{name}-nostrip.patch
18 Patch2:         %{name}-desktop.patch
19 URL:            http://djvu.sourceforge.net/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libstdc++-devel
24 %{?with_qt:BuildRequires:       qt-devel >= 3.0.5}
25 Obsoletes:      djvu
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _plugindir      %{_libdir}/browser-plugins
29
30 # list of supported browsers, in free form text
31 %define         browsers mozilla, netscape
32
33 %description
34 DjVu is a web-centric format and software platform for distributing
35 documents and images. DjVu content downloads faster, displays and
36 renders faster, looks nicer on a screen, and consume less client
37 resources than competing formats. DjVu was originally developed at
38 AT&T Labs-Research by Leon Bottou, Yann LeCun, Patrick Haffner, and
39 many others. In March 2000, AT&T sold DjVu to LizardTech Inc. who now
40 distributes Windows/Mac plug-ins, and commercial encoders (mostly on
41 Windows).
42
43 In an effort to promote DjVu as a Web standard, the LizardTech
44 management was enlightened enough to release the reference
45 implementation of DjVu under the GNU GPL in October 2000. DjVuLibre
46 (which means free DjVu), is an enhanced version of that code
47 maintained by the original inventors of DjVu. It is compatible with
48 version 3.5 of the LizardTech DjVu software suite.
49
50 This package of DjVulibre 3.5 contains:
51 - A full-fledged wavelet-based compressor for pictures.
52 - A simple compressor for bitonal (black and white) scanned pages.
53 - A compressor for palettized images (a la GIF/PNG).
54 - A set of utilities to manipulate and assemble DjVu images and
55   documents.
56 - A set of decoders to convert DjVu to a number of other formats.
57 - An up-to-date version of the C++ DjVu Reference Library.
58
59 Following elements are placed in other subpackages:
60 - a standalone DjVu viewer based on the Qt library.
61 - A browser plugin that works with most Unix browsers.
62
63 %description -l pl
64 DjVu jest przeznaczonym g³ównie dla WWW formatem i platform±
65 programow± do dystrybucji dokumentów i obrazków. Dane w DjVu ¶ci±gaj±
66 siê szybciej, wy¶wietlaj± szybciej, wygl±daj± ³adniej na ekranie i
67 zajmuj± mniej zasobów po stronie klienckiej ni¿ inne formaty. DjVu
68 oryginalnie zosta³ stworzony w AT&T Labs-Research przez Leona Bottou,
69 Yanna LeCun, Patricka Haffnera i wielu innych. W marcu 2000 AT&T
70 sprzeda³o DjVu firmie LizardTech Inc., które teraz rozpowszechnia
71 wtyczki dla Windows i Maca oraz komercyjne kodery (g³ównie dla
72 Windows).
73
74 Aby wypromowaæ DjVu jako sieciowy standard, LizardTech udostêpni³
75 wzorcow± implementacjê DjVu na licencji GPL w pa¼dzierniku 2000.
76 DjVuLibre (czyli wolne DjVu) jest rozszerzon± wersj± tego kodu
77 rozwijan± przez pomys³odawców DjVu. Jest kompatybilna z wersj±
78 3.5 oprogramowania LizardTech DjVu.
79
80 Ten pakiet zawiera: bibliotekê w C++, zestaw kompresorów, dekoderów
81 i narzêdzi do plików w formacie DjVu. Przegl±darka oraz wtyczki do
82 przegl±darek znajduj± siê w innych podpakietach.
83
84 %package devel
85 Summary:        Header file for DjVu library
86 Summary(pl):    Plik nag³ówkowy biblioteki DjVu
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89 Requires:       libjpeg-devel
90 Requires:       libstdc++-devel
91
92 %description devel
93 Header file for DjVu library.
94
95 %description devel -l pl
96 Plik nag³ówkowy biblioteki DjVu.
97
98 %package djview
99 Summary:        Qt-based DjVu viewer
100 Summary(pl):    Oparta o Qt przegl±darka DjVu
101 Group:          X11/Applications
102 Requires:       %{name} = %{version}-%{release}
103 Obsoletes:      djview
104
105 %description djview
106 Qt-based DjVu viewer.
107
108 %description djview -l pl
109 Oparta o Qt przegl±darka DjVu.
110
111 %package -n browser-plugin-%{name}
112 Summary:        DjVu browser plugin
113 #Summary(pl):   Wtyczka DjVu do Mozilli
114 Group:          X11/Libraries
115 Requires:       %{name}-djview = %{version}-%{release}
116 Requires:       browser-plugins(%{_target_cpu})
117 Obsoletes:      mozilla-plugin-djvulibre
118 Obsoletes:      netscape-plugin-djvulibre
119 Obsoletes:      djview-netscape
120 # for migrate purposes (greedy poldek upgrade)
121 Provides:       mozilla-plugin-djvulibre
122 Provides:       netscape-plugin-djvulibre
123
124 %description -n browser-plugin-%{name}
125 DjVu plugin for Mozilla and Mozilla-based browsers.
126
127 Supported browsers: %{browsers}.
128
129 %prep
130 %setup -q
131 %patch0 -p1
132 %patch1 -p1
133 %patch2 -p1
134
135 %build
136 cp -f /usr/share/automake/config.sub config
137 %{__aclocal} -I config -I gui/desktop
138 %{__autoconf}
139 QT_LIBS="-L%{_libdir} -lqt-mt"; export QT_LIBS
140 QT_CFLAGS="-I%{_includedir}/qt"; export QT_CFLAGS
141 %configure \
142         PTHREAD_LIBS="-lpthread"
143
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 install -d $RPM_BUILD_ROOT%{_plugindir}
149
150 # pass dtop_* to allow build w/o gnome/kde/etc. installed
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT \
153         plugindir=%{_plugindir} \
154         dtop_applications=%{_desktopdir} \
155         dtop_icons=%{_iconsdir} \
156         dtop_mimelnk=%{_datadir}/mimelnk \
157         dtop_applnk= \
158         dtop_pixmaps=%{_pixmapsdir} \
159         dtop_mime_info= \
160         dtop_application_registry=
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post   -p /sbin/ldconfig
166 %postun -p /sbin/ldconfig
167
168 %triggerin -n browser-plugin-%{name} -- mozilla
169 %nsplugin_install -d %{_libdir}/mozilla/plugins nsdejavu.so
170
171 %triggerun -n browser-plugin-%{name} -- mozilla
172 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins nsdejavu.so
173
174 %triggerin -n browser-plugin-%{name} -- netscape-common
175 %nsplugin_install -d %{_libdir}/netscape/plugins nsdejavu.so
176
177 %triggerun -n browser-plugin-%{name} -- netscape-common
178 %nsplugin_uninstall -d %{_libdir}/netscape/plugins nsdejavu.so
179
180 %files
181 %defattr(644,root,root,755)
182 %doc COPYRIGHT NEWS README TODO doc/*
183 %attr(755,root,root) %{_bindir}/[!d]*
184 %attr(755,root,root) %{_bindir}/d[!j]*
185 %attr(755,root,root) %{_bindir}/djv[!i]*
186 %attr(755,root,root) %{_libdir}/libdjvulibre.so.*.*.*
187 %{_mandir}/man1/[!dn]*
188 %{_mandir}/man1/d[!j]*
189 %{_mandir}/man1/djv[!i]*
190 %lang(ja) %{_mandir}/ja/man1/[!dn]*
191 %lang(ja) %{_mandir}/ja/man1/d[!j]*
192 %lang(ja) %{_mandir}/ja/man1/djv[!i]*
193 %dir %{_datadir}/djvu
194 %{_datadir}/djvu/languages.xml
195 %dir %{_datadir}/djvu/osi
196 %lang(de) %{_datadir}/djvu/osi/de
197 %{_datadir}/djvu/osi/en
198 %lang(fr) %{_datadir}/djvu/osi/fr
199 %lang(ja) %{_datadir}/djvu/osi/ja
200 %lang(zh) %{_datadir}/djvu/osi/zh
201 %{_datadir}/djvu/pubtext
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/libdjvulibre.so
206 %{_libdir}/libdjvulibre.la
207 %{_includedir}/libdjvu
208
209 %if %{with qt}
210 %files djview
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_bindir}/djview
213 %{_mandir}/man1/djview.1*
214 %lang(ja) %{_mandir}/ja/man1/djview.1*
215 %{_datadir}/mimelnk/image/x-djvu.desktop
216 %{_desktopdir}/djview.desktop
217 %{_iconsdir}/hicolor/*/mimetypes/djvu.png
218 %{_pixmapsdir}/djvu.png
219
220 %files -n browser-plugin-%{name}
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_plugindir}/*.so
223 %{_mandir}/man1/nsdejavu.1*
224 %lang(ja) %{_mandir}/ja/man1/nsdejavu.1*
225 %endif
This page took 0.064937 seconds and 4 git commands to generate.