]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- updated to 1.2.3
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        1.2.3
6 Release:        1
7 License:        GPL
8 URL:            http://distcc.samba.org
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 Source1:        %{name}.inetd
11 Patch0:         %{name}-user.patch
12 Requires:       gcc
13 Requires:       gcc-c++
14 Requires:       inetdaemon
15 BuildRequires:  popt-devel
16 Prereq:         /sbin/chkconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 distcc is a program to distribute compilation of C or C++ code across
21 several machines on a network. distcc should always generate the same
22 results as a local compile, is simple to install and use, and is often
23 two or more times faster than a local compile.
24
25 %description -l pl
26 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
27 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
28 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
29 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
30
31 %prep
32 %setup -q
33
34 %patch -p1
35
36 %build
37 %configure
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd
43
44 %{makeinstall}
45 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
46
47 %post
48 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
49 if [ -f /var/lock/subsys/rc-inetd ]; then
50         /etc/rc.d/init.d/rc-inetd reload 1>&2
51 else
52         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
53 fi
54
55 %postun
56 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
57 if [ -f /var/lock/subsys/rc-inetd ]; then
58         /etc/rc.d/init.d/rc-inetd reload
59 fi
60
61 %clean
62 rm -rf ${RPM_BUILD_ROOT}
63
64 %files
65 %defattr(644,root,root,755)
66 %doc AUTHORS NEWS README linuxdoc/html/*
67 %attr(755,root,root) %{_bindir}/*
68 %attr(644,root,root) %{_mandir}/man?/*
69 %attr(640,root,root) /etc/sysconfig/rc-inetd/distccd
70 %{_infodir}/distcc*
This page took 0.066866 seconds and 4 git commands to generate.