]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- rel 4
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        2.0.1
6 Release:        4
7 License:        GPL
8 URL:            http://distcc.samba.org
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 Source1:        %{name}.inetd
11 Source2:        %{name}.sh
12 Source3:        %{name}.csh
13 Patch0:         %{name}-user.patch
14 Patch1:         %{name}-hostfile.patch
15 Patch2:         %{name}-hostopt.patch
16 Patch3:         %{name}d-version.patch
17 Requires:       gcc
18 Requires:       gcc-c++
19 Requires:       inetdaemon
20 BuildRequires:  popt-devel
21 Prereq:         /sbin/chkconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 distcc is a program to distribute compilation of C or C++ code across
26 several machines on a network. distcc should always generate the same
27 results as a local compile, is simple to install and use, and is often
28 two or more times faster than a local compile.
29
30 %description -l pl
31 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
32 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
33 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
34 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
35
36 %prep
37 %setup -q
38
39 %patch -p1
40 %patch1 -p1
41 %patch2 -p0
42 %patch3 -p0
43
44 %build
45 %configure
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
51            $RPM_BUILD_ROOT/etc/profile.d
52
53 %{makeinstall}
54 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
55 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT/etc/profile.d
56
57 %post
58 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
59 if [ -f /var/lock/subsys/rc-inetd ]; then
60         /etc/rc.d/init.d/rc-inetd reload 1>&2
61 else
62         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
63 fi
64
65 %postun
66 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
67 if [ -f /var/lock/subsys/rc-inetd ]; then
68         /etc/rc.d/init.d/rc-inetd reload
69 fi
70
71 %clean
72 rm -rf ${RPM_BUILD_ROOT}
73
74 %files
75 %defattr(644,root,root,755)
76 %doc AUTHORS NEWS README linuxdoc/html/*
77 %attr(755,root,root) %{_bindir}/*
78 %attr(644,root,root) %{_mandir}/man?/*
79 %attr(640,root,root) /etc/sysconfig/rc-inetd/distccd
80 %attr(644,root,root) /etc/profile.d/*sh
This page took 0.08223 seconds and 4 git commands to generate.