]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- more BR.
[packages/distcc.git] / distcc.spec
1 #
2 # Conditional build:
3 # _without_gtk  build without gtk2(monitor) support
4 #
5 Summary:        Program to distribute compilation of C or C++
6 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
7 Name:           distcc
8 Group:          Development/Languages
9 Version:        2.10.1
10 Release:        1
11 License:        GPL
12 URL:            http://distcc.samba.org/
13 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
14 # Source0-md5:  7eeccb1a68d52c02bd96864e532e0870
15 Source1:        %{name}.inetd
16 Source2:        %{name}.init
17 Source3:        %{name}.sh
18 Source4:        %{name}.csh
19 Source5:        %{name}.config
20 Patch0:         %{name}-user.patch
21 %{!?_without_gtk:BuildRequires: gtk+2-devel >= 2.0}
22 BuildRequires:  popt-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  freetype-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 distcc is a program to distribute compilation of C or C++ code across
29 several machines on a network. distcc should always generate the same
30 results as a local compile, is simple to install and use, and is often
31 two or more times faster than a local compile.
32
33 %description -l pl
34 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
35 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
36 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
37 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
38
39 %package common
40 Summary:        Common files for inetd and standalone versions of distcc
41 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
42 Group:          Daemons
43 Requires:       gcc
44 Requires:       gcc-c++
45 Obsoletes:      %{name} < %{name}-2.1-2
46
47 %description common
48 distcc is a program to distribute compilation of C or C++ code across
49 several machines on a network. distcc should always generate the same
50 results as a local compile, is simple to install and use, and is often
51 two or more times faster than a local compile.
52
53 %description common -l pl
54 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
55 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
56 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
57 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
58
59
60 %package inetd
61 Summary:        inetd configs for distcc
62 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
63 Group:          Daemons
64 PreReq:         %{name}-common = %{version}
65 PreReq:         rc-inetd
66 Obsoletes:      %{name} < %{name}-2.1-2
67
68 %description inetd
69 distcc configs for running from inetd.
70
71 %description inetd -l pl
72 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
73
74 %package standalone
75 Summary:        standalone daemon configs for distcc
76 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
77 Group:          Daemons
78 PreReq:         %{name}-common = %{version}
79 PreReq:         rc-scripts
80 Requires(post,preun):   /sbin/chkconfig
81 Obsoletes:      %{name} < %{name}-2.1-2
82
83 %description standalone
84 distcc configs for running as a standalone daemon.
85
86 %description standalone -l pl
87 Pliki konfiguracyjne distcc do startowania demona w trybie
88 standalone.
89
90 %prep
91 %setup -q
92 %patch -p1
93
94 %build
95 %configure \
96         %{!?_without_gtk:--enable-gnome}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
103            $RPM_BUILD_ROOT/etc/rc.d/init.d \
104            $RPM_BUILD_ROOT/etc/profile.d
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
110 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
111 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
112 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post inetd
118 if [ -f /var/lock/subsys/rc-inetd ]; then
119         /etc/rc.d/init.d/rc-inetd reload 1>&2
120 else
121         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
122 fi
123
124 %postun inetd
125 if [ -f /var/lock/subsys/rc-inetd ]; then
126         /etc/rc.d/init.d/rc-inetd reload
127 fi
128
129 %post standalone
130 /sbin/chkconfig --add distcc
131 if [ -f /var/lock/subsys/distccd ]; then
132         /etc/rc.d/init.d/distcc restart 1>&2
133 else
134         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
135 fi
136
137 %preun standalone
138 if [ "$1" = "0" ]; then
139         if [ -f /var/lock/subsys/distccd ]; then
140                 /etc/rc.d/init.d/distcc stop 1>&2
141         fi
142         /sbin/chkconfig --del distcc
143 fi
144
145 %files common
146 %defattr(644,root,root,755)
147 %doc AUTHORS NEWS README *.txt
148 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
149 %attr(755,root,root) %{_bindir}/*
150 %attr(644,root,root) %{_mandir}/man?/*
151 %attr(644,root,root) /etc/profile.d/*sh
152
153 %files inetd
154 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
155
156 %files standalone
157 %attr(754,root,root) /etc/rc.d/init.d/distcc
This page took 0.034685 seconds and 4 git commands to generate.