]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- rel 2
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        2.0.1
6 Release:        2
7 License:        GPL
8 URL:            http://distcc.samba.org
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 Source1:        %{name}.inetd
11 Source2:        %{name}.sh
12 Source3:        %{name}.csh
13 Patch0:         %{name}-user.patch
14 Patch1:         %{name}-hostfile.patch
15 Requires:       gcc
16 Requires:       gcc-c++
17 Requires:       inetdaemon
18 BuildRequires:  popt-devel
19 Prereq:         /sbin/chkconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 distcc is a program to distribute compilation of C or C++ code across
24 several machines on a network. distcc should always generate the same
25 results as a local compile, is simple to install and use, and is often
26 two or more times faster than a local compile.
27
28 %description -l pl
29 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
30 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
31 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
32 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
33
34 %prep
35 %setup -q
36
37 %patch -p1
38 %patch1 -p1
39
40 %build
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
47            $RPM_BUILD_ROOT/etc/profile.d
48
49 %{makeinstall}
50 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
51 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT/etc/profile.d
52
53 %post
54 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
55 if [ -f /var/lock/subsys/rc-inetd ]; then
56         /etc/rc.d/init.d/rc-inetd reload 1>&2
57 else
58         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
59 fi
60
61 %postun
62 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
63 if [ -f /var/lock/subsys/rc-inetd ]; then
64         /etc/rc.d/init.d/rc-inetd reload
65 fi
66
67 %clean
68 rm -rf ${RPM_BUILD_ROOT}
69
70 %files
71 %defattr(644,root,root,755)
72 %doc AUTHORS NEWS README linuxdoc/html/*
73 %attr(755,root,root) %{_bindir}/*
74 %attr(644,root,root) %{_mandir}/man?/*
75 %attr(640,root,root) /etc/sysconfig/rc-inetd/distccd
76 %attr(644,root,root) /etc/profile.d/*sh
This page took 0.099507 seconds and 4 git commands to generate.