]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- rel 2
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        1.2.3
6 Release:        2
7 License:        GPL
8 URL:            http://distcc.samba.org
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 Source1:        %{name}.inetd
11 Source2:        %{name}.sh
12 Source3:        %{name}.csh
13 Patch0:         %{name}-user.patch
14 Requires:       gcc
15 Requires:       gcc-c++
16 Requires:       inetdaemon
17 BuildRequires:  popt-devel
18 Prereq:         /sbin/chkconfig
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 distcc is a program to distribute compilation of C or C++ code across
23 several machines on a network. distcc should always generate the same
24 results as a local compile, is simple to install and use, and is often
25 two or more times faster than a local compile.
26
27 %description -l pl
28 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
29 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
30 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
31 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
32
33 %prep
34 %setup -q
35
36 %patch -p1
37
38 %build
39 %configure
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
45            $RPM_BUILD_ROOT/etc/profile.d
46
47 %{makeinstall}
48 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
49 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT/etc/profile.d
50
51 %post
52 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
53 if [ -f /var/lock/subsys/rc-inetd ]; then
54         /etc/rc.d/init.d/rc-inetd reload 1>&2
55 else
56         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
57 fi
58
59 %postun
60 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
61 if [ -f /var/lock/subsys/rc-inetd ]; then
62         /etc/rc.d/init.d/rc-inetd reload
63 fi
64
65 %clean
66 rm -rf ${RPM_BUILD_ROOT}
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS NEWS README linuxdoc/html/*
71 %attr(755,root,root) %{_bindir}/*
72 %attr(644,root,root) %{_mandir}/man?/*
73 %attr(640,root,root) /etc/sysconfig/rc-inetd/distccd
74 %attr(644,root,root) /etc/profile.d/*sh
75 %{_infodir}/distcc*
This page took 0.088111 seconds and 4 git commands to generate.