]> git.pld-linux.org Git - packages/dictd.git/blob - dictd.spec
- ac stuff
[packages/dictd.git] / dictd.spec
1 Summary:        Dictionary database server
2 Summary(pl):    Serwer bazy s³owników
3 Name:           dictd
4 Version:        1.5.5
5 Release:        2
6 License:        GPL
7 Group:          Daemons
8 Group(de):      Server
9 Group(pl):      Serwery
10 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.sysconfig
13 URL:            http://www.dict.org/
14 Requires:       /bin/cat
15 Requires:       /bin/ls
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description 
19 Server for the Dictionary Server Protocol (DICT), a TCP transaction
20 based query/response protocol that allows a client to access
21 dictionary definitions from a set of natural language dictionary
22 databases.
23
24 %description -l pl
25 Serwer dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
26 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
27 definicji s³ownikowych z zestawu baz danych.
28
29 %package -n dict
30 Summary:        DICT Protocol Client
31 Summary(pl):    Klient protoko³u DICT
32 Group:          Applications/Networking
33 Group(de):      Applikationen/Netzwerkwesen
34 Group(pl):      Aplikacje/Sieciowe
35
36 %description -n dict
37 Client for the Dictionary Server Protocol (DICT), a TCP transaction
38 based query/response protocol that provides access to dictionary
39 definitions from a set of natural language dictionary databases.
40
41 %description -n dict -l pl
42 Klient dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
43 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
44 definicji s³ownikowych z zestawu baz danych.
45
46 %package -n dictzip
47 Summary:        Compress (or expand) files, allowing random access
48 Group:          Applications/Archiving
49 Group(de):      Applikationen/Archivierung
50 Group(pl):      Aplikacje/Archiwizacja
51
52 %description -n dictzip
53 dictzip compresses files using the gzip(1) algorithm (LZ77) in a
54 manner which is completely compatible with the gzip file format. An
55 extension to the gzip file format (Extra Field, described in 2.3.1.1
56 of RFC 1952) allows extra data to be stored in the header of a
57 compressed file. Dictd, the DICT protocol dictionary server will make
58 use of this data to perform pseudo-random access on the file.
59
60 %description -n dictzip -l pl
61 dictzip kompresuje pliki ko¿ystaj±c z zawartego w gzip(1) algorytmu
62 (LZ77) który jest ca³kowicie kompatybilny z formatem plików gzip.
63 Rozszerzenie do formatu plików gzip(pole dodatkowe, opisane w 2.3.1.1
64 RFC 1952) pozwalaj±cego na dodatkowe dane zapisane w nag³ówku
65 skompresowanego pliku. Dictd, serwer protoko³u DICT wykorzystuje te
66 dane do pseudo-losowego dostêpu do pliku.
67
68 %prep
69 %setup -q
70
71 %build
72 # --without-local-zlib option gives no effect. Usage of zlib from dictd tarball 
73 # is hardcoded in configure. 
74
75 aclocal
76 autoconf
77 (cd libmaa; aclocal; autoconf)
78 %configure \
79         --with-local-zlib=no
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{rc.d/init.d,sysconfig,%{name}},%{_bindir},%{_sbindir}} \
85            $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_mandir}/man{1,8}}
86
87 install dict dictzip $RPM_BUILD_ROOT/%{_bindir}
88 install {dict,dictzip}.1 $RPM_BUILD_ROOT/%{_mandir}/man1
89
90 install %{name} $RPM_BUILD_ROOT/%{_sbindir}
91 install %{name}.8 $RPM_BUILD_ROOT/%{_mandir}/man8
92
93 echo "server localhost" > dict.conf
94 echo -e "access {\n\tallow localhost\n\tdeny *\n}\n" > %{name}-main.conf 
95
96 install dict.conf $RPM_BUILD_ROOT%{_sysconfdir}/
97 install dictd-main.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/
98 touch %{buildroot}%{_sysconfdir}/%{name}.conf
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
100 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
101
102 mv -f doc/security.doc security.txt
103 gzip -9nf {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post
109 /sbin/chkconfig --add %{name}
110 if [ -f /var/lock/subsystem/%{name} ]; then
111         /etc/rc.d/init.d/%{name} restart >&2
112 else
113         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
114 fi
115     
116 %preun
117 if [ $1 = 0 ]; then
118         /sbin/chkconfig --del %{name}
119         /etc/rc.d/init.d/%{name} stop >&2 || true
120 fi
121
122 %files
123 %defattr(644,root,root,755)
124 %ghost %{_sysconfdir}/%{name}.conf
125 %attr(755,root,root) %{_sbindir}/%{name}
126 %attr(754,root,root) /etc/rc.d/init.d/%{name}
127 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sysconfig/%{name}
128 %dir %{_datadir}/%{name}
129 %dir %{_sysconfdir}/%{name}
130 %{_sysconfdir}/%{name}/%{name}-main.conf
131 %{_mandir}/man8/%{name}*
132 %doc {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}.gz
133
134 %files -n dict
135 %defattr(644,root,root,755)
136 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dict.conf
137 %attr(755,root,root) %{_bindir}/dict
138 %{_mandir}/man1/dict.1*
139
140 %files -n dictzip
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/dictzip
143 %{_mandir}/man1/dictzip.1*
This page took 0.079066 seconds and 4 git commands to generate.