]> git.pld-linux.org Git - packages/dictd.git/blob - dictd.spec
- removed requires: /bin/cat /bin/ls
[packages/dictd.git] / dictd.spec
1 Summary:        Dictionary database server
2 Summary(pl):    Serwer bazy s³owników
3 Name:           dictd
4 Version:        1.5.5
5 Release:        3
6 License:        GPL
7 Group:          Daemons
8 Group(de):      Server
9 Group(pl):      Serwery
10 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.sysconfig
13 URL:            http://www.dict.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  flex
17 Prereq:         /sbin/chkconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description 
21 Server for the Dictionary Server Protocol (DICT), a TCP transaction
22 based query/response protocol that allows a client to access
23 dictionary definitions from a set of natural language dictionary
24 databases.
25
26 %description -l pl
27 Serwer dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
28 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
29 definicji s³ownikowych z zestawu baz danych.
30
31 %package -n dict
32 Summary:        DICT Protocol Client
33 Summary(pl):    Klient protoko³u DICT
34 Group:          Applications/Networking
35 Group(de):      Applikationen/Netzwerkwesen
36 Group(pl):      Aplikacje/Sieciowe
37
38 %description -n dict
39 Client for the Dictionary Server Protocol (DICT), a TCP transaction
40 based query/response protocol that provides access to dictionary
41 definitions from a set of natural language dictionary databases.
42
43 %description -n dict -l pl
44 Klient dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
45 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
46 definicji s³ownikowych z zestawu baz danych.
47
48 %package -n dictzip
49 Summary:        Compress (or expand) files, allowing random access
50 Summary(pl):    Kompresja (i dekompresja) plików pozwalaj±ca na swobodny dostêp
51 Group:          Applications/Archiving
52 Group(de):      Applikationen/Archivierung
53 Group(pl):      Aplikacje/Archiwizacja
54
55 %description -n dictzip
56 dictzip compresses files using the gzip(1) algorithm (LZ77) in a
57 manner which is completely compatible with the gzip file format. An
58 extension to the gzip file format (Extra Field, described in 2.3.1.1
59 of RFC 1952) allows extra data to be stored in the header of a
60 compressed file. Dictd, the DICT protocol dictionary server will make
61 use of this data to perform pseudo-random access on the file.
62
63 %description -n dictzip -l pl
64 dictzip kompresuje pliki korzystaj±c z zawartego w gzip(1) algorytmu
65 (LZ77) który jest ca³kowicie kompatybilny z formatem plików gzip.
66 Rozszerzenie do formatu plików gzip (pole dodatkowe, opisane w 2.3.1.1
67 RFC 1952) pozwalaj±cego na dodatkowe dane zapisane w nag³ówku
68 skompresowanego pliku. Dictd, serwer protoko³u DICT wykorzystuje te
69 dane do pseudo-swobodnego dostêpu do pliku.
70
71 %prep
72 %setup -q
73
74 %build
75 # --without-local-zlib option gives no effect. Usage of zlib from dictd tarball 
76 # is hardcoded in configure. 
77
78 aclocal
79 autoconf
80 (cd libmaa; aclocal; autoconf)
81 %configure \
82         --with-local-zlib=no
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{rc.d/init.d,sysconfig,%{name}},%{_bindir},%{_sbindir}} \
88            $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_mandir}/man{1,8}}
89
90 install dict dictzip $RPM_BUILD_ROOT/%{_bindir}
91 install {dict,dictzip}.1 $RPM_BUILD_ROOT/%{_mandir}/man1
92
93 install %{name} $RPM_BUILD_ROOT/%{_sbindir}
94 install %{name}.8 $RPM_BUILD_ROOT/%{_mandir}/man8
95
96 echo "server localhost" > dict.conf
97 echo -e "access {\n\tallow localhost\n\tdeny *\n}\n" > %{name}-main.conf 
98
99 install dict.conf $RPM_BUILD_ROOT%{_sysconfdir}/
100 install dictd-main.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/
101 touch %{buildroot}%{_sysconfdir}/%{name}.conf
102 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
103 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
104
105 mv -f doc/security.doc security.txt
106 gzip -9nf {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 /sbin/chkconfig --add %{name}
113 if [ -f /var/lock/subsystem/%{name} ]; then
114         /etc/rc.d/init.d/%{name} restart >&2
115 else
116         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
117 fi
118     
119 %preun
120 if [ "$1" = "0" ]; then
121         /sbin/chkconfig --del %{name}
122         /etc/rc.d/init.d/%{name} stop >&2 || true
123 fi
124
125 %files
126 %defattr(644,root,root,755)
127 %ghost %{_sysconfdir}/%{name}.conf
128 %attr(755,root,root) %{_sbindir}/%{name}
129 %attr(754,root,root) /etc/rc.d/init.d/%{name}
130 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sysconfig/%{name}
131 %dir %{_datadir}/%{name}
132 %dir %{_sysconfdir}/%{name}
133 %{_sysconfdir}/%{name}/%{name}-main.conf
134 %{_mandir}/man8/%{name}*
135 %doc {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}.gz
136
137 %files -n dict
138 %defattr(644,root,root,755)
139 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dict.conf
140 %attr(755,root,root) %{_bindir}/dict
141 %{_mandir}/man1/dict.1*
142
143 %files -n dictzip
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/dictzip
146 %{_mandir}/man1/dictzip.1*
This page took 0.066328 seconds and 4 git commands to generate.