]> git.pld-linux.org Git - packages/dictd.git/blob - dictd.spec
6cc38698ae78bcb5ba721aafe3d794dc5e1f7df4
[packages/dictd.git] / dictd.spec
1 Summary:        Dictionary database server
2 Summary(pl):    Serwer bazy s³owników
3 Name:           dictd
4 Version:        1.5.5
5 Release:        2
6 License:        GPL
7 Group:          Daemons
8 Group(de):      Server
9 Group(pl):      Serwery
10 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.sysconfig
13 URL:            http://www.dict.org/
14 Requires:       /bin/cat
15 Requires:       /bin/ls
16 Prereq:         /sbin/chkconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description 
20 Server for the Dictionary Server Protocol (DICT), a TCP transaction
21 based query/response protocol that allows a client to access
22 dictionary definitions from a set of natural language dictionary
23 databases.
24
25 %description -l pl
26 Serwer dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
27 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
28 definicji s³ownikowych z zestawu baz danych.
29
30 %package -n dict
31 Summary:        DICT Protocol Client
32 Summary(pl):    Klient protoko³u DICT
33 Group:          Applications/Networking
34 Group(de):      Applikationen/Netzwerkwesen
35 Group(pl):      Aplikacje/Sieciowe
36
37 %description -n dict
38 Client for the Dictionary Server Protocol (DICT), a TCP transaction
39 based query/response protocol that provides access to dictionary
40 definitions from a set of natural language dictionary databases.
41
42 %description -n dict -l pl
43 Klient dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
44 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
45 definicji s³ownikowych z zestawu baz danych.
46
47 %package -n dictzip
48 Summary:        Compress (or expand) files, allowing random access
49 Summary(pl):    Kompresja (i dekompresja) plików pozwalaj±ca na swobodny dostêp
50 Group:          Applications/Archiving
51 Group(de):      Applikationen/Archivierung
52 Group(pl):      Aplikacje/Archiwizacja
53
54 %description -n dictzip
55 dictzip compresses files using the gzip(1) algorithm (LZ77) in a
56 manner which is completely compatible with the gzip file format. An
57 extension to the gzip file format (Extra Field, described in 2.3.1.1
58 of RFC 1952) allows extra data to be stored in the header of a
59 compressed file. Dictd, the DICT protocol dictionary server will make
60 use of this data to perform pseudo-random access on the file.
61
62 %description -n dictzip -l pl
63 dictzip kompresuje pliki korzystaj±c z zawartego w gzip(1) algorytmu
64 (LZ77) który jest ca³kowicie kompatybilny z formatem plików gzip.
65 Rozszerzenie do formatu plików gzip (pole dodatkowe, opisane w 2.3.1.1
66 RFC 1952) pozwalaj±cego na dodatkowe dane zapisane w nag³ówku
67 skompresowanego pliku. Dictd, serwer protoko³u DICT wykorzystuje te
68 dane do pseudo-swobodnego dostêpu do pliku.
69
70 %prep
71 %setup -q
72
73 %build
74 # --without-local-zlib option gives no effect. Usage of zlib from dictd tarball 
75 # is hardcoded in configure. 
76
77 aclocal
78 autoconf
79 (cd libmaa; aclocal; autoconf)
80 %configure \
81         --with-local-zlib=no
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{rc.d/init.d,sysconfig,%{name}},%{_bindir},%{_sbindir}} \
87            $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_mandir}/man{1,8}}
88
89 install dict dictzip $RPM_BUILD_ROOT/%{_bindir}
90 install {dict,dictzip}.1 $RPM_BUILD_ROOT/%{_mandir}/man1
91
92 install %{name} $RPM_BUILD_ROOT/%{_sbindir}
93 install %{name}.8 $RPM_BUILD_ROOT/%{_mandir}/man8
94
95 echo "server localhost" > dict.conf
96 echo -e "access {\n\tallow localhost\n\tdeny *\n}\n" > %{name}-main.conf 
97
98 install dict.conf $RPM_BUILD_ROOT%{_sysconfdir}/
99 install dictd-main.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/
100 touch %{buildroot}%{_sysconfdir}/%{name}.conf
101 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
102 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
103
104 mv -f doc/security.doc security.txt
105 gzip -9nf {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 /sbin/chkconfig --add %{name}
112 if [ -f /var/lock/subsystem/%{name} ]; then
113         /etc/rc.d/init.d/%{name} restart >&2
114 else
115         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
116 fi
117     
118 %preun
119 if [ "$1" = "0" ]; then
120         /sbin/chkconfig --del %{name}
121         /etc/rc.d/init.d/%{name} stop >&2 || true
122 fi
123
124 %files
125 %defattr(644,root,root,755)
126 %ghost %{_sysconfdir}/%{name}.conf
127 %attr(755,root,root) %{_sbindir}/%{name}
128 %attr(754,root,root) /etc/rc.d/init.d/%{name}
129 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sysconfig/%{name}
130 %dir %{_datadir}/%{name}
131 %dir %{_sysconfdir}/%{name}
132 %{_sysconfdir}/%{name}/%{name}-main.conf
133 %{_mandir}/man8/%{name}*
134 %doc {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}.gz
135
136 %files -n dict
137 %defattr(644,root,root,755)
138 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dict.conf
139 %attr(755,root,root) %{_bindir}/dict
140 %{_mandir}/man1/dict.1*
141
142 %files -n dictzip
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/dictzip
145 %{_mandir}/man1/dictzip.1*
This page took 0.068168 seconds and 3 git commands to generate.